PL6.10.0 maxing out the processor on Win 10 when working on an image


@DxO_Support-Team while testing some ‘Partial Presets’ on Win 10 the processor started to max out

Since my original post I have worked on an additional image and PL6 appears to behave itself .

Returning the the problem image again today I wrote this in a post in another topic

@kal I have submitted a support request and will keep you informed

If you have any further insight into when the problem occurs then post it here.

I have referenced this topic in my support submission and it might provide useful addition information.

Thanks! I hope everything will be sorted out.

@kal so do I it is really playing havoc albeit mostly with one image although I think that things deteriorate with other images but not immediately! I was about to create a topic yesterday but everything seemed to work O.K. but tests later on started the processor peaking at 100% and staying there for some seconds and then doing it again every time I touched the thumbnail or moved on to one of the VCs!

Can you please provide a few details of when your machine misbehaves, e.g. all the time, one directory, one image etc.?


I’ve been experiencing something the same or similar.

I upgraded to PL 6.10 when alerted to a new update on 27th Sep, and have been away from 3rd-10th October. I’ve just started processing the images from my holiday and run into the same issue of the CPU maxing out at 100% for around 10s each time I select a different image from the filmstrip in Customise mode. I then tried an export of one image which took 79s (DeepPrime noise reduction) compared to the ususal circa 30s. I could see the graphics card wasn’t being used during the export and the CPU was maxing out at 100%.

Although my graphics card is old and slow, and only marked as “partially supported” (NVIDIA GeForce 750 Ti) I wasn’t having this problem with PL 6.9 or any earlier versions of PL. I’ve also been using the EA versions of PL7 without any problem.

I’ve now just uninstalled PL 6.10 and reinstalled PL6.9. The same image now exports in circa 30s as before, and I’m not getting the CPU maxing out as I move between images. So it looks like the issue was introduced in the upgrade from 6.9 to 6.10.

I’ll raise a support ticket, and mention yours, and provde any response / update here.

1 Like

Support ticket raised

Hello Paul,

Thank you for contacting DxO Customer Support.

Your request #440051 has been received and is being looked at by our support staff.

To add additional comments, simply respond to this email or follow this link :

Thank you for your patience have a great day !

@SAFC01 Paul thanks for adding your comments and putting in a support request.

Any and everyone who experiences any changes in behaviour in the following situations

  1. Massive processor surges when just browsing images

  2. Big increases in export times which look as if DxPL has decided not to use the graphics card and has “internally” defaulted to CPU only processing with little/no GPU involvement

should put in a Support request.

Flagging in the forum is useful to other forum members but DxO have made it clear that we are supposed to use the correct support channels so we should do just that!

You have a worse variant than in my case!!


  1. I have the massive processor load (effectively a system “Panic”) when I specifically select CPU only and start browsing certain images. If I try to export one of those images then the problem is even worse because of the protracted length of the export and the machine is unusable during most of the export!

  2. But my export times have remained O.K even on my slower GPUs, so I have I 1050, 1050Ti and an RTX 3060 but others have experienced long export times on cards similar to the 1050Ti (similar in that they are on a laptop not a desktop, at least in some cases). In those cases DxPL shows the cards and shows them selected appropriately but then seems to ignore the GPU when doing the export!

It does in did!

1 Like

Well I’ve just finished working though 400 RAW images and then exporting them as JPEGs using PL 6.9 without any of the CPU maxing out performance issues I was having with PL 6.10, and the export times were what I’ve been used to. So for me it;s further confirmation that there’s a problem that’s been introduced in the development of 6.10.

1 Like

@SAFC01 I am glad you have a workable system, even if it meant going back to an earlier release. Hopefully that one can be identified and fixed.

My case was not a problem I typically encounter, it happened when browsing a particular image and its 4 VCs but with DeepPrime acceleration set to ‘CPU only’ and the image had DP XD set.

I just tried it on the 5600G with the 3060 card and the problem is present on the PL6.7 release. Because the machine has a processor roughly twice as powerful as the i7 it can cope somewhat better but this is what Process Lasso was showing

Please remember this is PL6.7 and just browsing the image with DP XD selected and 'DeepPRIME acceleration = ‘Use CPU only’!!

Hopefully no-one is experiencing that particular issue and I would suspect no-one is because the settings I was using are just weird, but then so is the problem!!

Nothing that signifcant to report other than I’ve had an initial response from DxO support asking me copy a file to the PL logs folder (which presumably triggers a more detailed log to be written), install the latest version of PL6 (i.e. 6.10 Build 284), use PL to trigger the problem, and then send a couple of the logs files.

With PL6.10 the CPU utilisation hit 100% each time I selected a different image in the filmstrip in PhotoLIbary (never going into Customise mode at all), and an export also took longer than usual. As soon as I reverted to PL6.9 the problem disapperared.

@SAFC01 So the same problem as mine except that taking my image to another machine (actually accessing the same image via the LAN) with PL6.7 the problem was still present but in your case PL6.9 appears not to have the same issue

You are correct that the file you were asked to copy triggers specific logging to help diagnose the problem.

see also → Exporting to disk takes extremely long with DeepPRIME XD - #44 by Barbara-S

@Wolfgang Thank for the “heads-up” I had seen that already, however, while I believe that the problems may be related to the two active topics

to name but two!?

This is slightly different and DxO have support requests from both of us, plus additional trace details in the logs!

One issue is that with my image I had problems with PL6.7 but for @SAFC01 “just” going back to PL6,9 fixed the problem!?

I don’t like “weird” differences like that @Barbara-S.


This looks like it might be a valid explanation of my problems with PL6.10, although it suggests the issue was first introduced in 6.9, whereas I’ve found 6.9 Build 267 works fine The description of the symptoms seems to match my experiences pretty closely.

@SAFC01 Paul it may be the reason for the many instances where the product seems to have reverted to the CPU and ignored the GPU, however my personal testing of exports, excluding my “rogue” image, all worked fine and they were on 1050 (2GB), 1050Ti(4GB) and RTX 3060(12GB).

My GTX1050 is particularly small with only 2GB of memory and yet the timings on that system, a near identical system to the GTX1050Ti(4GB) with the same CPU (i7-4790K), the same memory 24GB, similar SSD boot drives etc. etc. but different motherboard manufacturers and different graphics cards were a bit slower (1050 versus 1050Ti) but inline with expectations!

However, it certainly looks like the culprit or a culprit for many. It would be a culprit for mine only if the attempted allocation of GPU memory occurs early in the process, plus I believe I saw the exact same problem on my Ryzen 5600G with the RTX 3060 on PL6.7!?

Excluding that image I mostly escape unscathed but if it fixes your problem and the exporting problem of other users then that would be a very good thing!


As discussed in the thread below, the hotfix seems to correct my problem.,Cecile%2C,Paul,-Reply

1 Like

@SAFC01 Paul I am glad it has fixed your problem and I believe that it will fix the problems of a number of other users who have been experiencing export issues, which is excellent @Cecile-C.

However, my “rogue” image is still a problem

Twin peaks one for the [M]aster and one for VC[1] and a processor fan going like it was trying to take off, all my machines run with there left (as I face them) side off!

So the good news is that a number of users have found new life in DxPL, with their existing systems, the bad news is that I have an image and/or a selection of edits that cause problems on my machines!?



PS:- a reminder, green curve is processor utilisation and red is system responsiveness.


Are you saying, that this problem only occurs on a single image and that it is not repeatable with other images? If that is correct, have you shared this image with anyone else to see whether they’re having the same problem with it?


1 Like

@mwsilvers I have shared it with DxO support who cannot reproduce my problem but managed to produce another problem when they applied additional edits!?

This image currently causes problems of varying degrees on PL6.7, PL6.10.1, PL7.0.2 BUT in an atypical situation which I discovered by accident when trying to determine how long exports take with only the CPU selected for Noise Reduction.

It occurred while the various PL6.10 export issues were being reported which I could not reproduce on my three machines and the I set the 'DeepPRIME acceleration to ‘CPU only’ but had DP XD selected for the images.

This is PL6.10.1 just browsing each copy in turn and the graphs peaks look short in duration because Process Lasso stalled completely on each of the 5 copies!

This is 7.0.2 just browsing the [M]aster image and it did not seem to stall completely at any point

This is the image and DOP

P1102011.xmp (935 Bytes)
P1102011.RW2.dop (50.6 KB)
P1102011.RW2 (23.1 MB)

I will take a look at it myself, if you don’t mind. Is it possible that there is a corruption in the raw file or one of the sidecar files? It’s interesting that you are only having problems with this specific file. That’s happened to me one time in the past and had never occurred before or since. I don’t worry very much about one-off problems like that. Life is too short.