Issues with Nik4

I have the same issue when I open the new versions of Viveza or Silver Efex in Lightroom or as standalone. Moreover, Photoshop won’t open any picture file since I installed NIK Collection 4. If I delete NIK then Photoshop works again. If I then reinstall NIK, then the same problem appear. I’m on Macbook Pro 15-2018 with Big Sur and Photoshop 22.4.1.

Good Morning Les:

It’s whether I use it in photoshop or as a standalone. It worked for 5 minutes yesterday then when I tried to get back in it wouldn’t open. I tried uninstall and reinstall.

1 Like

Please, always post which system you are using. For me on macOS Catalina 10.15.7 with latest version of PhotoLab 4.3 no issues with the new Nik Collection 4, standalone and integration PL4.3. Btw. just bought this upgrade to support DXO. Don’t use it that much. Prefer editing as long as possible the RAW file.

1 Like

PC - win10 - the latest versions of both windows pro (19042.985) and adobe photoshop (22.4.1). intel core i9 - 9900 CPU, ram 32 GB Nik 4viviveza and silver efex go white screen in stand alone, lightroom classic, and photoshop.

Latest IOS - BigSur 11.4,
Load RAW from LR (10.2) to PS (22.4.1).
Duplicate layer
From Filter Menu to SEP > Loads the SEP window UNDER the PS image which has the beachball…

no difference if loading as smart object or as image layer.

Yesterday, I got the new Nik 4.0.7 version and – as ‘promised’ – it deleted the previous Nik 3.3 version.

As I need the latest Nik 3.3 for my old PS ( optionally running with the first generation Selective Tool )
I tried a lot of back and forth …

The easiest way I found is to install Nik 4 as ‘recommended’ (no change in installation path), which erases all former Nik version. Then after I installed Nik 3 (= in the same path), which (also) re-adds the replaced Viveza 2 and Silver Efex Pro 2 programs. – Now, the ‘old’ plugins for PS and Affinity work again and PL4, when exporting to Nik Collection, shows …
Screen Shot 06-03-21 at 04.40 PM

I’m glad it was possible that way, otherwise I would have dumped Nik 4.



macOS 11.4:

The Nik4 versions of Viveza and Silver Efex Pro will not run correctly as plugins in Affinity Photo nor PhotoLine. When running in either of these hosts, the plugin shows no “OK” button to return results to the host. File->Save produces a “processing” message on the screen that hangs. The other plugins in the suite run correctly as did the Nik3 collection.

No problem running as standalones or launching from PhotoLab 4.

(I have filed a trouble report with support.)

1 Like

I am using Mac mini M1 with Big Sur 11.4 and have not encountered that problem. When I am done with met edit in Silver Efex Pro 3 (version 4) I click the “Apply” button in the bottom right-hand corner of the screen and the edited photo is returned to Affinity Photo.

The same hold true for Viveza 3 (version 4). I just tested both again successfully. Don’t know if that helps your situation but it at least shows that both work being called from Affinity Photo.

The install procedures have changed from versions 2.5 and 3. I had self-inflicted problems because I followed those steps. However, once I read the install procedures for using with Affinity Photo everything has worked fine. Here is the link to the install page in the user guide for version 4. Just scroll down some and you’ll see the Affinity Photo section:


Unfortunately, I do not have an “Apply” button. There is a button in the lower right corner, but it is to save a customized plugin.

Wow, that is surely a bug of some sort. Glad you filed a report with support. Those folks are very good at getting to the bottom of things. They have helped me several times.

Bob, I opened up Silver Efex Pro 4 (version 4) and tried to see if there were some way I could hide the bottom bar but found no settings or adjustments that would cause the bottom bar to be hidden. If I do stumble across something in my using it I’ll certainly post. Would be interested in what sequence of events would cause that to happen.


@OldRadioGuy, I’ve had the missing buttons too and they reappeared when I changed the app window size - including maximize/minimize/full screen - a few times.

After that, the issue did not reappear.

Just for info

On windows with PL4, Nik 3 started installation of NIK 4
deinstallation of Nik 3 as announced
after installation restart
selecting Nik Collection from PL4 interface said no Nik Installation
Windows App interface shows Nik 4 installation with actual installation date
starting installation again…message this version is still installed (no repair or deinstallation option)
Deinstallation from App interface…succesfully
starting installation again… successful
selecting Nik Collection from PL4 interface…works

but the new Silver efex is great.

would not install to my productive system…waiting for the bugfixes :innocent:

I am having an issue where Viveza and SilverFx will not start in stand alone mode. I use Capture One on my M1 Mac so I need to export a TIFF for use in Nik Collection. I do that, but after making edits in Viveza or SilverFx, the updates don’t show up in a file. I suspect since I only have an “Apply” button and not a “Save” button that I am not in stand alone mode. I also do not have a “File” drop down on the menu bar. I’ve submitted a ticket for this issue.

1 Like

Bob, this morning I ran Silver Efex Pro 4 (version 4) in standalone mode on the Mac mini M1 and saw that the bottom bar with the “Apply” button was not visible. I was able to save my changes by using the File–>Save menu option. I know this doesn’t solve the problem because there is no File–>Save menu option when starting Silver Efex Pro 4 from Affinity Photo. However, until customer support gets back to you with a fix you might be able to use Silver Efex Pro 4 by starting it up standalone and dragging and dropping a .tif file to it and use the File–>Save menu option to save your work. Hope that helps some.


Silver Effects loads from DXO 4 then stops with ‘Image format or size not supported by Nik Collection’?!?!? Well it did with the old version this morning! Stand alone version seems to work OK.

Win10, Ryzen 3900X, 16G, GeForce 1660Ti 6G.

I am using NIK 4 with Affinity photo on win 10 Pro as well as DXO PL4. No issues. I am using a Beta version of Photo as it has issues with Z6 RAW.


try with uninstall and re-install – I had the same and it disappeared :slight_smile:

@Wolfgang Thanks for that, I had done several uninstalls but using an uninstal file in 'Programs/DXO/Nik Collection/… which I think may have been a left over from a previous installation(?)… Did a ‘proper’ uninstall via ‘Settings/Apps’ and it seems to have done the trick. :hugs: Now I just need to find out why Color Efex crashes with more than one image loaded whilst swapping recipes?! :thinking:

Following your directions, I was able to uninstall Nik Collection 4. Fortunately I found a copy of Nik_Collection_3_by DxO.exe in my Downloads folder and installed Nik Collection 3. I was able to take an image from LR to PS 2021 and choose Silver Efex Pro 2. The image opened… Yay!!! DoX asked if I wanted to update (to Silver Efex Pro 3). At this point I declined. I have already paid for Silver Efex Pro 3 and Viveza 3, but I think that I will wait awhile before I take the upgrade. Wolfgang, you are my hero today!!! Many thanks for your help!!!

Tech support finally contacted me today. I provided them with tons of info and screen videos of me trying to open the apps - hopefully, something good comes of it. I am still a little bothered this is more a 25 % upgrade.

1 Like