FilmPack in Affinity Photo 2.x

Affinity Photo 2.2.0 works with FilmPack 5

but not with FilmPack 6 and 7

  • neither with copying the complete FilmPack folder to Affinity’s Standard Plugins folder
    nor from the folder where to search for (Order für Plugin-Suche)

( the shown Nik Collection folder refers to version 5 and older … )


Affinity 2.2.0 works with FP6 for me on Windows I’ve just opened a JPG and then selected the FP6 plug-in (something I rarely, if ever, do) and this opens fine - and I can confirm it’s definitely FP6 that’s open. My plug-ins are all in the default folder as my settings show.

I notice in your settings you have a default folder, plus two others. Would it work if you added one pointing to FP6, assuming the plug-in is there. I must say, I can’t remember when or how I got these plug-ins installed - specifically whether it was during the installation of AF 2.2.0 or FP6 that I placed the plug-ins in the default folder. I suspect the latter but can’t be sure.

Hi Paul,
I tried again, but unfortunately no success …

  • copied the complete folder of FP6 and 7 into the Affinity Plugin folder
    to then show up like this

    but neither FP6 nor 7 work
    (well the Plugin Start Window appears … but nothing more happens, something is hindering)

  • added the FP6 and 7 locations to AP’s “search” folder

    and AP’s Filter menu shows
    Screen Shot 10-03-23 at 12.35 PM
    FP5 works, but neither FP6 nor 7
    (again: the Plugin Start Window appears … but nothing more happens)


Before I had copied the complete Nik Collection folder into the Affinity Plugin folder to make it work,
while now it was sufficient to add the NC’s location to AP’s “search” folder.
and AP’s Filter menu shows
Screen Shot 10-03-23 at 12.34 PM
(they all work with the -known- exception for Perspective Efex)

obviously you’re on Windows, where to find the .config on MAC to add filmpack to AP?
i had a file with all shortcup for PL3 on MAC but i’m sure it changed since.

I’m trying to run the free trial of FP 6. Everything is there, I get the notice its running FP 6, and the FP Trial notice comes up but after that nothing appears. Not inclined to buy it until I know it runs with Affinity Photo. Runs OK as stand alone. Windows 11.

FYI Richard; Even when you’re running FP “with Affinity” - all that’s really happening is that TIFF files are being passed between the 2 apps - the auto-interface is just a convenience … you can readily do this manually.

For example; I use the NIK tools with PhotoLab - but I don’t bother with the convenient interface between those 2 apps - - I manage that process myself.


I’m having the exact same problem. Whatever I do, I cannot get FP7 to start from Affinity Photo.

1 Like

I found FP was not working in Affinity Photo since the last update to FP6. I believe I looked at the manual online when FP7 was released and found no reference to Affinity Photo. I suspected they were dropping support for Affinity Photo so I didn’t upgrade. I am on Mac mini M1.

Affinity use PS plugins, so why not work? Does they work in PS?

I’m on an old PS version, which only accepts FP5

( and Nik 3.3 → Issues with Nik4 - #8 by Wolfgang
but Nik 6 / Perspective Efex, while AP cannot handle the latter one :person_shrugging: )

Just returned to this issue. The following is on Windows 10.

  • I launched FP6 standalone where upon I was was prompted to update, which I did. My previous test at the beginning of October (see above) was with FP6.6.0 Build 1. The update is to FP6 6.15.0 Build 55 (I don’t usually use FP standalone which is why the standalone version is several updates behind the latest one).
  • Having installed the FP update I then repeated my previous test above with a JPEG image. This time although the message in Affinity Photo (AP) about “you are currently using DxO FilmPack 6…” appeared as before, nothing further happened- there was no transfer of the image to FP6.
  • I then reinstalled FP6.6.0 (ignoring the warning about installing an earlier version of FP). Having done this AP successfully opened the JPEG image in FP6.
  • I repeated the update of FP6 and tried the test again. Once again, with FP6.15.0 I couldn’t open the JPEG image in FP6 from AP.
  • Throughout the above I’d been using AP 2.2.0, ignoring the prompt to update, so I now updated AP to 2.2.1 and repeated the test with FP 6.15.0 with the same, unsuccessful result.

So, somewhere between FP6.6.0 and 6.15.0 (I don’t know how many, if any, other updates were available between these two versions) we seem to have lost the ability to open an image in FP6 from within AP.

I’ll file a fault report with DxO and update with any feedback / results.


Just submitted the following support request to DxO support.

I’ve just updated my standalone version of FP6 from FP 6.6.0 to FP 6.15.0, After doing this I can no longer launch FP6 from within Affinity Photo (2.2.1). If I reinstall FP6.6.0, which is the version I previously had installed, then I can launch FP6 from within AP. After reinstalling FP6 6.15.0 again I can’t launch FP6 from within AP.

With both FP 6.6.0 and 6.15.0, FP6 appears as a filter in AP under the menu item Filters > Plugins > DxO Labs > DxO Filmpack 6.

- With FP6 6.6.0 the message appears in AP about “you are currently using DxO FilmPack 6” for a short while, then disappears and FP6 opens with the image transferred to it.

- With FP^ 6.15.0 the message appears and then disappears, but nothing further happens.

Looking at the DxO user forums, it appears I am not the only person experiencing this issue, and the same issue is reported with FP7.


Looks like the last update of FP7 fixed the issues. At least I can now start FP from Affinity as a plugin.

did you updated AP to 2.2.1 they just released today?

Yes – and thank you for letting us know.
(checked with AP 1.10.5 and 2.2.1)

@mikerofoto → FP7.1.0

Can confirm the latest upgrade is working for me. AP 2.3.0.

1 Like

checked with AP 2.2.1 (Windows)

( AP 2.3 is the current Beta )

I’m glad it’s now working for you with FP7, but it’s a little strange given the response I had last night to my support request.


We have never supported DxO FilmPack as a plug-in with Affinity Photo, our apologies:

If it no longer works, you would need to contact Affinity Photo directly, as our developers do not support a workflow with Affinity as a plug-in.

The link takes you to a set of “what supports what” charts that make no mention of AP.

So, taken at face value, the response would suggest a) it’s just a lucky feature that some versions of FP work with AP and b) future updates / versions may not (since the ability has already been broken once).

@SAFC01 Thanks for the info. I was afraid that was the situation. In previous versions the online guide use to tell you how to use FP as AP plug-in. However, when the final update to version FP6 failed and I could not find any references to its use as an AP plug-in I was afraid that was what had happened. Too bad.

As long as AP is plugin compatible with PS I cannot see that there should be issues.