NIK 5 crashing Lightroom

I have used NIK since the early Google days and never has it been so unreliable and constantly crashing. I am a prom wedding photographer and use NIK (ColorEFEX 5 and others) as a part of my workflow from Nikon D850 in Lightroom CC and back. I used to be able to select 20+ images, export direct to NIK as TIFF’s (as recommended) and process each image as I wanted then apply all back to LR. No problems with NIK 4. Now NIK 5 is a disaster. Yesterday bit took half a day to do just 27 images. Constant crashing. Even with just one image at a time. Sometimes I get the red screen flash then NIK dies. Other time LR to NIK just hangs and freezes - left it for half and hour once and nothing. Often when returning from NIK to LR - LR becomes unresponsive and I have to force quit to get it back again. I am on MacBook Pro 15" 2018), 2.6 GHz 6-Core Intel Core i7, 32 GB 2400 MHz DDR4 Ram, Radeon Pro 560X 4GB, macOS Monterey 12.5.1. 1TB SSD with lots of room.

I completely uninstalled NIK as per your instructions online - using Uninstall program and then the Terminal code as well. I also manually removed anything DXO, NIK and even checked for old Google NIK as well. Reinstalled and same issues. Tried switching on and off the GPU accelerations in LR and NIK - no change in behaviour.

Optimised the LR catalogue, emptied LR cache, increased LR cache to 100gb - all no effect.

I can see from a quick online search that this seems to be a common problem - do you have a fix??


I have exactly the same issues and have a different thread (Nik 5 Collection and Lightroom not working whatsoever). No need to read it. Basically, I’ve tried the works, except that I cannot seem to get the terminal code program (Nik Cleanup tool) to run - I keep getting messages that I’m not authorised to run it.

Like you, I have a fairly high spec’d machine, space etc etc What annoys me is that Nik 4 worked perfectly even with massive files. I sent a video of what was happening to DXO and got a response that the files I was using were too big (that particular one was 22Mb and way smaller than many tiff files I had previously used in Nik 4. I’m kicking myself for upgrading to Nik 5 too quickly - LR and other plugins (Topaz) are working seamlessly.

1 Like

Slightly different but similar.
I recently updated Nik 5 to version 5.1 and since then it’s been crashing on my Mac. The problems plugins seem to be the ones that share the new interface (Viveza, Silver Efex Pro, Color Efex and Analog Efex). I can also case the crash by using any of the slider controls and dragging slowly or moving the slider left and right repeatedly as if you would when trying to refine an adjustment.
Currently I’ve only experienced this when running the plugins in Photoshop but will try Lightroom when I have chance. Looks like a bug related to the interface controls.


Did anyone reading this case ever granted full hard disk access for all the Nik plugins on newer Mac OS (Monterey) in the Mac system configuration?
I wonder whether this issue is caused by insufficent permissions.
I will test this a.s.a.p.!

I have the same problem with sliders in CEP and AEP is almost unusable now. Been asking Dxo to fix similar problems for 12 months now !

Same here regarding the new interface - I asked Nik for a link so I could go back to Nik 4. The plugins with the new interface still don’t work in Version 4 (although they worked prior to my upgrade to Version 5). The rest of the old style plugins work, but very slowly as compared to prior to the past!?

Are you on a Mac by any chance? The crashing seems to have become worse with the latest Mac OS update. I’ve also installed the plugins on an old Windows machine and they don’t crash.

Hello, again. I had responded to your original thread about problems with version 5, and have been reading all the others on here reporting variations of the same. I had been thinking about rolling back to version 4, but probably won’t now since that didn’t help you. Thanks for letting us know.

This is a long reply, but maybe DxO finds it useful – or if someone already has a case opened with them and my comments might be helpful, feel free to send them to their support team.

I’m on a Mac Mini M1 at Monterey 12.5.1, Lightroom and Nik Collection are both at current versions. With Nik Collection version 4, I could routinely process 10-15 files as a batch from Lightroom to Color Efex Pro 4 and not have any problems. I’m processing RAW files (so using “Edit in…” to create TIFFs for Color Efex to use), and my RAW files are between 30 and 85 megabytes depending on whether I used an APSC or full-frame lens to take photos. These are not unusual file sizes for a DSLR. For the scenarios I describe below, I used the same four RAW files, about 35 megabytes each.

So… in Lightroom, I select the four RAW files, choose “Edit in Color Efex Pro 5” then “Edit a Copy with Lightroom Adjustments” and four TIFF files are generated, Color Efex Pro 5 opens, and I apply filters to all four images. After I choose “Apply” and am returned to Lightroom, it takes 15-20 minutes for Lightroom to show the changes I’ve made, and during that time Lightroom is largely unresponsive until it’s done processing the images. Sometimes Lightroom never actually finishes processing and has to be forced to quit.

If, instead, I first create the TIFF files using Dfine 2 (so select the images, choose "Edit in Dfine 2 then “Edit a Copy with Lightroom Adjustments”), apply automatic noise reduction, then save the four images, the changes are reflected back in Lightroom immediately and Lightroom works fine. That’s not so surprising but this is:

If I then select those four TIFF files (created by launching Dfine 2) in Lightroom, choose “Edit in Color Efex Pro 5” then “Edit ORIGINAL”, apply some filters and save them – Lightroom shows the changes I’ve made almost immediately. I realize this may or may not work for others (sorry!), but that’s not really the point. The point is that, on my system anyway, Lightroom is handling the images correctly IF the TIFFs were created by Dfine 2 (which has not been updated to the newer interfaces and code), but NOT IF they were created by Color Efex Pro 5.

I also tried giving the Nik apps “full disk access” (as was mentioned in one of the replies here); using some much smaller JPG files instead of RAW files; optimizing Lightroom’s catalog; toggling the Lightroom and Color Efex graphics processor settings; and starting with a new Lightroom catalog with only the four images in it… with the same results.

I’ve tried these tests so many times, I’ve become convinced that there’s something wrong with the way Color Efex Pro 5 and all the plugins using the new interface/code are creating TIFF files such that Lightroom has trouble processing them. I’ve also tried using the plugins standalone (though you still have to use “Edit in…” to create the TIFF files) with the same results: if Dfine 2 creates the TIFF files, Lightroom works fine and reflects my changes almost immediately; if Color Efex Pro 5 creates the TIFF files, Lightroom chokes when processing the images. This may be further confirmed by what you said, that the new interface plugins don’t work well even in version 4. I had only used Color Efex Pro and Dfine 2 in version 4 so had not noticed that Analog Efex or Viveza were causing problems.

Hopefully DxO is working on these issues; for the first time in the five years I’ve been using Nik Collection, I’m considering abandoning it.


An update:

I don’t use Photoshop much, but I decided to try something based on my own comments that Color Efex PRO 5 was creating TIFF files that gave Lightroom fits. Here’s what I did:

I selected the same four RAW images I’d been using for testing, and chose “Edit in Adobe Photoshop 2022”.

In Photoshop, I didn’t make any changes, just selected “File/Close All” then chose “Save” for the images when prompted.

Photoshop created four new TIFF files in Lightroom, so I selected those four images, chose “Edit in Color Efex Pro 5” and “Edit Original”, applied some filters and saved my changes.

Back in Lightroom, the changes I made in Color Efex Pro 5 showed up immediately. This might be a usable workaround for some. It adds a couple of steps to the workflow but even with a larger batch (I tried ten TIFF files), Lightroom’s performance was acceptable.


I really want to be able to use Nik plugins but even rolling back to Nik 4 hasn’t solved the problem(s). I keep verging between abandoning Nik Collection and trying to get it working.

I don’t use PS much, but I am on Adobe’s photography plan so I have it. I think I might give your workaround a try i.e. creat new TIFFs in PS first - it’ll be a bit ‘painful’ but I can live with it if it works. I’ll let you know!

1 Like

Robin, yes, I’m on a Mac. At the time I upgraded to Nik 5, Nik 4.x was working perfectly and I changed nothing else (i.e. no change to MacOS/LR). As I said elsewhere stupid. stupid. stupid. If it ain’t broke don’t try to fix it. I’ve learn’t my lesson about upgrading too quickly.

From the outset I could not get firstly Nik 5.0 and then later Nik 5.1 to work no matter what I tried. It was a while back now, but I think between Nik Ver 5.0 and 5.1 then may have been a MacOS and LR upgrade !? Whatever, everything else is working ‘perfectly’ - LR, Topaz… I’m going to give DaleDucatte’s workaround a try - create TIFFs in PS first and see how that goes…

As mentioned in my previous comment, I further tested the behavior while having granted “full disk access” to all the Nik plugins. Unfortunately, this made no difference at all. The plugins are still crashing very frequent. So I added two more crash diagnosis reports to my open case at DXO. But there is no answer yet from their R&D (no surprise).
I also followed DaleDucatte’s workflow to first use DFine to create the TIFF. But unfortunately ran into a new problem, that DFine did not open my picture from the LR TIFF. To be able to open the file in DFine, I had to reduce the BitDepth form 16 to 8 Bit. Did anyone ever have seen this and have another recommendation on how to avoid it?
I have been using a very early version of NikCollections (especially SilverEfex) for a very long time without having any issues on an old Windows PC. Now since I moved forward to a brand new and powerful MacBook using the latest and greatest versions of software, the problems seem to become endless and NC are becoming really useless to me.

Dear Dale,

thanks for the work and the detailed test procedure.

That shows me again that it isn’t a good idea to be an early adaptor and if there are any doubt’s in the reliability of new version not to install on a production system.

best regards


Is your MacBook one with the M1 (or later) processor? if so, the Dfine 2 application needs to be set to “Open using Rosetta”. To do that, locate the Dfine 2 application with Finder, in the Nik Collections folder. Right-click on the application then select the checkbox “Open Using Rosetta” and try it again with 16-bit.


1 Like

By all means try the workaround but if your issue is similar to mine it probably won’t work. I’m using an older Intel based Mac and I’m suspicious the recent Mac OS upgrade may be the cause. True the problem occurs when using the Nik Plugins (or standalone) which have the new style interface, but I think this may be trigger an issue with the underlying Mac OS.

The reason that I’m suspicious about the Mac OS is that since upgrading my OS my Mac fan is on most of the time. This disk drive temperature is running high even when the Mac isn’t doing anything, which is odd behaviour. I get the spinning ball mouse pointer frequently with silly things like opening a folder in the finder window. I’ve also experienced quite a few (1-2 a day) crashes, which seems to be triggered by things that are demanding.

Thanks Dale! “Rosetta” fixed my issues with DFine.

Thanks for the kind words! Much appreciated!

Glad to hear it, thanks for letting me know.

P.S. If you use the two Sharpener Pro apps and experience the same problem, they may also need to be set to open with Rosetta.

1 Like

Yes, Robin, I probably should have clarified that I wasn’t addressing the Individual plugins crashing – which I have also occasionally experienced – but the performance problems and lockups that are occurring in Lightroom when returning from a plugin. Like you mentioned earlier, I can also crash Color Efex Pro with the sliders, or sometimes just by looking at the screen (lol).

I had excessive fan noise on my MacBook Air a few times after operating system upgrades. Depending on how recently you did that, (some people say) it happens because the Mac is reindexing files and folders to use with the Mac’s search capabilities. I never totally bought that, but I did successfully get the fan to run normally following these instructions from Apple support:

It was a while ago but I think I may have had to do it a couple of times, then reboot, and the fan noise returned to normal.

1 Like

Thank you for the suggestions and links. I will have a look at these to see if I can find if it’s related to the problems I’ve been experiencing.

Robin, you guessed correctly - the workaround didn’t work. ColorEfex (henceforth known to me as “CrashEfex”) has just crashed Lightroom when I attempted it. I am using an ‘older’ Intel machine too (2017 27" iMac; 4.2GHz …i7; 64Gb RAM). MacOS Monterey 12.5.1. latest LR update.

Provided I stay away from Nik Collection, I don’t appear to be having any problems with my machine. I will do this and not hold my breath waiting for DXO to update Nik. Hopefully, you sort out your system problems ASAP.

PS Daily crashes (BSOD) are the reason why I moved from a PC to Mac some years back.

@Daleducatte - thanks for the suggested workaround - unfortunately it didn’t work :cry:

1 Like