NIK 5 crashing Lightroom

Sorry it didn’t work out, was hoping it would. Maybe DxO is working on some fixes, they seem to have made a mess!

1 Like

I’ve been stuck on this problem for so long that I’ve gone soft in the head… anyway, back to your workaround. I tried 2 methods the first of which didn’t work . Today I realised that I was doing it all “wrong” and your workaround does work with a modification.

i. Open the file in Photoshop from Lightroom, save it as a TIFF file and go back to Lightroom from where I use Nik as a plugin - exactly as before => CRASH.

ii. Open the file in Photoshop from Lightroom (as above). Process the file in Photoshop using Nik as a filter in Photoshop (Color Efex /Silver Efex). Save the result in Photoshop (it automatically appears in Lightroom) - voila…

I have only tried this on a few images but it seems to be working… guess the problem is (not sure of the techie term) something to do with handing off files between Nik 5 /5.1 and Lightroom!?

1 Like

Heyyyyy! Glad to hear you found a workaround to my workaround that works for you! :slight_smile:

Did you notice the “Last Edit” function on the Nik plugins in Photoshop? I was playing around with it this morning, wondering how I might process a batch of images sent from Lightroom to Photoshop, where the plugins only open one image at a time. DxO has a description of it here:

Workflow with Adobe Photoshop - Apply Last Edit

Seems like a real time-saver since you can open multiple images from Lightroom to Photoshop, apply Nik effects to one image, then use “Last Edit” to apply the same settings to another one. There are some variations on that – like getting presets to show up in the plugin panel in Photoshop by marking them as favorites in the Nik app, or applying a preset directly in Photoshop without the Nik app even opening – described starting here:

Workflow with Adobe Photoshop - Selective Tool

I agree it must be the Nik-to-Lightroom handoff that’s tripping up; but the workflow using Photoshop now seems better than I expected and at least with all our experiments we are learning some new things!

I’ve been following the forums wrt upgrading to NIK5. I feel for everyone who is experiencing any type of problem. I want to thank you all for keeping this topic alive and up to date, as I refuse to upgrade until I see these problems disappear or at least significantly reduce.

I am still on NIK4 and do not have any problems with the exception of - whenever I open aNIK product to edit a photo, the program launches followed by a quick red flash within the NIK program, and then the program locks up. I have force quit it and relaunch. A copy of the photo I originally selected for editing appears in LR (as a TIFF). I delete it. The relaunched program(s) work without issue.

OS Monterey V12.5.1
Mac Pro 2019 (tower)
LR 11.5

Nik v3 continues to work on M1 Macs from PhotoLab (I don’t have anything Adobe installed on my computers or phones or iPads any more, they all run better for it). Nik v3 is Rosetta only so it only opens in emulation mode. I’m not pushing Nik v3 hard though as I’m a light Silver Efex user.

Update: my Nik v3 files sent out of PhotoLab with the Nik Collection button are being created and I can edit them. They no longer seem to get sent back to PhotoLab though after the edit. I have to go and get the TIFF files where they appear in the original folder.

User error: I was filtering on RAW in the file browser (it’s not a DAM no matter how many times DxO says it is). Now I have five of the test image and not three!

I’ve just re-installed the Nik Collection which on checking is now version 5.2. I didn’t recevie any message that there was a new release but I’m pleased to say that it seems to have fixed my problems. I’ve been trying to crash Silver Efex Pro (previously very easy) and I can’t.

Fingers crossed this has fixed the problem.

I’ve been fighting with the problem of Lightroom Classic becoming unresponsive after returning to LrC from Nik (Silver Efex specifically). After trying to get support to help me (no success yet) I decided to do a lot of manual testing. At this point I’m convinced that the “updated” Nik apps that have the non-destructive edit feature are the problem. Specifically, they are outputting TIFF files that confuse LrC. If you let LrC wait long enough it will eventually sort things out. This takes roughly 30 seconds to 2 minutes for me depending on the megapixel size of the file and if non-destructive edits are turned on/off. I have a brand new M1 MacBook Pro 14" with 64GB so I imagine this problem is worse on slower hardware.

There are multiple threads on the forum that are really this exact same problem:

Basically when returning to LrC from the “updated” Nik apps, LrC gets stuck in some kind of loop trying to process the TIFF. Eventually it figures it out, but in many cases it’s simply faster to exit LrC and start it back up again.

I’m still hoping I can get support to send this to an engineer. So far no luck. The problem is 100% reproducible and I’ve sent them a video demonstrating it. Until then the best solution is to simply quit LrC after you exit a Nik app and restart LrC. The TIFF then works fine in develop mode with zero wait. Restarting LrC for me is actually faster than waiting up to 2 minutes for LrC to figure things out.

After updating the Nik Collections to v5.2, I can confirm Robin’s statement that the S/W (SEP) will no longer crash, at least I couldn’t force it.
In addition, after updating the MacOS to version Monterey 12.6, it looks like even the time consuming step while returning to LR Classic seems to be fixed. This is very promising and a step in the right direction. Fingers crossed …

When I edit in SFX from Lightroom on it’s return the image still makes multiple appearances the same as before. So no improvement for me I’m afraid.

I have upgraded to Nik Collection v5.2, and on a computer running Windows 11, I have not identified any problems using the applications with Lightroom Classic, Photoshop 2022 or PL5.

I just hope that I haven’t spoken too soon!

Interestingly this issue re crashing has only just started today in Version 5.1 - so upgraded to 5.2 so far, so good but…it is now taking even longer for the tiff files to render in LrC; in Nik 3 they were pretty instantaneous. I am not sure why i upgraded as except for the interface, i am not seeing any benefits.

Add to this although i can use the arrow keys on my Mac to move between presets they have to be mouse clicked to load - this was not the case in Nik 3? Or am I missing something?

So 5.2 did not fix the issue with Lightroom taking ages to build the preview and render the newly imported files?

Well not for me and I am finding having to click to load each preset very frustrating.

Not yet, but they are still in communication with me about it - trying to hep them be able to replicate the issue!

I worked with them to get this fixed. The fix is not in the original 5.2 version. It will be in an update. I can only speak for M1 Mac computers, but the fix works great in the test version they gave me. All of my testing has been with Silver Efex.

Thank you for the time and effort you put in with DxO on the problems with Lightroom interaction. I installed version 5.2.1 this morning (it must have just come out in the past day) and repeated tests I described above – editing a batch of 4 files with Color Efex Pro 5 – and upon returning to Lightroom the changes appear in the TIFF files immediately and Lightroom responds properly with no degraded performance. Yay! I also tried Silver Efex and it worked fine too.

The release notes for the new version 5.2.1 (for Macs) are at

Thanks again!


Dale, you are welcome! Somehow I missed the 5.2.1 update. I agree, it must have just come out. I can confirm that 5.2.1 solved the problem with Lightroom Classic (tested with the new v12 LrC). Finally, we can all use Nik again without these major problems. Bonus, they also fixed the crash I reported with the grain options crashing Silver Efex.




Just installed the latest Nik filters on Ventura for Lightroom and Photoshop.
Now Lightroom is unable to start up. Tried everything so far.
Even reinstalling. No idea what to do now. Photoshop is still working.