Unable to install Nik Collection as Lightroom plugin - 15 weeks & no resolution

Since updating to Nik collection 6 in early December I have been unable to install the apps as a Lightroom plugin. I have had an open support ticket for 15 weeks (https://support.dxo.com/hc/requests/452343). Support agents just keep telling me to ’ be patient’. After nearly 4 months, I simply no longer believe that they are doing anything and will not refund me for software that is not fit for purpose. To make matters worse, the standalone Nik Collection apps will not allow upload of modified images back in to Lightroom.

Hi Gary and welcome to the users’ forum. All DxO products come with at least a 30 day trial period. Didn’t you notice this behavior during your trial of the Nik Collection?

Hi Mark,
Thanks for your swift response. I previously had Nik Collection 2 installed and had no problem with the Lightroom plugin. Because version 2 worked perfectly I felt no need to go for the trial.

Oh, I see, I was afraid of something like that. Maybe @Cecile-C, of the DxO support team that corresponds with us on the forum, can provide some help speeding that up for you. I have “pinged” her for you, but she may not be available until tomorrow.

It’s a holiday here in France tomorrow.

Thanks @Joanna , so it will be Tuesday before she’s back to work.

Sometimes, it is necessary to remove a previous install completely. DxO provides a Nik cleaning tool that should do this thoroughly enough:

Alternatively, manually cleaning does a good job too. I use “Find any File” or “EasyFind”. They are available in rhe Mac App Store or as download from the manufacturer.

Thank you Platypus and Joanna.
I have uninstalled/reinstalled and used the cleanup tool twice, to no effect. I’ve also submitted various system logs. The last instruction from the technical team via the support agents was on 17th January. They cannot give me a phone number or tell me if the issue has been escalated to their management.


Your title says “unable to install”. Do you
a) don’t see Lightroom in the NIK installer as shown below?

b) does the install work without hiccups and (some of) the plug-ins don’t work? This is the case on my Mac. Lr’s module manager shows both the HDR and Nik plugin parameter modules as active, but they don’t even show up in the module menu item. I’ll check and report back as soon as something “suspicious” shows up.

BTW: The uninstaller is not quite sure about the version of Lightroom:

The Nik Collection apps seem to install ok and are available in standalone mode. During the installation, Lightroom does not appear in the list of compatible modules, so I attempted to use the “+” to add it. When I selected Lightroom Classic, for some reason it appears as “Adobe Photoshop Custom 1” in the module list.

Looks like the installer has problems recognising Lightroom. In your case when installing, im mine when uninstalling.

I’ve had situations, in which it wouldn’t recognise PhotoLab either. Be it as it may, the installation seems shaky and so are the consequence.


Now, that you could install the LR plugIn … :+1:

I noticed “Photolab 2” in your screenshot. You may check out, if Nik 6 works with it
cause the Release Notes say different …

while Nik standalone shouldn’t be a problem.

Thanks, but I don’t use Photolab, only Lightroom. When I use the standalone Nik Collection apps, a new copy appears in the Lightroom catalog, but without the Nik Collection edits applied. It’s hugely frustrating.

Ok – tried myself.

Started LR 5.7 (I’m still on that old version),
searched & imported files,
send them from within LR (in German: “Bearbeiten in”) as copy to Nik 6 ColorEfex,
changed the color & applied it, so that Nik 6 ColorEfex closed,
LR showed both versions for each file

screenshots taken in PL6

the files at the RHS “…-Bearbeitet.jpg” are the new versions

My apologies. I tried the process on standalone Silver Efex app as you suggested and it worked correctly. It must just be my incompetence. In the meantime I tried another full uninstall clean and re-install of the Nik Collection 6. It still won’t show as Lightroom plugins. DxO support told me today that I ‘must be patient’ and wait for their fix. After 15 weeks?

I’ve become convinced (right or wrong) that DxO is outsourcing Nik Collection development and support. Support agents who are very competent with PhotoLab support act completely differently when I interact with them about Nik Collection problems. They were asking me ridiculous questions over and over and weren’t answering any of my questions or even looking at what I upload to them. I’ve been frustrated to extremes with serious issues that four years later still haven’t even been investigated after multiple reports, with no reply from anyone I’ve reached out to. The experience became nothing less than abusive. We can only draw our own conclusions. I finally gave up on the Nik Collection and its support channels - I won’t use it anymore or report bugs. :rage:

@popsarmchair Hello Gary, we sincerely apologize for any inconvenience caused by the delay in resolving your issue. I understand your frustration, and I assure you that we are committed to addressing your concerns promptly. I have escalated your case for further investigation. Please allow us a little more time to thoroughly review the situation and provide you with a satisfactory resolution. Your patience and understanding are greatly appreciated.

1 Like

Thank you Cecile.

1 Like

Thanks @Cecile-C.
I’ve been asking for weeks for this to be escalated, to no avail.

@popsarmchair Hello Gary, your case requires a Teamviewer session. You will be contacted within a few days to organize it. Thank you for your understanding.