This is getting old

I appreciate DxO’s commitment to improving PhotoLab with frequent updates, but every time I install a new update the connection to Nik is lost and I have to uninstall the Nik collection, download it again, and reinstall. This has been the case for the last several PhotoLab installs. Is it just me? Running Windows 11…

I run PhotoLab 5 Elite, FilmPack 6 Elite, Viewpoint 3, and the Nick Collection 4 on a Windows 10 machine and I have not seen this issue.


Mark, I have all of those add-ons too, but only Nik has a problem. After installing PhotoLab, the Nik Collection button is dim and hovering over it says that Nik is not installed. It is installed of course, and still useable by Lightroom, Photoshop, etc., but it is lost to PhotoLab. Maybe it has something to do with Windows 11, but if I remember right, this started before I installed 11.

I’ve never had this problem with Windows 10.

If the problem started before you installed Windows 11, then it is most likely some kind of a configuration issue at your end. Perhaps an antivirus program, or some other software that you’re running. It’s impossible to be sure. I’m not sure if logs are generated by the Nik collection, but if they are, sending them and the PhotoLab logs to DxO for evaluation would be the next step.


It just happened again - I restarted my computer and when I opened PhotoLab the Nik button was again dim. Had to delete and reinstall Nik for the second time today. I guess I am the only one :face_with_raised_eyebrow:

That is interesting. So it occurs even if you’re not installing an update to PhotoLab. The only other report I’ve read that is similar to your problem was on the PhotoLab users Facebook page (Not related to DxO) The poster reported similar link issues with the Nik Collection after running the Dell support assist scan on his computer. Although a number of people, including me, responded to this person, I just checked and there has been no resolution, except to not run that Dell utility.

Perhaps you are running some program on startup that is causing this problem. Consider disabling startup programs one at a time before restarting to see if you can identify one that might be the cause. I know that’s a lot of effort and it may not resolve your issue, but it’s something to consider.


Mark, I did run Dell support assist before restarting! However, I never noticed that coinciding with the Nik problem before. It looks like this is something I will have to live with. I guess we could blame the Nvidia GPU, since that’s a convenient (and commonly used) scapegoat for graphics software issues.

Hmmm. Well, that may be the issue. You can test it by ensuring that he Dell utility doesn’t run the next time you reboot and see if the problem disappears, and then test once again after running it to see if it reoccurs. Of course there is always the possibility that the issue with that utility is only intermittent. There appears to be a good chance though that this Dell utility is the culprit. I’m not familiar with it. It may be residing in memory monitoring things all the time…


I will certainly keep that in mind - thanks!

I remember something like this occurring a few months back. I had to completey remove my Nik package and Photolab USING THIS. Then reinstall both programs Photolab first. This solved the problem.

Be advised: Revo will COMPLETELY uninstall these programs, so you need to back-up all your databases, presets, workspaces, lens modules and licenses before you run it.

1 Like

If the Dell support assist scan is causing a problem for PhotoLab, the DxO support team should be made aware of it.


Absolutely, I agree. But afterwards complete uninstallation may be required in order to clean up the mess.

Was the problem you were having a few months back also a result of that Dell utility program?


FWIW: I have a NVIDIA GPU (GTX1650) and I’m using a Dell system (with Dell Command|Update running regularly), and I’ve never experienced this problem.

Confirmation: I’ve just installed PLv512 and the “Nik Collection” button is visible & active.

John M

No, I don’t have Dell computer. Mine is HP.

Good morning!

@barthovis Seems you are not alone - Installed NIK Collection not recognised by Photolab 5 but your problem is even worse as you loose NIK after each restart of the PC as far as I understand.

I suggest you to get connected to the support ( as most probably Nik developers will need a direct access to your PC.

Svetlana G.

1 Like

Good morning & thanks Svetlana. I started the topic referred to in your post & I have a partial workaround. After one of the PL5 updates I did the usual uninstall & reinstall of NIK & checked the registry key again. This time the NIK Collection entry was there. I exported the registry key to a safe place &,when it happened again I doubble clicked on the saved key and PL5 showed NIK Collection as being installed without all the pfaff of uninstalling & reinstalling NIK. NIK Uninstall Key.txt (2.3 KB). I have attached a copy of the key in text format. You would need to change the extension to .reg to import the key back into the registry & change the version number if NIK is updated. It looks like something is knocking out this registry key &, hopefully, the DxO developers can figure out what. Incidentally I noticed that with the latest update of PL5 the problem only arose after I restarted the laptop. Subsequent restarts did not affect PL5 seeing NIK Collection. I am using a Lenovo Thinkpad P1 Gen 2 with a Nvidia Quadro T2000 graphics card. I hope this helps. Geoff Foote

Hi Svetlana, the problem does not occur after every restart, but it did occur when restarting right after running Dell Support Assist utility. It’s possible that this app does some registry cleaning that breaks the PhotoLab/Nik connection, since this has apparently been a problem with other users.

1 Like

Hi Barthovis, I agree that the problem does not occur after every restart but, in my case, restarting after a PL5 update. As I said above I use a Lenovo laptop not Dell so it’s possibly more to do with the PL5 updates than the Dell Support Assist utility. Have you tried the registry solution I described above rather than the uninstall/reinstall route? If you don’t want to click on the text file in my previous post then run regedit & find the key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\Windows\CurrentVersion\Uninstall\Nik Collection when the link is showing in PL5. Right click then select export to save the key as a .reg file. Next time the problem occurs simply click on the .reg file to import the key back into the registry instead of unistalling etc. PL5 should then see NIK collection. The only caveat is that, if NIK Collection has been updated since you saved the key you need to open the .reg file in Notepad & edit the line “DisplayVersion”=“4.3.0” then save the file with the .reg extension. I hope this helps. Regards, Geoff