This is getting old

Thanks Goeff! I have not tried this yet because the Nik button has remained active in PL5. I appreciate the instructions and I will do that next time the problem occurs.

You’re welcome Bart. If the Nik button is active in PL5 it might be as well to export the key to a safe place on your PC now so you can restore it if necessary later. Geoff

1 Like

Once again the NIK Collection button was inactive this morning witj the notification that NIK was not installed. There was no apparent reason for this, no updates to PL5 or Windows. Again importing the NIK Collection Uninstall key resolved the issue. I will raise this again with support & see if they can figure out what is happening.

1 Like

I can confirm that running the Dell Support Assist utility does disable the Nik button from Photolab, even without restarting the computer.

Since some other users who do not run the Dell Support Assist utility seem to have a similar problem, it suggests that they may be running some other type of support utility program that also disables this link. My own experience with some clean up utilities is that their default settings occasionally cause unexpected issues.


Yes, that seems likely. I did notice that running CCleaner does not disable Nik, even though it does a registry cleanup.

I also use CCleaner and have had no problems with it my. However, I briefly was using Iolo System Mechanic which caused some small issues on a few occasions so I stopped using it and I uninstalled it from my system.


1 Like

I think I’ll hold off on using the Dell utility for now. On my system at least, that is what seems to be directly related to the problem.

As I said above, I can confirm that it is not just the Dell Support Assist utility that breaks this link. I am using a Lenovo laptop & running their update utility does not disable the link. I aso use Ashampoo’s WinOptimiser program to clean up my laptop. I have just tried running this &, once again, the NIK button in PL5 is still active even after restarting the laptop. I have raised this as a support ticket with DxO again but, apart from a ticket acknowledgement, I haven’t had a response.

Assuming for the moment that your problem is caused by an interaction with some other third party software, especially if this software is not ccommonly used by many PhotoLab users, it may be more difficult for DxO to isolate the cause of your relatively isolated problem than if they had your machine on their workbench. It is far easier for them to analyze a problem experienced by many people and which they can reproduce.


I agree Mark & I think I may have found the culprit. My machine has an application called Lenovo Vantage & I also subscribe to an add-on to this called Smart Performance (which may be similar to the Dell Assist Utility). Part of this is a check for registry errors &, although it was set to scan once a week on a Tuesday, looking at the log there seems to have been some additional scans performed between these. I checked that the NIK button was active then ran a scan manually. Sure enough, the NIK button was disabled. Reimporting the NIK key restored the button in PL5. I have reset the scan interval to 1 month &, if the NIK button becomes disabled, I will check to see if an unscheduled scan has taken place. It has taken a bit of detecyive work but I think between I might have solved my problem. Still no idea why it just wipes out this key though. I’ll contact Lenovo & see if they have any ideas. Thanks for all your inputs.


Of course, you don’t have to wait and can try various testing scenarios yourself. Keep in mind the resolution may not be so black and white, and there may be an as yet unknown component that you haven’t identified yet.


That’s interesting, Mark - I’ve been using System Mechanic for quite some years now (it does a great job of keeping my system “clean”), and I’ve never encountered any problems … I’ll keep an eye on it, tho.


I have checked back on the Lenovo Smart Performance logs & each time the NIK button has been disabled in PL5 the app has carried out a scan & fix. I am still trying to contact Lenovo to see if they have an explanation. It doesn’t look like any other key is affected but the logs do not give any information on what registry keys were removed so it’s difficult to say,

Further examination of the registry entry above shows the following entry for the Uninstall String:
C:\Program Files\DxO\Nik Collection\bin. All the other entries I have looked at show an exe file in the string, eg: “C:\Program Files\CEWE Photoworld\CEWE Photoworld\uninstall.exe” and
“C:\Program Files (x86)\X-Rite\i1Studio\unins000.exe”
Looking at the bin subdirectory in the NIK collection folder there is no uninstall executable file in the subdirectory which is possibly why some registry cleaners are seeing this as an invalid registry entry & removing it. Does anybody know why the uninstall executable doesn’t exist?

to uninstall …
screenshot taken from my old Lenovo W520

the 1st entry is the recent NC 4.3.0

and the 2nd belongs to the reinstalled NC 3.3
Issues with Nik4 - #8 by Wolfgang

Thanks Wolfgang but the issue is not with uninstalling Nik Collection but the fact that, due to an incorrect registry entry, some registry cleaning apps are removing the key that PL5 looks for to determine if Nik colection is installed.

Well, I got your ‘problem’ – uninstall and then re-install the Nik Collection and get rid of this Lenovo blabla.

I’ve deleted these things since long. Later I installed something like “Lenovo solutions”, but don’t let it run in the background. – To check the systems health simply use windows’ board tools.

Good advice Wolfgang. My subscription to Lenovo Smart Performance expires at the end of January so I don’t think I will be renewing it. The program I mentioned above, Winoptimiser, does much the same job without knocking out the registry key, I would still be interested to know, however, why the Nik Collection uninstall key is different to all the other uninstall keys as mentioned above. The real uninstall key appears to be in an obscure place in the registry: “C:\ProgramData\Package Cache{844d5c3d-ab3b-4568-8174-368fa6c5100c}\NikCollection-4.3.0_r-nik4_3_5.exe” /uninstall. Thanks for your input. Geoff