Remove virtual copy?

I’ve created some virtual copies I’d like to delete to avoid confusion with other VCs. However, the right-click menu item ‘Remove…’ is greyed out. In fact, all the thumbnails (I’m using an External Selection here) are also greyed out.

The PL5 PDF manual also suggests there should be a trash can icon in the thumbnail in the PC version, but there isn’t.

Elsewhere in the PDF manual there is discussion of removing images from a Project. Are Projects the only place where I can remove a VC?

It doesn’t seem logical that I can create new VCs but not delete them. Do I need to make a feature request, or am I missing something?

That doesn’t sound right. It certainly works on my Mac.

It doesn’t sound right to me either… (And I thought it used to work, but I see the same behavior in PL4.)

No problem here – and also tried it with projects.

Deleting the VC in the project left the “master folder” untouched, while deleting in the “master folder” also killed the VC in the project, which afaik is the normal behaviour.

Have you tried the keyboard shortcut?
Have you checked the settings for the trash can in Library view?

  1. Yes; keyboard doesn’t do anything (as expected, given that the command is greyed out).
  2. Where do I find the settings for the trash can in Library view? They’re not in Edit/Preferences, and I don’t see any trash can options in Library view.

Hmm. Perhaps there’s something specific to my computer/PL settings, but I don’t know what it would be.

…the option is gone in DPL5…but if you pull down the separator to show a larger preview in PhotoLibrary, a trash can is shown…at least on my Mac.

Maybe it’s time to delete the preferences file.

  • Point PL to an empty folder
  • Quit PL
  • Delete the preferences file with Explorer
  • Restart PL
  • Review preferences and change as needed

Thanks for the suggestions; unfortunately:

  1. That doesn’t seem to work in Windows for seeing the trash can…
  2. Sounds like a good idea, but where (Win) does the Preferences file exist? It doesn’t seem to be in %AppData%\Local\DxO\DxO PhotoLab 5.

Cannot help with finding the prefs files, but maybe @sgospodarenko can point you in the right direction.

this one ???

IF you like to find out, copy and/or rename it and see if you can restart PL …

Thanks! Just before I saw your note, I also saw a post by @yonni who mentioned the same file.

There are several references in the file that might apply to my issue, esp.

<setting name="PrefsShowThumbnailDelete" serializeAs="String">

but I don’t know for sure if this is it, or what the appropriate value might be.
Perhaps @sgospodarenko can shed some light here?

Rename the config file. Start PhotoLab and get default config back to work.

Good idea, but PL5 crashes if the config file isn’t present, rather than creating a new one. So I’m now back to the original config file.

well, it was worth a try… I’ve trashed the pref file many times over and PhotoLab simply created a new one…on Mac :man_shrugging:

Hint: The values are probably 0, 1 and 2 for on/mouseover/off in whatever order it is.

you mean the one that does hide the trash?

Changing the values of that setting (to 0, 1 or 2) didn’t affect the issue of not being able to remove thumbnails…

Maybe it’s time for a support request:

Good idea. Done. We’ll see what transpires.

Preference settings are held in the User.config file, stored in the version-specific sub-folder within the DxO.PhotoLab.exe_Strongname~ folder … BUT, I don’t recommend deleting this file as it also contains your Export settings. etc.

I’m guessing your issue is related to you “using an External Selection” … even tho I’m not sure what that means ! (?)

John M

Thanks. I’ll check that out. But this isn’t related to External Selections. Those are something that one can use with some other programs to send selected images to PL5; the selection is created in a PL5 External Selection. (At least with the Windows version; I don’t know about Mac.) For some reason this isn’t documented by DxO in the Help.