Rating/IPTC from Lightroom read inconsistently in PL5 Windows

I’ve been using Lightroom to import new files, add IPTC info, and make selections before opening in PL5. I use the star rating in LR as that has been (up to today) the best way to share my picked images. All the data is written to XMP sidecars. In PhotoLab, I use the filter to filter out all RAW images with no stars.

Today I imported four days’ worth of photos into four separate folders. I went through the usual procedures, but when I open in PL5, it sees the ratings in the XMP files in two folders, but does NOT select any files in the other two folders. I viewed the XMP files in Notepad, and all looks proper. Side note while writing this up: the two folders that aren’t showing ratings are also not showing the IPTC info for the photos (name address, copyright, etc), while the ones that show the ratings are also showing the IPTC data.

Isn’t seen by PL5 as having a rating:

PL doesn’t see this one either:
xmp:CreatorTool=“ILCE-6000 v3.20”

PL sees these two:
xmp:CreatorTool=“ILCE-6000 v3.20”

xmp:CreatorTool=“ILCE-6000 v3.20”

The first one is a Nikon NEF file, the other three are Sony ARW files. But that shouldn’t matter since it’s what’s in the XMP files that counts, right? I can work around this, but I shouldn’t have to.

Have you refreshed the folders on PL5? Someone’s you need to tell PL that metadata had changed. Also check your settings re keeping metadata synchronised.

…possibly more issues to discover…like the one I reported here:

Nevertheless, please post a few related .xmp and .dop sidecars as .zip file. This might help to crosscheck the issue.

I refreshed several times to no avail. The “keep metadata synchronized” was not checked. Checking that fixed the problem, although I don’t understand how two folders worked OK and two didn’t.

…what exactly did you do to “refresh”?

  • Index the folder again? (From the sidebar)
  • Read metadata again? (With the respective menu command)
  • Import settings files again? (With the respective menu command)
  • Other?

I switched back and forth from one folder to another, and I right-clicked on the folder and selected Refresh. Thanks to your question, I just found the View>Refresh (F5) command. I don’t see the read metadata again or the import file settings again commands.

The read metadata command can be found in PhotoLab’s file menu:

Do I have to do that for each individual image? Can I select all the images and click that? It’s not very intuitive to have metadata actions under both “File” and “Image.” Anyway, I would expect PL to be reading the metadata automatically. It obviously did that with no problem for two out of four folders.



Good morning!

  • Well, if the folder was previously opened in PL and you changed the IPTC/Exif data after that → the data won’t be automatically updated until you switch “keep metadata synchronized” in Preferences.
    But as not everybody wants to have this option enabled you can manually push reading the data from xmp:
  • No you don’t. You can select all the images and then press Read.

Svetlana G.

No, I never changed the metadata after opening the folder in PL. I did all my metadata changes in Lightroom before opening the folders in PL, and as I said, it worked as expected for two folders but not for the other two.

Thanks for your help.

1 Like