Keywords from DPL 5.0.1 not visible in DPL 5.0.2

I had written keywords in DPL5.0.1 to a bunch of test images and saved the .dop sidecars. Thy contain the keywords as shown below.

After updating to 5.0.2, the keywords did not show, no matter what I did (run an index, manually read settings and metadata), also, the keyword list is empty.

Possibly related:

Issue found with iMac 2019 and macOS 11.6.1.

Aren’t the keywords in PhotoLab 5 supposed to be stored in the .xmp file going forward? Perhaps PhotoLab 5 is migrating any keywords it finds from .dop to .xmp and then erasing them?

1 Like

If you check your sidecar files (.dop and .xmp), you’ll find that DPL5 writes keywords to its .dop sidecars too - have a look at the screenshot above!

Before DPL5, Keywords were not transportable to newer versions of DPL except through the database. Now, keywords travel in .dop sidecars too…they just don’t reach their target, which in this case, is a dot update to DPL5.

As far as I am concerned, I expect DPL to be able to update its database with whatever information comes along in the files. As I’ve seen, this is not (yet) the case. Maybe it’s only a matter of checking a version number or timestamp, maybe it’s something else, whatever the cause, DxO should fix it.

1 Like

Try to retry and update with File - Metadata -Write or turn on the switch for always update in the References. Maybe the last advise will do if you don’t edit with external software.

I thought that was OK already as is.

I’ve tried all the things that have helped in other cases.

The one thing I haven’t tried yet, is to fall back to DPL5.01 and repeat the exercise. Maybe I’ll do that tomorrow.

Maybe someone in the 'hood could test the case too, to see if it’s an individual or general issue?

Tested on MacBook Air M1 running macOS 12.01

  1. Installed DPL5.0.0.39 next to DPL
  2. Keyworded images in build 39 and saved sidecars, quit build 39 and renamed the database
  3. Checked keyword entries in .dop and .xmp files, entries present in both
  4. Opened build 43 and the keywords were shown (build 43 started with a new database)
  5. Pointed build 43 to an empty folder and deleted the keywords from the keyword list
  6. Pointed build 43 to the original folder and the keywords are gone
  7. Imported the settings (.dop) and the keywords are still gone ← should not be the case imo
  8. Imported metadata (.xmp) and the keywords reappeared.

Lesson learned: DPL does NOT read keywords from .dop sidecars.

Sidecars as mentioned in step 3 above

Keywords as displayed in DPL

Note that AAA and BBB are not shown, but we knew that…

Thanks for your hard work on isolating this issue!

Test on DPL v5.0.2 Win
I don’t know what my test is worth but I manually add a keyword in the * .dop and imported this one and the keyword was not added to the image.
I had also modified another parameter (WatermarkActive = false) to test and this one was has been modified.

1 Like

Thanks for testing this. It looks like this is a general issue or design decision.

So far, .dop files have not been able to be a “distributed database backup”. If PhotoLab writes settings and metadata to the sidecar, but cannot import all it wrote, we’re still using a system that does not take advantage of its own possibilities…

  1. We can automate .dop sidecar import/export - but import ignores metadata
  2. We can back up the database - but we cannot automate it
  3. And then there’s history…while advocating its introduction a few years ago, I can do without it, specially in the current super-granularity.
1 Like

This might be a related issue:

Is there an implementation difference between manually reading/writing metadata and synchronisation?