Photolab 3 demo doesn't run on W10

Hi there

I’ve downloaded the PL3 demo but it won’t run.

It installed succesfully but when I try to run it I get the egg timer for a few seconds then nothing happens.

Windows 10 ver 1909

Can anyone help me?


Hello @jezzle and welcome to the Forum,

Let me ask @alex to assist you. In the meantime, could you, please, try to uninstall it, re-download the installer and install again?

Svetlana G.

OK I’ve done that but still have the same problem. My video card drivers and Windows are both up to date

Good morning,

@jezzle in this case, please provide us with your logs. You can find them here:
Crash files – %UserProfile%\Documents\DxO PhotoLab 3 crashes
Log files – %UserProfile%\Documents\DxO PhotoLab 3 logs

You can archive them and attach here.

Than you,
Svetlana G.

There are no DxO Photolab files or folders in the Documents directory. I’ve reinstalled using ‘run as administrator’ but it makes no difference.


Could you please download and install and test again?

Thank you,

Svetlana G.

Hi Svetlana

Tried that.
Uninstalled Photolab
Installed Microsoft stuff
Installed Photolab
Made no difference


Thank you for the feedback. @alex it’s time for you to join. Please, assist.

Svetlana G.

Hello @jezzle,

  1. Do you confirm that you installed DirectX 9.1c successfully?
  2. Could you please share the information about unsuccessful attempts to launch DxO PhotoLab 3 from the Event Viewer log in your system?
  3. What is your user account name in your system? Does it contain spaces?


Hi alex

I downloaded the package that Svetlana mentioned and it installed correctly.

The event viewer logs:

Application: DxO.PhotoLab.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.BadImageFormatException
at DxO.OpticsPro.App…ctor()
at DxO.OpticsPro.App.Main()

Faulting application name: DxO.PhotoLab.exe, version: 3.2.18334.4344, time stamp: 0x5e6b8845
Faulting module name: KERNELBASE.dll, version: 10.0.18362.752, time stamp: 0x2023e189
Exception code: 0xe0434352
Fault offset: 0x000000000003a859
Faulting process ID: 0x724
Faulting application start time: 0x01d606a97f5b2b0e
Faulting application path: C:\Program Files\DxO\DxO PhotoLab 3\DxO.PhotoLab.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report ID: 2e3330fc-6462-454d-bb5e-7d84d0881849
Faulting package full name:
Faulting package-relative application ID:

My user account name is a 5 character name, all lower case, no special characters and no spaces.

Hello @jezzle,

That error can indicate a problem of your system or a conflict with some 3rd party application. What is your Windows version? Could you try to install the latest version of .NET Framework from Did you try to uninstall and install the application again?

Best regards,
Alex K.

Hi alex

My Windows is version 1909. Tried to install the latest Net but it says I already have it installed.

I’ve tried uninstalling and reinstalling DXO but it makes no difference.

Hi @alex

I have the same problem. Photolab 3 Elite does not run on my second windows machine.

I have done the folowing:
Reinstalled Photolab
Reinstalled .NET 4.8
Reinstalled Visual C++ distributions
Updated graphics drivers
Installed directx
Ran sfc/ scannow
Ran windows repair using windows iso
Ran windows in clean boot (all non-windows services and autostart disabled)

Nothing helped. The event viewer shows the same messages as above.


Hello @jezzle and @anthonysikorski,

Please generate a full crash dump and share it with us. @sgospodarenko will provide you with the instructions on how it can be done and where your dumps can be uploaded.


Hello @jezzle and @anthonysikorski,

Please, take this app (836.4 KB) unzip it and put on your Desktop for example. Then run this application and try to start PhotoLab.
Wait until the dump will be collected (it is usually placed next to the DxO.PhotoLabDump application) and provide it to us via (please, put your forum name in the “support ticket number” field).
As soon as it’s ready, please, notify us.

Thank you
Svetlana G.

I uploaded the dump

Cool! Thank you!

Uploaded now

Thank you!


My customer purchased Photolab 3 and is experiencing the same error, is there any fix available for the problem described in this topic?

Best Regards,