Dxo Photo Lab 3 doesn't work on Windows 10 (64 bit)


Let’s try to find a fix for your problem step by step. Please try to install .NET Framework 4.7.2 from the location I mentioned above.

@alex i’ll be waiting for fix issue DXO
I tried DXO Photo Lab 2 - the same issue.

But unistall .NET 4.8 is imposible. This goes from windows update and isn’t good to unistall, becouse next update come back. This update KB2828152 below isn’t exist current version windows, and are dependent from another application and system processing.

Microsoft say clear:
“.NET Framework 4.5.x/4.6.x/4.7.x/4.8 cannot be uninstalled using this package. To uninstall .NET Framework 4.5.x/4.6.x/4.7.x/4.8 from your computer, go to Control Panel, choose Programs and Features, choose View installed updates, select Update for Microsoft Windows (KB2828152) and then choose Uninstall.”

If You will have some fix , let us know !


Sławek, what happens if you open Windows PowerShell as Administrator and run this command?

sfc /scannow


We are already working on switching to .NET Framework 4.8. Please wait a bit for an updated version.

@alex i have no choice, but if You not fix it to 24.11 I’ll lose 30% SALE.
But then will think about buy becouse this is big different.

Hello @slaw,

  • Well, even if you buy it now and the issue won’t be fixed (which is a rare case) then, you’ll be provided with the refund. But in most cases even specific to the user’s PC issues are resolved successfully.

Svetlana G.

1 Like

@sgospodarenko yes, but we don’t know how long You fix it.
It looks like how buy a car and can’t drive.
I think You understand me exacly.

Yes, sure. No problem.

Svetlana G.

This resolve my problem:

Hello @slaw,

Thank you for the info. @alex please, pay attention to.

Svetlana G.

But why a direct link to the installer self and not to the description/page?


@George i get this link from this proposition of solution:

My laptop doesn’t have external graphics cart (use from CPU GPU), so i didn’t have installed Direct X.
When i install Direct X , the DXO PL3 run :slight_smile:

Photolab 3, Windows 10

Would crash when trying to do edits. Sent a number of reports from the “Stopped” popup. Tried reinstalling, deleting registry DXO items (not NIK).

Finally unistalled windows update KB4560960 (6/10 update)

Looks like that’s the fix.

1 Like

DxO PhotoLab 3 should install DirectX 9 during its own installation.


@alex yes.
But no one will know that.
If some library doesn’t exist , than should flash/show some message. “Direct X requiment”
But a lot of people, install program, than can’t open it. This is programmer’s mistakes.
Application should check requierments, before open any time.

That’s impossible in this specific case because the application crashes while being prepared to run, i.e. before it reaches our own code so we cannot check any requirement. The only good solution here that we consider now is to get rid of this dependency.


Hi all,

mabe yo will give the Net Framework Repair Tool a chance https://www.microsoft.com/en-us/download/details.aspx?id=30135

For checking if the net framworks are correctly installed please check https://docs.microsoft.com/de-de/dotnet/framework/migration-guide/how-to-determine-which-versions-are-installed

Detect .NET Framework 4.5 and later versions

The version of .NET Framework (4.5 and later) installed on a machine is listed in the registry at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full . If the Full subkey is missing, then .NET Framework 4.5 or above isn’t installed.

.NET Framework 4.8 On Windows 10 May 2019 Update and Windows 10 November 2019 Update: 528040
On Windows 10 May 2020 Update: 528209
On all other Windows operating systems (including other Windows 10 operating systems): 528049

I’ve seen a lot of installations where you got message “is installed” but it is corrupted.

Attachement is from my computer

Thats only my suggestions

I forgot…normally you have all Installations of Net Framework installed, so V2, V3, V4 (C:\Windows\Microsoft.NET\Framework64). The software itself has to assign the right Version it needs.
But if for example the Version 4.7 seems to be installed, but something is missing maybe it crashes.
So you have to check correct installation and afterwards youare able to install DXO.

explain the stuff


1 Like

@slaw, did you ever run sfc /scannow as I suggested back in November?


I’m not exactly sure but I think sfc command will not find any failures within the Net Framework subsystem. Maybe it’s a 50:50 chance to fix with sfc.
I would follow the MS recommendation with the Net FW repair tool.

sfc is still important as an overall health check.