Nik Collection 4.3.4 causing Photoshop Elements 14 to crash?

I use Nik Collection as a plugin in both DxO PhotoLab (most of the time) and an old version of Photoshop Elements (Version 14) which I mostly only use now for stitching panoramas (I could do without it altogether if DxO provided a stitching app).

I updated Nik to version 4.3.4 on 30 April and now when I try to open Photoshop Elements, it crashes within a few seconds before I can do anything. I’ve tried rebooting the PC several times to no avail. Ditto opening PSE without anything else running - it still crashes. I’m running Windows 10 and not aware of any Windows updates since I last used PSE that might be causing the problem. So I wonder if the new version of Nik Collection is clashing in some way with my ancient (c.2014) edition of PSE - it’s been pretty reliable up to now.

Next time a new version of Nik is offered I’ll uncheck the plugin for PSE to see if that makes a difference - I don’t really need to be able to open it in PSE anymore but don’t know how to remove it as a plugin from PSE given that I can’t keep it open for more than about 5 seconds and therefore can’t access its settings.

check here if supported

if not → reinstall Nik 3.3 (without deleting your Nik 4 version !)
Issues with Nik4 - #8 by Wolfgang and further links

Thanks for that, Wolfgang. The first link is very useful - according to this, Nik Collection 4 is not compatible with PSE 14 - not a huge surprise I guess, given how old it is. To be honest, I probably haven’t tried to use Nik via PSE since it was version 3. If I’d known it was incompatible I simply wouldn’t have checked it as a plugin for PSE because I don’t really need to use it via PSE anymore, I’d just checked it as a plugin for PSE by force of habit every time a new version of Nik came out.

PSE doesn’t crash when I try to open Nik as a plugin - it crashes within a few seconds of me opening PSE. Which it wasn’t doing with earlier versions of Nik 4, even if I couldn’t actually use them as a plugin. So reinstalling Nik 3.3 would be pointless if I was going to leave Nik 4.3.4 installed, because the latter would still be a plugin for PSE. So if there isn’t some way that I can remove Nik as a plugin without having PSE open, I’ll have to wait until the next version of Nik comes along and uncheck it as a plugin for PSE.

As an aside, given that Nik 4 isn’t compatible with these old versions of PSE etc., it’s unfortunate that you can still add it as a plugin.

I’m still using LR 5.7 and with each new version of PL or Nik collection, I get PlugIns for LR which would work, IF my old LR was supported – but isn’t.
So, you either check where they are stored and try to get rid of them OR just ‘ignore’ them.

I’m using Nik 3.3 (mainly) and Nik 4 (mostly for testing).

Has anyone figured out a fix for Photoshop Elements 2020 crashing after updating to 4.3.4? I explained the situation here: Nik Collection 4.3.4 causing Photoshop Elements 2020 to crash, and have a DxO support ticket going, but so far haven’t found an answer and I will need my Photoshop Elements 2020 for work tomorrow. The easiest thing I guess I’ll do is reinstall PSElements and not include Nik plugins, if that’s easy to figure out. The other option I’m guessing is to export out all my presets, uninstall the Nik collection and then reinstall it. Has anyone else had that problem and done either of those things? Thanks!

Hi Cove,
just reading this. – When you get your editor running without PlugIns (or not using them), you should be able to open your tif-/jpg-outputfile with Nik application standalone. But I’m on Windows and don’t know how things are organized on MacOS.

Very late response here but if you aren’t already aware, this problem seems to be solved (at a price) with Nik 5. And presumably if my ancient (c.2013-14) version of PSE doesn’t crash, your much more recent one won’t either.

I thought I’d return to this topic to say that I’ve just installed Nik Collection 5 and my heart initially sank because I’d hoped to be able to uncheck it as a plugin to PSE14 during installment, in order to stop PSE14 from crashing, because I no longer need to use Nik via PSE as I have PL5. But when it came to the plugins section of the installation wizard, it didn’t seem possible to remove it from PSE14; the minus button didn’t remove it from the list. But just to be sure, I then opened PSE14 and - to my great pleasure - it didn’t crash, despite still having Nik as a plugin. I can even use the Nik modules without it crashing. It looks to me like the little menu pane that Nik 4 automatically opened in PSE14 may have been what was causing the crashes as it would initially start to open. Although IIRC Nik 3 also opened such a pane and it didn’t cause crashes then. Anyway, thanks to whoever has sorted this problem out - now I can make multi frame panoramas again (pretty much the only thing I use PSE for now).

1 Like

FYI, the panorama tools in Affinity Photo are quite good. Affinity Photo is flat rate software, no paid updates so far (although I expect someday soon) in ten years.

My understanding is that there will be a major upgrade to Affinity Photo coming fairly soon. When that occurs, I suspect there will be a cost to upgrade to it.

No software company can really prosper and continue development of their software with income only from new users of their products. Even with a reasonably priced upgrade cost every several years, Affinity photo is very cost-effective for anybody who wishes to own it



Hi and Thank You for your response. Yes, I have been using Nik with DxO Lab and sometimes as standalones. That’s always been ok. I reinstalled PSE 2020 without adding the Nik Plug-Ins and it works fine now too. It’s too bad I can’t easily use Nik Define, etc., or Color Efex right from PSE, but, I’ve learned to live with it. DxO techs did offer some suggestions but they haven’t worked so far. Today I downloaded the latest version of the 4 Nik collection, ok’d adding to PSE 2020 as a plug-in, but it didn’t do it. There’s no Selection Tool and no path to Nik apps. I tried adding the Nik Collection via PSE 2020 Plug-Ins “Choose” from preferences, but after clicking ok and restarting, they never showed up. I see all the DxO/Nik files in the PSE 2020 Support Files folder, but they’re not in the “Plug-Ins” folder, they’re in a DxO folder. I told all this to DxO. Maybe they’ll have me manually add the Nik Collection to the Plug-Ins folder? Btw, there are two graphs on the DxO site, one saying the newest update to the Nik 4 Collection is not compatible with PSE 2020, and another saying that it is. My Nik 4 always worked perfectly until the 4.3.4 update. PSE 2022 doesn’t seem worth it, or I’d consider getting the Nik 5 Collection. It’s too bad the 4 updates just didn’t work.