Nik Collection 4.3.4 causing Photoshop Elements 2020 to crash

I use Nik Collection as a plugin on my PC W10 x64 in DxO PhotoLab 5 AND Photoshop Elements 2020 (18 20201207.m.154403 x64). I recently updated Nik to version 4.3.4 and now when I try to open Photoshop Elements Editor 2020, it crashes within a few seconds before I can do anything.

My PC is under Windows 10, Édition Windows 10 Professionnel, Version 21H2, Installé le ‎21/‎10/‎2020, Build du système d’exploitation 19044.1682, Expérience Windows Feature Experience Pack 120.2212.4170.0, Language is FRENCH.

If I came back to Nik to version 4.3.3, everything is fine AGAIN and Photoshop Elements Editor 2020 works properly.

1 Like

Hi and welcome! For a problem like this, you should open a support ticket at it could also be an Adobe bug.

The same thing happened to me just now. I have an iMac on Big Sur. I finish my work in Photoshop Elements and now I can’t. I created a ticket. Whoever finds an answer first, please post it. What a drag. I don’t have the 4.3.3 version anymore. To uninstall and reinstall, I’ll have to save all my presets from all the programs and then reinstall them. I found an Adobe page regarding this and in trying to remove the plugins - it looks like the Plugin folder is missing. I followed the Adobe help with plugins page, but there is no “Plugin” folder. Not when you try going through Applications>Support>, or Applications>Support>Assets, there isn’t a Plugin folder anywhere there. (There is a “plugin.icns” 45kb.) I also tried Library>Preferences>Adobe>Plugins, but it’s only Adobe filter gallery. That explains the finder saying “The file can’t be found.” Did the Nik upgrade throw away my Photoshop Elements Plugin folder?

I haven’t received any resolution on this after 17 days. I have a support person working on it, but there have been no directives at all. She doesn’t understand the problem, even after running a DxO diagnostic terminal report and me having repeated over and over what has happened.

2022-05-19 This problem has been solved by DxO’s Support & Assistance. I received a private link to download Nik Collection version 4.3.5.


Thanks! No such luck here. My support person must not be aware of that. Maybe I can start a new ticket and get another person.

I discovered through the process of elimination that the Selective Tool plugin from Nik Collection 4.3.4 is the problem causing Elements 2020 to crash during startup on my system. I disabled the Nik plugins one at a time by temporarily renaming them then restarting Elements. Attached is a screen grab of the file location on my Macbook Pro running Monterey 12.2.1. Navigate to the Applications folder on your system to find the info in the image.

I can’t thank you enough for your efforts to help with this matter. I recently stopped responding to my DxO support person because she consistently failed to grasp the problem, asking what hosting platform I used when it crashed, etc., etc., and wanted me to run ‘’ through terminal, but I got security warnings doing that and stopped. I had sent them a DxO diagnostic program run through terminal that I realized later was more invasive that I should have allowed. I just uninstalled and reinstalled PSE 2020 so I have that again, and figured Nik products would no longer be supported through it, which is a shame. I have Photolab 5, so, there’s that. If I understand what you’re saying, by renaming the selective tool, and adding Nik back to the PSE 2020 plugins, everything should work? What did you name it? Can it be deleted? We need the selective tool for the apps, don’t we? I looked for a 4.3.5 update but couldn’t find it and my support person didn’t offer it after I mentioned someone else had gotten a link for it. Thanks again for your perseverance!

checked my account and downloaded the latest version, which is 4.3.4

@Cove – to check about compatibility

Well, there you have it. This compatibility chart, saying Nik Collection 4 is NOT compatible with PSE 2020 is news to me. It was working without issue before the 4.3.4 update. That was still Nik Collection 4. Why did technical support even bother wasting my time over the course of weeks with requests for diagnostic reports and code changes if it wasn’t compatible? Perhaps the answer is instead of releasing software that works with the host programs it previously worked with, and fixing the bugs, it was easier to just move along and not bother, rendering it useless as a plug-in after a relatively minor update. Sometimes DxO is great, sometimes not.

7/10/2022 Update: I have been using Nik with DxO Lab and sometimes as standalones. That’s always been ok. I reinstalled PSE 2020 without adding the Nik Plug-Ins and it works fine now too. It’s too bad I can’t easily use Nik Define, etc., or Color Efex right from PSE, but, I’ve learned to live with it. DxO techs did offer some suggestions but they haven’t worked so far. Today I downloaded the latest version of the 4 Nik collection, ok’d adding to PSE 2020 as a plug-in, but it didn’t do it. There’s no Selection Tool and no path to Nik apps. I tried adding the Nik Collection via PSE 2020 Plug-Ins “Choose” from preferences, but after clicking ok and restarting, they never showed up. I see all the DxO/Nik files in the PSE 2020 Support Files folder, but they’re not in the “Plug-Ins” folder, they’re in a DxO folder. I told all this to DxO. Maybe they’ll have me manually add the Nik Collection to the Plug-Ins folder? Btw, there are two graphs on the DxO site, one saying the newest update to the Nik 4 Collection is not compatible with PSE 2020, and another saying that it is. My Nik 4 always worked perfectly until the 4.3.4 update. PSE 2022 doesn’t seem worth it, or I’d consider getting the Nik 5 Collection. It’s too bad the 4 updates just didn’t work.