Multiple Issues of Nik 4 Collection

Really frustrated.
Firstly the Nik Collection appears as a big block on the left hand side of Photoshop and I can’t get rid of it.
Viveza 3 says the disk is full. “Could not complete the Viveza 3 command because the disk is full”
Define 2 text is tiny
Perspective Efex does nothing
HDR Efex Pro seems to work
Silver Efex 3 says the disk is full “Could not complete the Viveza 3 command because the disk is full”
Sharpener tiny text
Metapresets doesn’t see to do anything.

Photoshop can’t be used because the Nik collection is blocking half the screen.
Really its very bad and disappointing.

1 Like

Sorry to hear that. First things first: If one of your storage devices/volumes is full, it’s very important for you to fix that - especially if it’s your OS drive. Or do you believe it’s not true?

No its not full. There is 125 GB free. Nik blocking the screen is a huge issue. Photoshop is not usuable unless I uninstall Nik.

Thanks for replying Greg.

I got rid of the Nik blocking the screen by reducing screen resolution to HD size , I could then see the maintence button and unticking launch at start up - if anyone has a similar issue.
Still can’t get Nik to work Silver Efex or Viveza (the only two to be upgraded I think)
Text size on the others is better at HD resolution rather than the full resolution of the screen.
Does this mean Nik doesn’t work with high resolution screens (in 2021?)

Nothing in the new release notes about HiDPI displays not supported. However, there are known issues - particularly, with Dfine and Sharpener Pro - that have been around since DxO started supporting the Nik Collection and were mentioned in the first post above. DPReview has a review that mentions these issues and more:

DxO Nik Collection 4 review: Viveza and Silver Efex rebooted: Digital Photography Review (

Your disk full error needs to be addressed, whatever that’s about. Best to open a support ticket at

Yes - thanks Greg- its a strange one the memory one. The other apps start.
Screen resolution does seem to impact the size of the Nik Collection Start Up.
At least I have been able to remove that from the screen which was stopping using Photoshops completely. Very strange issue too. I’ve installed loads of plugins in Photoshop and this is the first to have issues. Nik Collection 3 didn’t have similar issues. In 2021 high res screens are quite normal.

1 Like

yeah - i can’t get those 2 to work either…

Got feedback from the support desk:

Please uninstall any existing Nik version on your computer (Google and/or DxO versions if relevant).

If relevant, please manually check there’s no Nik sub-repositories (“Analog Efex Pro 2”, “Color Efex Pro 4”, “Dfine 2”, “HDR Efex Pro 2”, “Selective Tool”, “Sharpener Pro 3”, “Silver Efex Pro 2”, “Viveza 2”) in:

*C:\Program Files\Adobe\Adobe Photoshop Elements \Plug-ins\Google (for Photoshop Elements versions)

*C:\Program Files\Adobe\Adobe Photoshop Elements \Plug-ins\DxO (for Photoshop Elements versions)

*C:\Program Files\Adobe\Adobe Photoshop CS \Plug-ins\Google (for Photoshop CS versions)

*C:\Program Files\Adobe\Adobe Photoshop CS \Plug-ins\DxO (for Photoshop CS versions)

*C:\Program Files\Adobe\Adobe Photoshop CC \Plug-ins\Google (for Photoshop CC versions before 2015.5)

*C:\Program Files\Adobe\Adobe Photoshop CC \Plug-ins\DxO (for Photoshop CC versions before 2015.5)

C:\Program Files\Common Files\Adobe\Plug-Ins\CC\Google (for Photoshop CC versions above 2015.5)

C:\Program Files\Common Files\Adobe\Plug-Ins\CC\DxO (for Photoshop CC versions above 2015.5)

Then, please delete all Nik related repositories from C:\ProgramData\Google and C:\ProgramData\DxO

Finally, please re-install latest Nik Collection by DxO version.

I tried. Still the same: Silver Efex disk is full… Have to go back to Nik 3

Having the same issue with Silver Efex and Viveza. Frustrating to pay for an “upgrade” (I don’t see a change) and have it not work properly.

I’m using Photoshop 2021, my Startup Disk has 755 GB free, I use an external drive for Photoshop Scratch Disk that has 25 TB free. Computer is brand new. Mac OS 11.4.

I’ve the same issue with the new version of Silver efex and Viveza 3. I’ve opened a ticket to without having received any response yet.

I am also getting ‘disk full’ error message . Have opened a support ticket

Looks like your open ticket is contributing to action by DxO, Neil … See here.

John M

I’ve had and solved the Disk Full problem. In my case, it was because the uncompressed size of the image was more than 250Mb. By uncompressed image size, I mean the size reported by Photoshop in the bottom left of the interface when you first open the image before editing. Resize the image so that it’s less than 250Gb (it shows the Mb size in the Photoshop resize window) and both Viveza 3 and Silver Efex 3 work and don’t display the error. Not ideal but it may fix your issue.


I am having exactly the same problems, especially with the ‘Could not complete the Viveza 3 (or Silver Efex) command because the disk is full’.

I have 7 disks comprising 24 Tb of free space, including nearly 700Gb alone on the NVMe SSD C Drive - on which Photoshop is loaded. I am running 64Gb of DDR4 RAM. Changing the scratch disks selected in Photoshop preferences has no effect. The defaults are the C and D drives, both of which are NVMe SSDs.

Some photos can be edited in PS using Silver Efex or Viveza without issue in 16 Bit mode, others edit only when downgraded to 8Bit. Some refuse to edit at all.

As for screen sizing, I’m lucky to now have a 4K display on which some modules are correctly scaled, whereas I need a magnifying glass to read the settings for Sharpener Pro 3 - though at least it loads for any file I attempt to edit. This implies a total lack of coordination between the developer teams for the overall package.

It’s a strange problem that Nik should have picked up in testing and have a solution or work around for. It wasn’t a problem with previous versions and mug file size hasn’t changed.

It’s due to the file size of your layer being more than 250Mb. When you downsample to 8bit it reduces the size to less than 250Mb. Try reducing the number of pixels so that the image is less than 250Mb in 16bit format and it should work.

1 Like

Thanks Robin; I understand that. However, reducing the size or downgrading to 8-bit is pretty unacceptable when working with large .tifs from large raws. It’s a sticking plaster to sidestep just one of the problems with Nik 4. The suite is inconsistent and does not feel properly tested. At best, it is a BETA.

It’s just a workaround until DxO fixes this.

Experiencing the exact same issue. Worked fine version 2. Uninstalled all NIK tool before installing the new ones after reboot to ensure the registry was not holding anything. Same issue. I do IT for a living so it is not silly things like the disk is actually full etc.