I currently use Export to Application but cannot find a way to make additional application exports


Right now I use Export to Appliaction to send the inage to Epson Print Layout printing program.

However, I now wish to add at least one other program, another editing program but cannot see anything in PL that allows me to add such additional external programs…in this Affinity Photo 2 which hides the location of the .exe file from searching but I cand find it by other methods and then copy& paste as needed.

So two questions:-
can I add extra extrernal applications, if so how is it done?
If there is a there a way can I do by copying in the “path” to it?

TIA :slight_smile:


You can choose an application in the export window.

Just bring up the “Export to application” dialog then click on “Browse”. Go to “Program files” and scroll down to “Photo.exe” and click on that, then click on “Export” in the dialog.

Thanks, yes I know but, it seems as far as I can see, that you can only have a single external program not multiple ones and as I said because the way to find it is using OS system search you cannot add Affinity Photo 2 as Serif in their wisdom have used the MS .msix APP installation method and you cannot find the .exe by using Windows search.

I and many others hope that Serif will fix this latter oddity ?

But I hope there is way in PL add further external programs rather than be limited to just one ! :frowning:

Thank you I have just checked what you say and I can indeed add further program(s) ~ phew! Though it would be nice to make the selection a single selection step from the GUI dropdown :wink:

Now, to figure out a way to add the path of the unsearchable AP v2 .exe Note ~ I know copying & pasting the path I found works for FastRawViewer so it can be done depending the program in use?

1 Like

Take a look here File path for Affinity Photo / Start EXE-File - Affinity on Desktop Questions (macOS and Windows) - Affinity | Forum (serif.com)

You can find the path using Task Manager. Open the Processes tab, find Affinity Photo 2 (that needs to be running), expand and select the Affinity Photo 2 executable, right-click and select Open file location. The you have the path in Explorer if you right-click and open Properties for example. (In two pieces at least, the Location directory and executable name.)

On my machine it’s this:

C:\Program Files\WindowsApps\SerifEuropeLtd.AffinityPhoto2_2.0.0.1640_x64__3cqzy0nppv2rt\App\Photo.exe

The problem with this is likely that it looks to be version-specific and will probably break with every update. Don’t know how applications that want a path are supposed to deal with this, but from what I’ve read this is how apps from the Microsoft store are installed.

Thanks, I have previously tried that method and the various other ones and as noted above the only that yielded results for me when adding it FastRawViewer was the windows search method.

None of the other worked at all.

Yes, I tried the Task Manager method but it did not work for me :frowning:

There are also executables under %HOME%\AppData\Local\Microsoft\WindowsApps I see. Maybe these are intended to be what other apps reference, but I’m just guessing.

Affinity pressed on with apps knowing they can’t work with many (most) other programs and now say other programers need to adapt there programs to deal with the mess the Affinity apps have created.

1 Like

The only way of runing any program in the Apps folder is to remove the security on that folder. I am told there have been nasties in the wild that caused MS to tighten the secrity so I have been told its not really a good idea. Pl is one of the programs that only exportys to EXE if they changed just that its esy to make a bat and run from that. But is a mess Affinity have created.
There are also executables under %HOME%\AppData\Local\Microsoft\WindowsApps I see. Maybe these are intended to be what other apps reference, but I’m just guessing it will run direcly from there but it will not run via PL or other programs I have tried. I don’t understand why but I expext its the programs lack rights?

I have copied the path but when DXO tries to start AP2 it fails.

it the apps folder security, Affinity know this and went on with apps. They say DxO can/should change PL to allow app use but given DxO how likly is that?

Certainly seems like a big omission for Serif to change the installation like this and not provide a solution for use as an external editor.

Does anyone know where the Affinity v2 release notes are? I’ve been searching, but haven’t found them. You’d think Serif would at least mention the issue there unless they’re clueless themselves. Or write as lousy release notes as DxO. :grimacing:

They knew and have posted as such on there fourm where they said it was up to oyther programs to deal with the problem.

Affinity V1 is fine with DxPL

and FastStone and FRV but I don’t have Affinity V2 and since we have users with V2 here, can I pick your brains and ask why would I buy a copy of Affinity V2, even though it is currently cheap!?

The only resion I have got it is the lack of phone support by PL and unable to open dng in PL. Hopfully not only will Affinity open DNG but have support for my new phone (if I get it)

Affinity 1 is no problem its the change to 2 being a app thats causing so many problems.

Because it offers non-destrucive RAW editing and other stuff, watch this video:

1 Like

Here’s another one on non-destructive RAW: