Affinity pass app problem to other program producers to sort out

There has been a posting, after one saying Affinity programmer’s knew there was problems with producing there new versions as apps some month ago that says from Affinity

"Unfortunately, we’ve had reports that the above locations are not working for certain apps. It’s an issue our developers are aware of but it appears to be out of our control and related to Windows App Sandboxing. This can only be rectified by the developer of the third party app. "

One of the best workarounds an bat but PL will only export to program so that not working.

Can DXO modify their export to application to include Microsoft Store apps?

I have copied the path to the .exe but DXO fails to open AP2. I assume due to permissions?

The other one is to allow non EXE links then a simple bat will run Affinity. I have it working through Photo Supreme 7 but that alows non EXEs to be selected.

From another topic where is posted this solution. I found that PL will not let me use a .bat file, just the .exe, so this is the workaround I found and modified for this case

A workaround is to go to “Local Disk (C:) → Programs” and scroll down to a hidden folder “WindowsApps” and take ownership of it and all sub folders.

One of the folders within is “SerifEuropeLtd.AffinityPhoto2_2.0.0.1640_x64__3cqzy0nppv2rt”

Within that is the folder “App” and the Photo.exe is located there

Once that is done the location of the .exe file is accessible

Just tested and works fine for me

Not my solution btw, but what the hell, it works

I have had it pointed out you can add a bat to PL, and it worked, go to the location of the bat, type . (or even just *) and all files are selectable and you can select the bat.

I have seen a variety of reports on Official Affinity forums that the bat works for some and not for others. I tried that first but it didn’t work

Affinity have also stated that their app worked in beta and they are trying to identify the issue. msix installers will eventually be default installer for Windows (their decision to increase security [and control…?]).

Seems like Affinity decided to adopt early and got bitten on the ass as a result.

1 Like

@tilltheendofeternity The biggest “pain” with the new method of installation is that it did not offer an alternative location for installation, an implication of Microsoft .msix perhaps and the method for storing apps, i.e. back to the stone age! Affinitiy is stored on my E: (Extension) drive when I started running out of room on C:\ but Affinity 2 trial is now on C:!!

The .bat didn’t seem to work initially so I changed the permissions (of the .bat file) and discovered the .bat option in FastStone so launched successfully from there!

But DxPL did not show the .bat file, however typing “affinity2.bat” into DxPL seemed to do the trick.

1 Like

Update. .bat file method works.

1 Like
  1. had gone into the Affinity forum

  2. followed here

  3. got this info


  4. did as instructed
    Screen Shot 11-11-22 at 01.56 PM
    Screen Shot 11-11-22 at 01.42 PM

  5. opened PL6 → Export to application

    typed APhoto.bat into the file name’s field !

  6. et voila … then could export to Affinity Photo 2

simply didn’t want to juggle around with ‘ownership’ for

Screen Shot 11-11-22 at 11.27 AM

what I found to be explained here (and how to reverse here)

@Wolfgang exactly what I did except that when I first attempted it I missed the ability to add a .bat to FastStone and couldn’t see the file .bat file on the C:\ drive (no directory)!

So I changed access rights and then discovered the .bat facility in FastStone and launched Affinity 2 successfully so when I couldn’t see the .bat file in the DxPL ‘browse’ of ‘Export to application’ I typed it in and it all worked as expected!

However, from FastStone I can pass 6 images to Affinity 2 but in PL6 all four selected images are exported to disk (as TIFFs) but only one seems to have made it to Affinity 2?

If you want to install the AP 2.0 app to a different location, other than Drive C it is possible to do so. I also keep my Drive C clear of anything which is not OS related, so wanted to try AP 2.0 without installing the code to C:

Microsoft Apps using the .msix installer can be installed to any available drive, and can be moved between drives. You also can set the default drive for Microsoft Apps to save documents.

Unlike earlier installers, you don’t get the option to select specific folders in the tree structure, just the drive. The installer manages the directory structure for the installed files related to the App.

Go to Settings, Storage and select ‘Change where new content is saved’ to change the default drives for app installs and documents.

To move an already installed App, go to Settings, Apps and Features, select the App which you want to move and click on the ‘Move’ button to move to another drive.

When I first started to work with this App install model on Windows (as part of my day job) I really did not like it, but after some experience with it I see that it has advantages (and disadvantages). Like everything new it takes some time to get used to the change, lots of old tricks don’t work anymore.

I’d prefer the standard install approach, but it does look like more and more software for Windows will be packaged this way.


@acloughley I don’t “hate” anything “new” per se but I detest it when features that were useful are just discarded because some … decides there is a better way of doing things and this or that feature are “so yesterday”!

“Yesterday” is where I come from, DOS to Win 3.1, Win 95 etc… to Win 10 where my current kit must stay because it is non TPM compliant and fitting a TPM module didn’t work, all because Microsoft wanted to cut ties with having to support ancient devices, wanted to help promote sales of all new PCs and …!

Sorry, age has only made me more sceptical and cynical (if that was possible) but thanks for the advice because it looks like I am going to need it in the foreseeable future!



:wink: - I come from the Unix/Linux world and most of the changes I see in Windows these days leave me confused as to why they were considered to be good ideas.

As for not getting to Windows 11 due to lack of TPM support - that is easily fixed by a couple of registry changes. Either edit the registry directly before starting the upgrade, or use something like Rufus to create the installation media. I have an old Dell laptop on my desk here running Win 11 happily with no TPM :slight_smile:.

@acloughley I know and I have two of my three machines fitted with ‘Sata’ power switches so cloning a copy of the Test machine and adding the new clone SSD to the power switch is actually 30 minutes work!

I have the various articles written about the workarounds, I just felt like a “moan”, plus taking all three machines to the next level, plus my wife’s that was my old “daily” machine, not to mention the aging laptop, is just too much “fun” for an old man to take!

But I will move the Test machine soon, given that swapping back is just power off, turn off Win 11 SSD and turn on Win 10 SSD and start the machine (the reason I fitted the SATA power switches in the first place), and re-orient brain.

I managed to avoid Unix/Linux all my career and worked on Burroughs/Unisys MCP on their Large Systems range, as was, with Windows laptops for administration and then for operating the mainframes remotely and even running the MCP operating system on a Windows Laptop in E-Mode (emulation mode).

Thanks for your help



Affinity have now produced a EXE tpo use in provide a link to run in all other programs. Its at
For those wanting to run PhotoPlus from within DAM applications please check this post

1 Like

Hi all – got this post (at 16:49 in Germany)

Patrick Connor has posted a comment on a topic, Not able to start Affinity Photo 2 from DxO, XNViewMP, ART and Raw Therapee

|40x40||Posted in Not able to start Affinity Photo 2 from DxO, XNViewMP, ART and Raw Therapee

We are working on a simple solution to this and will likely have it tested and with you by Monday.

PLEASE just sit on this till then do not do anything hasty.
Go to this Post|
| — | — |

[ some info – people have been hammering Affinity for a solution and all stuff came up, like installing in a different destination, changing 'ownership and what not … ]


The Affinity Devs have now announced that they will make Affinity Photo available as a standard MSI install file.

The longer term problem remains, ie that DxO doesn’t play well with Windows sandboxing of MSIX installs. But at least everyone is now aware of the issue, and hopefully these sort of issues will get resolved in time.


A naive/curious question:

  • Why is it important to have a standard MSI install file ?
  • What’s wrong with a simple .EXE install file ?

John M


Affinity had decided to install v2 in the ‘hidden’ path

which then creates problems, e.g. when you want to export from PL, have access from FRV etc.

1 Like

Microsoft now has a package handler install system with file extension MSIX, colloquially “Store Apps” which are potentially more secure, easier to update etc.Unfortunately programs like DXO do not understand store apps which use aliases to the real .exe file and also installs go into a hidden, protected folder. This means that you can’t add them easily to the “Export to Application” function in DXO.

1 Like