How to revert back to earlier revision (6.8) in place of a newer revision (6.9)?

Anyone know how I can get back to 6.8 revision of PL from revision 6.9?
Deep Prime is failing with my GPU in 6.9 but it doesn’t fail in 6.8.
I usually keep the older revision install file, but not this time (being that it’s 9 revisions into this version).
I can’t find a way to download older versions/revisions (6.8).
I was able to reinstall my older rev 6.0.1, but I have many edits after I had updated that revision up to 6.8 and would like those DOP files to be recognized and applied but they’re newer than the software rev so it won’t apply those DOP file.

I’ve tried editing the “Software” revision field in the DOP file along with the “CafId” field but I haven’t gotten that to work yet.

Thanks in advance for how to obtain an install file for an older rev than the latest rev.

always keep a copy of the last version you install, that’s my way to do things as you never know. you can also wait for other people to test drive latest update and you can read the pros and cons.

I’d get in touch with, describe your issue and ask for a fix. DxO should support you as a paying customer - and if there is a issue with 6.9, DxO should know about it.

Make sure you add good detail about what you do and expect vs. what you get. Add info about your gear, e.g. your GPU and other hardware.

Just tested this with DPL 6.9 on macOS and found that denoising worked as expected.

Hi! On which OS/System do you run PL?

And rename it to the version.


I’ve just checked the DOP files written by DPL6.0.1, 6.8.1 and 6.9.0 and found that

I’ve never seen any issues reading sidecars from newer versions of DPL within the same major version. Nevertheless, you can always edit the .dop files with a text editor, if you feel you have to or if your finding is different than mine. Let all other items be as you find them.

BTW: CafID relates to the DxO module that was used.
All tests done with DPL on macOS.

you have to specify which PL version you referring to. PL6 run from Big Sur so the clock is ticking and won’t be supported by the end of 2023

I had the same issues on my Windows machine (Export with HQ and Prime worked, but not the DeepPRIME options). My Video Chipset is: NVIDIA GeForce RTX 2060 Super. I found a new version of the driver for this card and installed a “stiudio” version (for content creators) - it resolved the issue!

1 Like

My OS is Windows 10.
My GPU is an AMD 540 (fails with PL rev 6.9 but not 6.8)
I’ve made sure my GPU driver is up to date
I’ve reverted back to PL rev 6.0, and now no problem with GPU
Would like to get back to rev 6.8.
I’ve contacted the DxO Support group

Platypus, during DxO re-install of 6.0, a message said it wasn’t possible to re-install an earlier version than what was already installed (6.9). So I had to uninstall 6.9 first. I believe that might have removed association with the existing PL database and a new database might have been created that caused my 6.8 and 6.9 DOP files to not work.

However, I reloaded a previous database that was a month old and then IMPORTED each of the more recent folder’s DOP files (Sidecars). But the newer DOP files are still ignored apparently because there are none of my changes applied to the RAW photos I’ve exported to JPG and PL isn’t allowing a comparison to the JPG (doesn’t recognize that the RAW was exported to JPG).

Depending on how you set DPL, it will or will not read the .dop files automatically.

There’s a catch though: If DPL is set to automatically import and export sidecars, a “new” database might overwrite existing sidecars (depending on how the sync is implemented)…and the new DB (listing no changes yet) might effectively destroy your work.

Please note: This is speculation and I’ve never tested it, because I set DPL to NOT import/export sidecars automatically. This setting keeps me in control and no third party good intention can spoil my work :wink:

Again, I use macOS and your experience on Windows might be different.

Hmm. Same issue for me. Windows 10 and NVIDIA GeForce GTX 1050, Deep Prime exports fail using Photolab 6.9. Reverted to 6.8 and Deep Prime works again. I’ve logged a support call - fingers crossed.

Just exported 2 different files, one with DeepPrime and one with DeepPrimeXD – took a moment, but no problem so far.

(GTX 1060 6GB with studio driver v 536.99)

I encountered GPU-related issues with PLv6.9 too (See details here) - and also found the problems went away when I reverted to v6.8

there is a new release today, 5.14.1 so might be a new update for 6.9.***

For Mac or Win ?
For Mac the V5.14.1 and V6.9.1 version were released a week ago

i got 5.14.0 a week ago, and now just noticed 5.14.1built 97
don’t get me wrong, i just double checked, the version i downloaded last week says 5.14.1 but, when looking from PL it is version 5.14.0 built 96

Screenshot 2023-09-12 at 10.25.10 AM

As of the time of posting this message there’s no update for Windows beyond the current 6.9.0 Build 276.

Same for PL5 on Windows, there is no update beyond the current 5.14.0 build 4894.

here’s what i get when i check for update from PL on mac.