How to revert back to earlier revision (6.8) in place of a newer revision (6.9)?

Yes this update was released for Mac only last week and also in v6.9.1.
Win versions are still in v5.14 and v6.9

i missed the boat last week then :smiley: :cup_with_straw:

I can’t find a link to download version 6.8. of Photolab (Windows).
And the support team has been silent on my request for over a week. I had addressed my problems with version 6.10. and asked for a link to version 6.8.
Can anyone provide me with Windows version 6.8 for download? That would be very helpful, thank you.

DxO only provides the most current update for any of their software versions available for download. I believe I still have a copy of 6.8 for Windows, but I will have to check to be sure. I am away from home for the next few days. If you can’t find someone else to help you out, please send me a private message on Monday as a memory jogger.


There’s an update to 6.10.1 which purports to fix some GPU-related issues. Have you tried that ?

See here for details.

Thanks for the tip.
With the update to 6.10.1 I had hoped that it would get better, but it got even worse.
PL has been crashing regularly since 6.9 and what is even worse is that the computer freezes reproducibly at the end of an export process with 6.10.1. The only thing that helps is a hard reset. And that’s pretty annoying.
Maybe it’s not even due to PL, but version 6.8 would be worth a try.
My environment: Windows 11, Intel i7-10710U, 32GB Ram, Nvidia GeForce 1650 with Max-Q-Design
Not exactly up to date anymore, but fortunately this will soon come to an end.

I bought a new laptop this summer with win11. I installed firefox and other stuff I use. Everything ok. Until last week. Every time I watch a youtube movie it crashes after a while. No problem with Chrome or Edge. No problem with the same version on my old Win10 desktop.



sometimes the order of installations is also important.
Example: Installation of software1 installs a necessary abc.dll and the software works.
Then you install software 2, which also requires the abc.dll in the routine, but a different version and install this. And software 1 no longer works properly.
You could uninstall DXO, then check again whether you have installed all Windows updates and graphics driver updates (studio drivers). Then install DXO again and check.

Maybe this will help

Thank you for this tip.
I have already had this experience and have actually tried to solve the problem by uninstalling PL. Unfortunately, it didn’t help in this case, but it will certainly help in other situations.

Many thanks for your offer.
In the meantime, another user has already provided me with version 6.8.
I’m curious to see if it gets better or if it was something else. I will report back, as this always helps other users.

1 Like

After you uninstalled DxO did you also delete the folders:

C:\Program Files\DxO

before you tried reinstalling? Those folders contain some info that might be causing your problems so make sure they are deleted.

DxO will re-create what it needs when it is reinstalled.

Yes, I had deleted the folders, I already know this necessity from beta testing.
But thanks for the tip.

It looks like I’m back in business.
After some export processes I had no crashes of PL, not even a complete crash of the computer. And the export is now much faster than before, which I didn’t remember.
Thanks again for your help (especially @George)

1 Like

I only did send where you asked for.



there could also be leftovers in the registry, but since there could be entries in both HKLM and HKCU, it’s more like a puzzle…or you can use an uninstaller like Revoke

The PL uninstaller is appalling my uninstaller finds an enormous amont of rubish it leaves when uninstalled.

I did uninstall firefox, not vissible in ccleaner and win11, except on my window screen. It’s still working!!! Well, except for the problem I had.


A hint for proven practice:

  • When PhotoLab signals an update, I go to my shop account, download the (new) full installer and use it to update PhotoLab.
  • I keep the full installer. It provides the means for a fallback - for future use.
  • If you don’t have the current installer, I propose you fetch it now, before PhotoLab gets its next update.

Great procedure. I will do that going forwad. I use an app called MacUpdater that installs updates automatically. I will not use it for PL anymore.

Since I have a great Time Machine backup I was able to revert to PhotoLab Elite 7.1 from the backups and no longer have the bug in 7.1.1.

If you use Time Machine, go back to mid-November and Restore the 7.1 version.