Export doesn't work anymore (DxO PL6)

Just started crashing on export after several weeks of successful output. Coincided with update to V6.1


Hi Martin,
welcome here – and check with the update from today PL 6.1.1. build 86 please – and report back if possible

Thank you.
Quick trial suggests problem solved.
Will test more extensively today.

Update on my side : started working again, hope it will remain that way. Can’t explain what happened, still haven’t updated to 6.1.1

Sorry - earlier reply was too soon.
Export to LR fails on both Deep Prime and Deep Prime XD - access to GPU blocked.
With my workflow PL6 is worthless.

1 Like

I agree, I am having the same problems. I’m sure I probably need to upgrade my computer, but when you can’t export, (I’m having problems exporting to the disk as well, even in JPEG) Sometimes it works, sometimes it doesn’t. I think it’s dependent on the degree of denoising that is used… The program is pretty much worthless. I would like to buy it, I like what it does in general, but if I can’t export, it’s a NO.

I had this same problem until I terminated Adobe Lightroom Classic. Then I was able to export. I restarted Lightroom and the problem did not come back.
I am running DxO Photolab 6.1.1 Elite build 86. Adobe lightroom Classic versio nis 12.1.

I have a similar situation the edits I carry out in PL are saved automatically to the original folder, I can export to the Nik collection and return the image to PL… But if I try to export the image from PL the program locks up and I have to force close it.
It’s a new computer with very little loaded onto it so plenty of storage space and 16gb of ram and an AMD chip in excess of the recommendation. Programs requiring similar specs work fine so I would be surprised if it’s hardware related.
I have screenshot fotos but can’t see how to attach images
Any help much appreciated

I have yet to see if this is the problem, but it seems that Avast software maybe the problem
Fingers crossed :grin:

@stevepaint sadly the reference to avast didn’t work

“An error occurred while processing your request.
Reference #102.a67232b8.1676980341.323d1871”

I have experienced similar problems but only under rare circumstances, principally starting another export while a previous export was actually running and requesting a unique filename which was then taken by the previous export, I think.

But that shows like this, i.e. having started an export to the same directory, I started the same export when the first was part way through and created a clash situation, i.e. DxPL allocates the names at the beginning of the process not as it goes along

I have also had this error once or twice but don’t think I got to the bottom of the problem

Whether it occurred while I was running tests from both machines on the same directory at the same time I cannot remember, sorry.

I would be looking for file locking (directory?) clashes and that includes DOPs because DxPL updates them with the details of the exports it has made, I don’t think the xmp sidecar should be an issue.

All exports are done by a process started by DxPL and there is one copy as per the setting in ‘Preferences’, recommended as 2 which will give two copies of the export process running.

I have been doing a lot of tests recently looking at export performance times and have had no problems whatsoever, even when starting multiple export sessions at the same time (with images from separate directories that are exporting to a sub-directory) which are all queued by DxPL until the previous export(s) are finished.

But all these exports have been to sub-directories not back to the original directory.

I have uninstalled Avast and tried PL and it worked perfectly, I then reinstalled Avast, the problem returned.
I am now loading AVG to see if I have similar problems… Stay tuned :crazy_face::stuck_out_tongue_winking_eye::rofl:

1 Like

Somewhere it was said, that there is an update from Avast – maybe check for it.

Not sure an update will do the trick as the install was only done last Friday and from experience it is self checking for updates.
AVG produced the same problem
However Bitdefender is now installed and seems to be ok

Some more info and maybe a solution ???

I was crawling through several threads here wrt issues occuring randomly on DeepPRIME or DeepPRIME XD with RX 580 grahics cards.

The driver and hardware seem to have a hard time running smoothly on some machines.

One hint was given in this thread

I was not aware I would be able to change the usage type from graphics to computation.

I’ve changed it and the randomly failures were reduced (unfortunately still available). At least the small group of tests on the benchmark files did indicate so…

Another indication was given in this thread

I thought I had already checked this page which is referred in that thread

Potentially I’ve missed to save the config file as admin, at least the proposed change was not applied in my config file, hence I’ve done accordingly.

Interestingly the last change did also influence the Task Manager view of the RX 580. I did not saw a huge load before on the GPU (which I was wondering about). After changing the above setting (pls. don’t ask, why this setting in DXO PhotoLab did change the Task Manager loading of the CPU). I saw GPU usage already before in Adrenalin Softwrae…

But the most important, the last change (and maybe also the one before) did reaveal no further issues yet, i.e. I can run and export DeepPRIME XD without errors (as said, fingers crossed, at least up to now).

A huge step forward and thanks all for helping to resolve this !

Kind regards,

1 Like

With the AMD drivers and their updates, it’s always a bit hit and miss. I’m still on an older version than the latest as they are a lot more stable. I actually use 22.10.3 if I recall correctly.

In some cases, Windows will install the latest drivers using Windows update. You should disable this (How To Stop Windows From Updating Graphics Drivers) and install the AMD drivers from the website yourself. Make sure you download the older version of the drivers. It can be a bit of a search on the AMD website, but if you go to the Driver download page and select your GPU, you’ll be redirected to a page with drivers per operating system. Somewhere on that page there’s a link to the previous drivers (just search for that text :wink: )

Like I said, 22.10.3 is stable on my machine. I didn’t try the latest drivers yet. With my RX 480, the drivers will not bring much improvement anymore as AMD doesn’t focus on old GPU’s that much. They are simply supported. So installing the latest drivers won’t improve performance. And this version is stable so why update :slight_smile:

Best to uninstall drivers completely using DDU before installing an older version.

Thanks for the reply. I`ve just removed the old files and already installed the latest driver. Including above mentioned steps it is running now perfect (or nearly, it could be faster :wink: )

Hence I`m not going to change the drivers and (fingers crossed) hope this will last a long time…

Good to hear the latest drivers work fine too. Gives me a small reason to try them :+1:

I’m facing the same issue, randomly with DeepPRIME or DeepPRIME XD export I got errors. It seems getting worse over the time (development of PhotoLab). Currently I’m using PhotoLab Elite 6.5.0.Build 171 on a AMD Ryzen 3700X / Radeon RX 580/8GB. “Correction failed at the Exceute Stage” occurs randomly in a bunch of files to export, usually I use export to Lightroom, but even processing files and writing to disk (into same directory) ends up with an error.

Initially I thought this to be an error due to the old GPU and was looking for a new already. I found a thread pointing to this Google document

I’ve used the images as listed and had several times the a.m. issue with the D850 files. Finally after more than 10 atempts I was able to get a complete set of finished jpg exports with DeepPRIME, I never made it with DeepPRIME XD (and refused to run again and again).

I would be pleased if anyone could let me know the solution for this. I use Microsoft Defender, so no Avast issue…

Thanks for any update to get rid of that sh*t, because I like PhotoLab and the functionality, but I hate the annoying workflow, exporting a huge bunch of files several times to get the output finished.

Kind regards,

What OS are you on?
There is a new driver available for the Rx580 released on the 20th April 2023. Have you tried updating to that driver?
The sort of problems you are seeing are often driver related.

no, I did not update to the most recent driver as you’ve mentioned, but I’m using the one before.

As mentioned above, after changing the settings in the Driver and the CONFIG File (I guess was the main trigger) it is running now without errors for my RX 580, not the fastest solution but at least stable for the moment :slight_smile:

1 Like