V6.1: Lauching Color efex, PS opens immediately closes layer doesn't start Nik

So, I installed v6.1 yesterday and found that when in Photoshop 24.5.0 opening either Color Efex, Analog Efex, or Silver Efex results in PS creating a new layer and immediately closing it without ever going into the Nik application. This does not happen if I click on v6.1’s Perspective Efex or Define. These are just examples, not the complete list of apps that do and do not show this problem.

Going back to v6.0 corrects this problem. Reinstalling v6.1 reinstates the problem, so it’s something to do with v6.1 on Windows in the latest version of Photoshop (not beta).

Anyone with solutions?

The bug described here may be related to the bug in this post:

It seems that it is related to the bug I’ve posted in the linked thread. But…

Do you habe tried to deactivate the ‘Use GPU for image processing’ option? If this option is deactivated then it worked as it should.
I have the problems with version 6.0.0 of the Nik Collection. After I have installed the update to 6.1 it seems to work also when the GPU option is activated.
Very strange.
I an using the Nik collection with Photoshop 24.5 and Beta (24.7).

I’m in contact with the DxO support.

I have not tried to activate GPU usage in v6.1, but that’s worth trying. (I have ‘use GPU’ activated in v6.0, and it works as expected.)

I have also sent a message to DxO support reporting this problem.

Please post if you get a response from DxO; I will do the same.


Update - uninstalling 6.1 then running the Nik Cleanup Tool and installing 6.1 again solved all my problems. The cleanup tool runs in PowerShell and takes several minutes to run. Be sure to run PowerShell as an administrator.

Thanks for the suggestion. I have never heard of the NikCleanup Tool, despite having used Nik software for decades. I’ll give it a try and will post results.

Confirming that using the NikCleanup Tool as stated corrected the problem I had with v6.1.