Unsupported file error when opening Topaz TIF files in DXO apps

I’m using Topaz Sharpen on Nikon raw NEF files and when I try to open the file in DXO PL3 I get the error: “This image cannot be processed because of an unknown error. It may be corrupted or in an unsupported format.” I have tried using Topaz as either a stand-alone app or as a plug-in from Capture NX, and have tried several ways to save the file too, no compression, different color profiles, bit-depth, etc., but I still get the error in DXO PL3. When exporting the NEF file as TIF from Nikon’s Capture NX-D, DXO-PL3 does open the TIF file. All of my other programs open the Topaz TIF files just fine, including the NIK 2.x suite but also not in DXO ViewPoint, or DXO FilmPack 5. Does DXO have some issue with Topaz?

2013 Apple MacPro 64Gb Ram / D500 graphics
OSX Mohave 10.14.6
Latest versions of all apps (Topaz, Capture NX -D, & DXO PL3, and others successfully tested with the TIF files.)

Does Topaz stay open after it writes a TIFF file? Or does it shut down (crash)?

Topaz writes out the TIF file without crashing, and it is readable in other programs. These are Nikon D850 files sharpened in Topaz. I’m not using the plug-in from DXO and trying to return back to DXO for further processing.

My workflow is to open the NEF file in Capture NX-D to preserve the in-camera settings and to do some minor sharpening in Topaz, saving the sharpened image from Topaz as a TIF file to then use DXO for post-processing.


Anybody else having problems opening Topaz TIFs with DXO apps?

The only Topaz app that I have is their JPEG => RAW app. I have no problems opening the TIFFs that it produces in DXO Photolab 3.

I’ve just created a TIF in Topaz Denoise AI using its default export options (16bit, lzw, original color profile). The original file used was a Lumix G9 raw file. Photolab opened the TIF file without any problem.

I have the same problem. DxO PL 4 will not open TIF files created by either stand-alone Topaz Sharpen or stand-alone Topaz DeNoise. The starting files are Nikon raw NEF files from a Nikon D500. Other programs have no problem opening the files. So I typically use Affinity Photo or on1 to work on files created by Topaz. I would prefer to use DxO PL.

Try creating the TIFF in Topaz without compression or with LZW compression instead of Zip compression.

1 Like

I also know about the issue with TIF files created by TopzLabs software. I use other software to open and save these tif files again, so the files can be used with DxO products after usinsg TopzLabs products

I have been using LZW compression. I’ll try creating with other settings.

1 Like

I had no problems opening TIFF files created by Topaz Denoise 2 in PL3. I believe I also tested them in PL 4 but will test again a little later today. I’m running Windows 10 so this problem may be specific to Macs.


I know this is an old thread, but is the problem still there? I started from PhotoLab 4, and exported some photos to Topaz Sharpen AI, as TIFFs. When they come back into PhotoLab, I get a “Cannot load image data” message. As one poster said, opening and saving in Photoshop meant PhotoLab could open it, but having to open up Photoshop each time is a pain. Another poster said to enable different compression in Topaz, but I cannot see any options in Topaz for saving the files. If I open Topaz Sharpen AI as standalone, and choose “Save As”, the defailt is LZW compression, but if I open the file from inside PhotoLab, I do not see this option.In any case if I try to open the file created with standalone Topaz in PhotoLab, I get the error message.

I don’t have Topaz, Roger - but if it has an option to save a TIFF with LZW as the compression method then it’s likely it has an option to save as uncompressed too … and that, I believe, is what you’ll need for PL to be able to read it.

John M

Thank you for the response. I tried changing the option to Uncompressed when using Topaz standalone, and PL can read those. I need to check again about LZW compression, because the other thing I have found is that to get PL to recognise a file, I sometimes have to close it and reopen PL (refresh does not always work). It is odd. I export from PL to Topaz Sharpen AI, and the TIFF file appears in PL. When I then save it back from Topaz, the file disappears from PL. I quit PL, and then restart, and the file is there. So I need to try this with LZW compressed files exported from Topaz. Too many possibilities to try.

New PL user here. I have this same problem on WIndows 10, and PL will neither open compressed or uncompressed TIFF files, and I have checked them very carefully. Photoshop opens both just fine.

Whatever could be going wrong? The error message is uninformative:

This image cannot be processed because of an unknown error. it may be corrupted of in an unsupported format.

Strange that PL cannot read a long established file format. What are we missing?

Andrew, have you opened a support request and submitted a sample TIFF image to DxO for analysis? This is the best and fastest way to get this resolved. (support.dxo.com to open a ticket, upload.dxo.com to provide one or more TIFF files)

Oops. I replied in too much of a hurry and thought the query was a different one about PL not finding the files. My fault. Sorry.

Have you tried closing down PL and checking that PL does not recognise the file when you restart it? This should not be necessary, and it does not make sense, but I find that it Topaz apps have changed the TIFF it is necessary. There is a “Refresh” option, or some similar name, but in my experience it does not work, and closing PL and reopening it does usually work. I cannot remember what compression options I selected in Topaz apps, the main ones I use outside PL.

Received a reply today (12/08/2021) from support to my question about DxO PhotoLab 4’s perceived compatibility issue with TopazLabs Sharpen AI (current version), with regards to .tiff files. From what I have read on this forum, other users are experiencing similar problems. Below is DxO support’s explanation and their recommendation.

"Thank you for writing. In order to get the best, and most consistent, results from DxO PhotoLab, we recommend that you always use the original and unmodified photo files from your camera in the program and then use all other post-production programs. All of the modules used in PhotoLab are constructed using extremely precise measurements of actual output files from specific camera and lens configurations. The resulting code is so precise, that the use of processed files in the program can cause unexpected and unsupported results.

The best workflow to use is:


The other post-production programs you mentioned do not contain any of the advanced production code contained in PhotoLab. By following the above workflow, you will find that you can rely on PhotoLab to always deliver the best results possible.

Thank you for contacting DxO Customer Support.

Seth - DxO Labs Support Team 1".

Hope this reply from DxO’s support team answers, or at least gives some clarity to previous questions asked by forum members.

While I generally agree with that workflow suggested by Seth, sometimes a TIFF exported to another program can benefit from further work within PhotoLab - for example, watermarking, resizing, recropping, color adjustments, local adjustments… And the recommendation avoids the problem rather than studies it to determine if the TIFF file is malformed by Topaz software (has happened before) or if PhotoLab’s TIFF handling code needs to be updated. DxO support can do better here.

A possible workaround would be to open the TIFF file in another program and then save it again to TIFF and see if it’s now readable by PhotoLab. It would be helpful to know if that resolves the problem. But I wonder if it’s the size of the TIFF file that PhotoLab can’t handle. How big is that file?

1 Like