Unable to start any new Nik Collection 6 applications after upgrade from NC 5

Hello all, I need your help.

I’m unable to start any new Nik Collection 6 application besides HDR Efex Pro 2, Nik 6 Perspective and both Sharpener Pro 3 Output Sharpener and Sharpener Pro 3 RAW Presharpener.

Trying to start the others (in standalone mode or in Photoshop, Lightroom etc.) results in “nothing”.
The ones mentioned above work as expected in standalone and Photoshop, Lightroom etc.

I have the latest Adobe programs installed and here is a list of my PC configuration:
Processor Intel(R) Core™ i7-3720QM CPU @ 2.60GHz 2.60 GHz
Installed RAM 16.0 GB (15.6 GB usable)
Product ID XXXXX-XXXXX-XXXXX-XXXX (replaced with X)
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

Edition Windows 10 Pro
Version 22H2
Installed on 11/30/2022
OS build 19045.2965
Experience Windows Feature Experience Pack 1000.19041.1000.0

I also installed (upgraded from 5) the collection on a second notebook; same results.

Any ideas how to get this fixed?

Thank you

How about deinstallation and new installation of Nik Collection 6? Maybe this helps? Did you see any of the “non running apps” in the task manager?

I deinstalled, rebooted and reinstalled… all to no avail.

Same behavior as before.

No, non of the “non-responsive” apps show up in Task Manager.

Any other suggestions or any additional information I could supply?

Thank you.

On my side the installation seems partial whereas in Affinity I have access to the whole suite including Corlor FX and Sylver FX which do not appear in Photolab 6
Capture d’écran 2023-05-18 111906

Hello Pascal94,
I also noticed that not all apps are available in the different “host applications”.

This is the log file of Process Monitor concerning Color Efex Pro 5 when I double click it…

Color Efex Pro 5 Logfile_CSV.zip (295.6 KB)
Color Efex Pro 5 Logfile_PML.zip (2.6 MB)

One is in procmon log file format, the other a regular csv file.

Perhaps someone finds it useful and comes up with a solution…

Thank you all.

1 Like

I propose you uninstall NC5 and NC6, reboot and reinstall NC6…or get in touch with support.dxo.com.


Version 5 is automatically uninstalled when installing version 6.

As noted above I uninstalled version 6, rebooted and reinstalled version 6 (which then "sees that version 5 was installed at some point in the past and offers to download it for installation…), all to no avail. Same problem.

Oh, and I did get in touch with support. No reply yet…

Finally with un update to Photolab 6.6, everything it s OK !

… see the extract from the PL 6.6 release notes

1 Like

Hi Wolfgang,
perhaps an update to PL 6.6 would solve my problems with NC 5 Pro (which I doubt) but tbh, I’m interested in using NC 6 Pro as stand alone applications as I’m using Adobe (classic PS CS6 13.01, LR 6.14 and the new CC versions).
I’m still quite happy with PL 4 Elite (or more precisely “unhappy” - I’m a Ricoh GXR and Pentax user and these are either hardly or not supported at all, not even in PL 6.6) and I don’t see any reason to upgrade to PL 6.6.

NC 5 should not be as problematic as it is in the first place and “solving a problem” by having to install a separate program at additional cost is not a viable solution.

BTW, no reaction yet from DxO support besides listing my request as “open”…

Hi all,
just to make it clear, I’m talking about Nik Collection versin 6, not 5 as I might have mistakenly written in earlier posts.

I have problems with the latest version.

Hi Michael,
I’ve not installed Nik 6 and don’t know myself about missing modules etc., but it sounds like a bug.
Otherwise have a look at this video from Robin Whalley.

For problems with Nik, DxO provides an uninstaller, if normal uninstalling from Windows doesn’t help.
BUT – read about how to save your customs presets …

PS CS6 works with Nik 3.x as PlugIn (+ with FP 5) → see …
( don’t know about the ‘newer’ PS versions ).

At present I’m running the latest AP 2.1 with Nik 5 and 3.3 (also FP 6).
→ It was reported somewhere that AP2.1 and Nik 6 don’t like each other.

about your cams

@zkarj uses a Pentax DSLR. Maybe you communicate with him.
For the Ricoh GXR … no idea who you could talk to.


I missed this until @Wolfgang tagged me about it.

I thought DxO’s Pentax support was pretty decent. Certainly all of my cameras excepting the ancient *ist DS are supported, as well as all my relatively modern lenses. I do have only eight lenses, and the three old M series are not supported, but the other five — four Pentax and one Tamron — have been supported for ages.

On macOS, the apps with the reworked UI need resources that have been installed in a completely separate folder. If that folder is absent, incompletely filled or renamed, those apps won’t start. Can’t tell where this folder is on Windows and if it also should exist, but someone with Windows could possibly find out.

See Nik Collection v6 - #14 by platypus for more.

Hi all,
thanks a million for all your tips and suggestions; unfortunately none solved the problems…

I’m in contact with customer support and hope they will find the cause soon (and a solution!).

If / when there is an update to the situation I’ll post it.

Again, thank you :smile:

BTW, I upgraded to PL 6.6 but no change…

Good morning everyone, I am writing to you from Spain.

I have installed Nik 6 just a day ago. After I use Color effects and Analog in DxO 6, the next day these effects disappear.

I have tried to install it again and the error is the same.

This problem does not happen in photoshop.

Hi all,
the DxO support team had me download a “personalized” installer to try.
I had to uninstall NC6, reboot, install the “personalized” version, reboot.

Everything is now working as intended. Both in standalone & plugin mode.

The support team informed me that all the fixes in the personalized installer would be implemented in a future public update.

Thank you all for your help / suggestions.
Thank you DxO for solving the problem so fast and efficiently.

All the best,