This image cannot be processed since the source file could not be found ( After I cloned the Drive )

I just completed a disk clone, that performs an image copy of the original disk, every application ran fine, but when I used DX0 PL5 all the images have an " ! " when I perform a search ( This image cannot be processed since the source file could not be found). I rely on the search application to fine my images, they are all there if I select a file in a directory it’s there. There is a problem with the data base after the disk clone. I backup my drive every 3 months by cloning this ensures my data and drive from corruption, in addition I perform normal backups every evening on to my NAS server. I used WD 2TB drives alone with Acronis tools to clone my drive. the Drive is a 100% copy of the original this is the only application DX0 PL5 that suffers any repercussion. I just upgraded from PL4 to PL5 as tech support team stated this should correct my issue, well it hasn’t, I a Intel i5, Windows 10, WD 2tb drive place over 10,000 photos with all have "keywords " associated then perform a clone, and it forgot.

Is the drive name the same on both hard drives?

I do not want to sound like tech support that asks “Is the system plugged in” But Can you manually find the images on the clone?

1 Like

and “is it switched ON?” :joy:

Wow! I ask for help and get sarcasm, Yes it’s plugged in, yes it’s on, Yes I get the Windows 10 Logo, Yes I get all my icons, including “PL”. yes it’s an exact duplicate, right down to the file structure and file names. technically they identical and cannot tell the difference as they are the same drive maker and model. All the files are accessible if I manually select them and edit them and yes with “PL5” . BUT when a search on a “keyword” is performed it returns with "! " next to the image, then I manually have to perform [ Fix Image Path ] by right click on the image. seems the DOP files some how disassociates with the Database

I suspect (but not 100% certain) that every new hard drive has a unique ID that is used by PL to locate files. If you have a new HDD then it will have a different ID to the old one. I am away at the moment so cannot check this for you.

Maybe you should open a support ticket to ask the question.

1 Like

No sarcasm, just a joke. But if you ask a user forum instead of the DxO support, it might help to imagine you eventually could get answers you don’t like. No one here is obliged to help the way you’d like and no one here is obliged to remain dead serious at all times. :wink:


The one question that you have not explicitly answered is the one by @JoJu of:-

This, when I have cloned drives is vital to maintain search paths in Windows.

By this I mean if I start with a drive designated G that I then clone, once I have removed original drive G and install the cloned drive, Windows in my experience does not automatically designate the same original drive letter. I have to go into Drive Management (with admin rights engaged) to change the allocated drive letter to G.

I hope that is of some help but of course I may, as the expression goes, be teaching you how to suck eggs :wink:

Not trying to be sarcastic.
Just commenting on stupid things that I have done trying to fix software/hardware issues in Windows

Not only you :wink: Sometimes the focus on one specific problem “which has to do with X/Y!” ignores the influence of A, B, Z… :unamused:

I don’t understand exactly what you’ve done. You cloned the disk. But what after that? You tried to run PL on the original or on the clone? Or did you transfer the clone back to the original?


Photo folders/directories are listed in DPL’s database and the root folders/directories are also identified by their UUID.

You could try to reconnect the database to the new drive by editing the database…at the risk of bricking it completely.

I’ve cloned disks to and fro without such issues, but I’m on macOS…

@roman I reproduced the problem as follows, with PL5 shut-down I copied a directory I had been using for tests on the F: drive (Win 10 system) to an attached USB drive using Beyond Compare and then changed the name of the original directory (known to PL5).

I opened PL5 and navigated to the new copy of the directory (on the R: drive) containing an image with a sidecar containing keywords A|B|C or A>B>C as you may prefer. I then did a search on C and PL5 returned a count of 2 but when I clicked on the 2 I got two thumbnails and the first had the dreaded !.

The PL5 database had the references to the original directory still in place (I hadn’t let it discover it had been removed) so the keyword search found 2 entries in the ‘ItemsKeywords’ structure relating to the C keyword but one was pointing to an an entry in ‘Items’ (or ‘Sources’) which pointed to the ‘Folders’ structure with an entry relating to the deleted entry so PL5 got a “NOT found” and reported the situation with a !.

However, you are cloning and returning the cloned drive back into service in a way that must create a scenario similar the one I have just tested.

Please state exactly what your configuration is before, during and after cloning and we can see if we can make it fit my test scenario! PL5 will always discover directories because it is led by the discovery of the directories not the database but the search is driven by what the database “thinks” is (was) the status quo (even when it isn’t, any more)!?

Indeed - and there is no built-in functionality to “sync” the database to “reality” or to reconnect a structure that was moved. Lightroom can do both (and more) due to its database maintenance functions.


Thanks for the input, I normally clone the drive and use the clone to ensure it’s authentic. The drive is an exact copy, you cannot tell the difference. If I did clone your drive and put the clone into your PC you will not know it’s been cloned. BUT DXO checks the drive Serial Number, the only application I have that does this. If I kept the original in place and did not use the clone, then this issue would not have presented itself, as the SN of the HD is the same.

If you plan to upgrade your drive or the PC, don’t be surprised if you perform a search for Keywords and fails.

I did Open a ticket with DXO read below

Just read your manual on page 241, there is a topic

Can I transfer the database to another computer?
*No, because it contains not only the location information of the images, but also information about the computer’s hard disks, such as their serial numbers.

My question is there a way to disable this “flag” in the database, there are others out there that upgrade their hard drive to a larger drive, in my case every few months I swap and clone drives for extra protection, in the event of a drive becoming corrupt, or virus, or in the future want to install a much larger drive.

Today at 09:23

Hello Roman,

Thank you for writing back. No, not at this time. The flag cannot be disabled.

We will be happy to pass along your interest in this capability to our development team for their consideration. A suggestion on your behalf will be automatically created and sent to the developers once this ticket is closed.

If you have not already done so, may we also recommend that you subscribe to our e-mail newsletter. It contains information about new features, new camera support and updates being added to our programs. You can subscribe to the newsletter at this location

DxO Newsletter

Thank you for contacting DxO Customer Support and please have a good week. If you should need additional assistance with other program related issues or have any other questions, please do not hesitate to use our online support system.

Seth - DxO Labs Support Team

When you attach the clone as the drive of choice do you put it in place of the original drive, i.e. are you always working with a single drive letter F: in my case and where is you database located, i.e. the same drive as your data (which would imply that you are keeping the drive letter the same because otherwise you would have to change the database location in the DxPL options).

Nowhere have I seen the drive serial number in the database what I see is the Drive letter!?

The UniqueId is put there by DxPL I believe, whether it is then used to access some other file?

If a drive serial number failed a check by DxPL then it would flagged immediately, hence, I need to know how you connect your perfectly cloned drive and start to use it as you new image and (possible) database drive. To be honest I don’t believe it needs to be a clone (you can copy the drive id with some cloning software but that has caused me more problems than it is worth in the past).

I believe that all you need is a simple copy and with products like Beyond Compare that could be an incremental update. That type of update would not read to and write from most of a disk so that kind of assurance would not be guaranteed but it would be quicker.

I believe that the following are possible but I never tested them with the search function, i.e. I may have thought it worked successfully but only within the scope of the tests I ran!?

  1. A USB drive with the database and data on the same drive was taken between two systems and attached with different drive letters seemed to work perfectly but DxO never got back to me with a reason why this seemed to work.

  2. Both of my machines accessing a third (spare) machine which held the database and the images!

  3. Others have reported a similar result for a NAS drive (holding both the database and the image files) but I ran into problems with my DS220J with a permissions issue right from the start and abandoned further attempts.

@platypus if you look at the table in the post above you will see that the drive letter is at the head of an hierarchical set of directory names. While you have been campaigning for a more comprehensive set of housekeeping capabilities, for those of us that keep cloned or duplicate copies, in my case F: (Main), V:(mapped to Test), J: (USB 3) and R:(USB 3) ( the photo files are now too big to go on the NAS), “all” that is required @Musashi and @sgospodarenko is to change F: in the ‘Folders’ structure, I believe, e.g. to V: or J: or R: in my case!

Unless someone has tucked something away in the config file (for a “rainy day”).

Reconnecting the database with a moved or cloned image folder is something that should come along as a housekeeping feature of the product imo.

On macOS, UIDs of the respective volumes are used instead. The UID is defined by macOS.


@roman and @platypus I just ran a test that did not have the results I expected but there were no missing rather I had twice as many as I hoped for!

I recently purchased two new USB 3 drives, one had already been attached to the machine so the other came out of its box and was also attached to the system as Elements-1 and Elements-2.

  1. Cleared database etc.
  2. Copied 4 JPGs and 4 RAWS to Elements-1 (K:)
  3. Opened the directory on Elements-1 in PL5 and set up my 4 scenarios twice once for the JPGs and once for the RAWs.
  4. Closed PL5
  5. Copied the directory from Elements-1 (K:) to Elements -2(L:)
  6. Changed the mount point for K: to Z: and for L: to K:
  7. Opened PL5 and made a search and received twice the number of hits I expected.
  8. On examination of the hits (all O.K. and no !) some were for L: and some were for Z:

Hence PL5 had “tracked” the original K: drive to its new mount point of Z:. The changes were done through the Win 10 Data management screen but I do run Zentimo to manage USB drives!

I need to repeat the test with the Z: drive taken offline before discovering L: remounted as K:.

I don’t know why or how PL5 is tracking the K: drive to Z: but I am hoping that there is a DxO guru who is prepared to spend a few minutes looking at this @sgospodarenko.

In the meantime (when I have time) I will repeat the test (already the second time with the same outcome) with Z: offline to see what happens.

But I believe the issue if with drive lettering (mount points).

@roman (@platypus) I have tried many different things with the two USB 3 drives which finally included having exactly the same names and mapped to the same Drive Letter and finally with the database also residing on the same disk but on every occasion I wound up with this or variants thereof

Essentially PL5 is simply re-discovering the files and treating them as new. I get a mixture of half with the “!” and half O.K. but that is because I am using just the one small directory and starting out on it after the drive swap etc…

Hence, old data will continue to be linked to the original ‘Folders’ entry and the newly discovered ones to the new entry but exactly why PL5 cannot find the original entries in spite of the fact that the old and the new are identical I do not know @sgospodarenko.

Although we are asking for a feature to allow data to be re-synchronised I can’t help but wonder why this is happening in the first place!?

Are the checks that are causing it actually necessary, i.e. what are the tests supposed to protect and can they actually be relaxed so the product works in a way that appears safe and logical, albeit with warnings to the user etc…!? If the checks are relaxed then the work necessary to re-synchronise simply goes away!