Sony A7CR still no RAW on 7.1.0 build 35

This seems to be an OSX issue. I’m not having any luck with PL import. I don’t have PR. my workflow would ideally be RAW direct into PL.

So close. Can’t wait to get this finalized, the quality of this camera + PL is going to be incredible.

1 Like

@kgstettner We can open the ARW image (the RAW of the Sony A7CR) and the dng without any problem in PhotoLab 7.1. We need your logs to investigate further. Could you, please, create a ticket via You’ll be personally assisted there.

Created a ticket, thank you !

1 Like

Created a ticket as well. Still trying some things on my end. @kgstettner if you get any insight, can you share here?

Sure - havent heard anything yet

I just started a trial of PL 7 (7.1.0 build 35), coming from PL6 (6.11.0 build 59).
My A7C II .ARW (Lossless L) files that worked perfectly in PL 6 won’t open in PL 7, saying that my camera is not supported.

Screenshot 2023-11-12 at 09.31.53

I tried deleting everything DxO related in ~/Library but it didn’t help.
If I modify the exif in the .ARWs to set the camera model to ILCE-7RM4 (A7 IV), the files open perfectly in PL 7.

Does anyone have free software for OSX that can change exif? Im really against having to purchase more software just to work around this glitch.
Also annoyed every time I have to use Sony’s software, and export as TIFF.

I’m having the exact same issue on my A7C II. All uncompressed RAW. I’ve tried this with the latest versions of Photolab, Filmpack and Pureraw. All say it is incompatible.

1 Like

Install exiftool with brew install exiftool if you have Homebrew installed, or get the .dmg package from
Then open your terminal and:

cd /path/to/photos
exiftool -model="ILCE-7RM4" *.ARW

You are a saint.

Edited to add: This approach also works for DxO PL, which shows how simple the solution truly is, unless there is far more to the process than updating software to recognize data.

Well only a workaround - not a solution.
The proper way is to let DxO sort their identification bug as they have sensor specific profiling and processing based on their lab measurements.

So even though this do work to get PL to accept the raw files, it’s not what I would do.
But it is up to each and every one to do what they belive in. :slight_smile:

It just hit me that you want to use ILCE-7RM5 (A7R V) instead, since they have the same sensor. Hopefully we will soon see a new PL build from DxO that fixes this bug, though.

Yes, that combination works fine for me in the latest PhotoLab 6, but not in the latest PhotoLab 7.

@Per thank you! This worked perfectly. I’m annoyed that I have to change the exif to make the tool work but I’m now running it after export to re-embed the correct camera model.

Same problem with my A7CR

As not having a raw-file from this camera, I went to depreview to get a pic taken with a(ny) supported lens, downloaded the corresponding lens modul in PL6

as well in PL7 (you see, it’s the → same modul)

and camera + lens had been recognized.

If one feels to download / install several modules …

In Windows the modules will be stored in

left: with corresponding modul installed ← || → right: modul removed

in that case showing up in PL7

I installed a PhotoLab 7 trial on a Windows 11 computer and my files open just fine there, so it really seems to be a problem specific to PhotoLab 7 for Mac. The latest Windows version is 7.1.0 build 94 but the latest Mac version is 7.1.0 build 35.

1 Like