Silver Efex Pro 3 is a mess!

My system: MacBook Pro 2015, 2.8 GHz Intel Core i7, 16GB, 10.14.6 Mojave.
I am working with PhotoLab 4.3 and Nik Collection. 3 days ago I have upgraded from Version 3.3 to 4.

After working a lot with CEP yesterday, I wanted to use SEP today. Unfortunately, this is impossible, SEP is unusable. Each correction takes several seconds until it becomes visible. There is no idea of fluent working, SEP is a complete and utter disaster now, I am totally pissed off. :rage:


Hi Manfred. Your experience is not typical - - I suggest you raise a ticket with DxO Support (click here).

John M

I read about many problems concerning SEP3. Both under macOS and under Windows. I’m afraid I’m not an isolated case. I will uninstall Nik Collection 4 and return to 3.3.
BTW: I don’t think it’s a coincidence that all webinars regarding Nik Collection have been cancelled: Webinars - Nik Collection dy DxO


Quite agree with you here, SEP3 is unusable given the number of bugs. I’ve submitted 2 tickets with three problems already and no response yet (they must be busy as support is usually good).

I’ve downgraded again to Nik 3

I guess that if the bugs aren’t fixed, I’ll request a refund.


I found that reinstalling version 4 - over an already installed version 4 - makes SEP 3 faster. Maybe worth a try.

It never hurts to reinstall software that is giving you problems.


Well, I’ve just had to submit a ticket over Silver Efex Pro 3’s performance. First time I’ve ever had an issue with it in a decade of use, but having to wait 4-5 seconds for a control point adjustment to appear makes it unusable. Working with Lightroom Classic as I can’t get it to work at all in Photoshop 2021.


Have you tried to reinstall Version 4 over an already installed version 4?
By the way, an update is supposed to be released today.

Yes, and with the update released today, same slow speed except it now crashes if I open it in Adobe Photoshop 2021! Issue is very much control points, performance is better (though not as good as previous version) if I don’t use them, the minute I add one, both control point and global adjustments run at a snail’s pace. Get the same result opening it from Capture One.

My experience with performance is much the same as yours. Running it standalone or from Affinity Photo I have found the time lag when using control points to be such that the Silver Efex Pro 3 is a frustration. I was pleased with the Silver Efex Pro 2 and enjoyed working with it. I am not being a wise guy when I say this but I believe the best fix they could make for me would be to pull out Silver Efex Pro 3 out of the Nik Collection and put Silver Efex Pro 2 back in so that I could at least work on B&W conversions. As it now sets for me I’ll have to go to other products to get the job done. Will they be as good as Silver Efex Pro 2 - absolutely not but they darn sure will provide a better experience than I currently get with Silver Efex Pro 3. I’ve been a customer for many years. I own each one of your products except for Pure Raw and always have kept up with updates. This situation will be on my mind when I consider updates for any DxO software in the future. This is the first time I have been disappointed in an update of a DxO software product. This product was in my opinion not ready to be released. If Nik Collection 3 was still available for me to download I’d go back to it. But, it is no longer in my software account here at DxO.


I understand your frustration all too well. I have noticed that when I install version 4 over the already installed version 4, it helps with the speed of SEP 3.

Additionally, I missed the previous version in my account as well. A short message to the support team and they will send you a link to download Nik Collection 3.3 again.


Thank you very much for that information. I’ll get Nik Collection 3.3 running on my laptop and use that for B&W conversions and keep Nik Collection 4 on the desktop and use it for everything but B&W conversions and keep trying as they make releases to it. Appreciate the information.



Interestingly, if I uncheck the use GPU option in SEP3 preferences, restart it, then check it again, it seems to have improved the performance with launched from LR Classic. Still crashes if launched from Adobe PS though,

Think I’ll be reinstalling SEP2.

1 Like

Sorry to be negative but I have been using Silver Efex ever since it appeared on the market originally through PS later stand alone and now through DXO Photolab. The beauty of the control points was that the sliders were right were your eye would focus and it worked perfectly well as an old fashion dodge and burn tool in the darkroom. One could work they way around an image and do quick adjustments very efficiently. Now your eyes are in one place and the sliders somewhere else which on a large screen can even be outside you peripheral vision. A precise professional tool has now become a toy. It may be ok for some general adjustment but if you are balancing tone and texture locally. The time delay is also far too slow and this is on abrand new Mac Book Pro with stacks of ram. to make things worst if I try to launch my stand alone older version it now takes me to the web site and say it will overwrite with the new. No matter what ever clever new algorithms have been introduced the UX of the product has been neglected its nothing sort of pure vandalism. I hope someone can tell me how I can at least get Silver Efex Pro 2 back and install it as a stand alone PLEASE


If you contact the support team, they will send you a link to download the previous version of Nik Collection. I did it this way.


Thank you I will try

Like everyone else here I am in agreement Silver Efex Pro 3 is an epic failure! DxO software is ALWAYS buggy. Eventually they straighten things out and they more more or less. But this new update is a disaster. I have submitted three tickets and am still waiting for a response.

1 Like

Silver Efex 3 is DEFINITELY an epic fail - I bought my copy on the 2nd June and it’s never worked from day one. The support guys, who are usually very good, have stopped responding to my tickets / emails…

Anyone got any idea when the next release will be?


Same here - on Mac BigSur, for the last ten-plus years Nik silver was perfectly fine, … now with paid-for upgrade to PhotoLab 4 and Nik 3 and tool panel 2, when activating SilverEfex, the SilverEfex panel opens fine, but the image remains hovering on top of- and covering the SilverEfex window - with Photoshop unresponsive-beachballing, thus with the SilverEfex underneath being unusable… - then, when force-quitting PS, SilverEfex is usable with the image able to to adjust - though also pretty much unworkably with the adjustment lag-delays… then when ‘apply adjustments’ to close the image, there is no option to ‘save-as’ or find the adjusted image afterwards… thus, useless -
As well, the move of the adjustment-point- sliders into a side-panel away from the actual point means we now have to perform a click to activate the point, then scroll of the panel to make the desired adjustment- slider visible, then slide by having to alternate attention from the image to the panel and back and forth… A Very Inefficient Workflow compared to previous -
Will surely have to find a way to get the previous version of SilverEfex back - :frowning:

I totally agree!