Returning image to PL MAC

Just edited an image in Color Efex from PL and when I finally save the image the thumbnail created in PL does not show the changes, neither does the underlying image when opened. However once I have closed and reopened PL all is well (this is on 2.1). Seems to be an update problem somewhere?

Push the F5 key.
Maybe you need first to click the thumbnail.

If I open the thumbnail it does not show the changes unless I restart the app or move to another folder and return. Will try f5

F5 makes no difference either. Am on iMac running Mojave.

Hello guys,

This problem exists on MAC but it will be fixed soon. You can read about it here - I guess I give up

Svetlana G.

Yes. This has been a problem on the Mac side for at least the last 5 years but apparently is being fixed in this major release, although perhaps not until the 2nd minor update.

There is a workaround that I have been using and that is to save the externally edited image with a different name than the name sent to the external editor. For example, Dxo appends _openWith to the original file name when it creates the file it sends to the external editor (for example, it renames Img0001 to Img0001_openWith) and when I save that image back to the original folder I changed the name to something like Img0001A. It then becomes a new image in the folder and PL2 recognizes it and opens it as a new image.

There is one issue with doing this and that is that PL2 wants to apply its initial preset to this “new” image and so I have my version set up to apply the initial preset only to raw images (which is what I edit) and not to apply it to RGB images.

This is not a perfect solution as it causes some issues if you are editing RGB images instead of raw and it adds a large number of fairly large files by forcing you to duplicate the externally edited image, but it does work and is suitable for me until they fix this issue.

Thanks Mike, that approach will be useful. I had not thought about the initial presets - going the raw only route seems sensible. I have changed my prefs accordingly.

Hi Svetlana, has this been fixed in the latest update (2.1.0 - build 14) on Mac? If so I am seeing no change here in that the image is being returned but is not updating/refreshing the DPL tiff automatically. Also when working in a Project folder I can export a tiff to a Nik but that tiff is not being shown in the Project folder. It shows in the “real” location however. Equally when the edited tiff is returned to DPL it suffers the same refresh problem but still only shows in the “real” location. I have been exporting to Color Efex.

I am running a fully updated Mojave on a late 2017 iMac 4K.

Thanks :slight_smile:

Further update. Having now done this many times I can say that is seems to be spasmodic, sometimes it works and sometimes not. The issue with Projects is constant in that created tiffs are not displayed in the Project.


For me this release has been a puzzle.

As I wrote in a different thread all of my external editor changes showed up back in PL2 after saving them, and I thought and posted that the fix had showed up in this release, but today none of that works. I am assuming that something about the installation may have caused the changes to show up but when I shut down and rebooted this morning those conditions have changed and now none of the changes are showing up back in PL2.

What that might be I do not know, but PL2 is back to working as it did before the update (that is, the changes do not appear) and now I am back to hoping that the fix shows up in the next update.

Some additional information:

I have the latest version of PL2 installed, but I downloaded the dmg file for it and re-installed it. After doing that I edited a series of raw images, exported tiffs to PS, edited them and saved them back to the same image. All of the changes showed up back in PL2.

I then rebooted my Mac (MBP, High Sierra) and again tried externally editing my images as before, but this time none of the changes showed up back in PL2. So the reboot did something to my system and caused the changes to no longer show up when saved back to PL2. I am guessing that there is something important hidden in those facts but I do not know what they might be.

Unless I am willing to reinstall PL2 every day I edit images I guess I have to wait until the next update and hope the fix is in that.

Pleased it is not just me, Mike. But still disappointed. I have found sometimes it works and sometimes not. More often not. I also have problems with the link to Lr. Not impressed thus far. Maybe the devs are trying to do too much,

> Maybe the devs are trying to do too much

Perhaps I am a bit closed minded about this since I need it so much, but being able to reprocess a returned image does not sound to me like too much. Every other tool does it.

I have been experimenting with the new version to try to see if I can pin point what sequence of operations allows the returned image to be seen correctly in PL2 and so far I have found some very strange things, and I suspect that some of them are pointers to the source of the problem.

For example, I noticed that I could send an image to Photoshop, edit it and return it, and not see the changes. I then went on to another image, edited it in Photoshop and returned it and, much to my surprise, the first image now showed up with the PS changes while the second did not. I then edited a third as with the others and, when I got it back, the second image now showed up properly. It all seems very odd.

I also noticed that if I reinstall PL2 and then use it the changes show up, but if I exit and restart PL2 (or reboot, which I suppose does the same thing) the changes no longer show up.

Hopefully the developers will fix this issue or, I suppose, I will move to AlienSkin. C1 has gotten far too expensive for me to use and AlienSkin, although not as good a raw editor as PL2, does at least allow me to work in my normal workflow manner.

There certainly seems to be a significant issue as I have also been losing images coming back from DPL to LR. I always worry when software companies try and change direction/take an app to the next level in that it always seems to give rise to problems that impact the original implementation and therefore the longer term users. it is a difficult one for pressure on software houses to deliver change quickly is relentless. It gets worse when these bugs cannot be fixed quickly. Hence my decision of ages ago) to stick with Lr.

Tried Alien Skins once - hated the shadows and highlight sliders (in fact hated the raw development in general). The rest of it was fine and they certainly are improving the software at a controlled pace.

Hello Colin,

Judging by Fred’s reply (I guess I give up) it will be in the next release but not in the current one.

Svetlana G.

This might be a side effect of some kind from something else we worked on. There were a few supporting components to the bug fix itself, some of them being in 2.1.0, some of them not.
But I can definitely confirm the bug fix will be in the version that comes right after 2.1.0 (along with other stuff), and it should support all cases properly.

Good to know and many thanks for that.

Quick question, is the “round trip” process that applies to the Project folders supposed to be the same as applies to the main folders?

Is that the issue you’re talking about:

when working in a Project folder I can export a tiff to a Nik but that tiff is not being shown in the Project folder.

Yup that’s the one :slight_smile: