Preset preview not showing since last uptate (Mac)

Hi,

The preset preview is not working anymore for me or randomly. When I click on the preset button at the top-right corner of the window, I have the complete list (the built-in ones and the FilmPack 6 Elite edition ones). But when I open a category the thumbnails show a greyed version of the original image with a static spinning wheel. For some image, some categories or part of categories are behaving OK.

I think the problem appeared when I updated to the last version released 2 or 3 weeks ago.

Thanks for any help !

Hervé

1 Like

Tested on DPL 6.8.1 on macOS 12.6.8 on 5K iMac 2019.

  • Issue with presets that depend on the FilmPack license
  • No issue with presets that can be used without FP license

Same issue with DPL 5.13.1.
No issue with DPL 4.3.6 though.

I then deleted the database and cache files and tested again

  • DPL4: no issue
  • DPL5: some of the FP previews came up, but not all
  • DPL6: none of the FP previews came up
1 Like

Let’s hope DXO is going to solve the problem. I uninstalled the last version of PL and installed back again. Same problem + now PL is crashing randomly! I am fed up!

I will send a message to support.

Hervé

1 Like

Hello , same problem on my side !
Display of presets not effective since the last Update.

Refresh previews of presets no longer display after some time of use. I tried several sequences of uses to determine a possible root cause, but a priori it is a random bug. I had never encountered it before the last update (5.13.1 build 95). A restart of DPL solves the problem for a while, but it comes back…

I have sent a message to support also … wait and see …

I am glad I am not the only one with this problem. I am sad that such problems are occurring when new updates are released.

I am still waiting for the support team answer.

Let’s hope it I’ll be solved soon, it is annoying!

Hervé

I had an idea… Since I have a TimeMachine backup, I grabbed the PhotoLab 5.13.0 app… I kind of rolled back… And it works! :slight_smile: Joy ! All presets are displayed!
I think I can share with you the application (1.13Go) in version 5.13.0… Just rename it and install it next to the most recent one… And launch this one… . :wink: Tell me if you’re interested, I’ll make you a link … :wink:
!
Capture d’écran 2023-08-18 à 18.14.29

Thanks for the proposal. I have got PL5 still installed on my machine, I told support that it is working fine. Being French I always liked to support French companies but I feel that the updates are not as carefully crafted as they should.

Hervé

2 Likes

Moi aussi Hervé j’aime bien DXO et je les soutiens depuis fort longtemps, ( mise à jour payante régulière ) et je ne doute pas qu’ils vont faire une mise à jour pour corriger ça rapidement. En général ils sont très réactifs …
Je pense que la maintenabilité de tous leurs logiciels représente une masse de travail non négligeable ! D’ou peut être des mises à jour parfois perfectibles ( mais c’est rare :wink: )

Comme dis, j’ai downgradé en 5.13.0 pour retrouver PL de façons pleinement utilisable … J’attend le correctif pour faire de nouveau la mise à jour .
PS : Je proposais le partage de l’appli juste pour que vous puissiez revenir à un PL utilisable, l’application ne contient pas la license … :wink: Ce n’est pas une sorte de proposition de “piratage” :wink:


English version :

Me too, Hervé, I like DXO and I have been supporting them for a very long time (regular paid update) and I have no doubt that they will make an update to correct this quickly. They are usually very responsive…
I think that the maintainability of all their software represents a significant amount of work! From where can be updates sometimes perfectible (but it is rare :wink:)

As said, I downgraded to 5.13.0 to find PL in a fully usable way… I’m waiting for the patch to update again.
PS: I was suggesting sharing the app just so you can get back to a usable PL, the app doesn’t contain the license… :wink: This is not some sort of “hacking” proposal :wink:

Same here. Too many of the presets not available to preview since the latest update. Just emailed the support.

@HerveB Hello everyone !! This issue is being fixed. The fix will be available in the next version of PhotoLab. thank you for your understanding

3 Likes

The issue seems to have been fixed with the yesterday’s update. All good now.

1 Like

It’s gone in DPL versions 5.14.0.96 and 6.9.0.55 on macOS. Thank you.

Problem solved in 5.14.0 build 96 … :slightly_smiling_face:

New user here. On DXO photo lab 7 on a M1 Mac studio max the apply preset drop-down menu does not show a thumbnail preview of the presets.

I can confirm this on Ventura PL 7.5.1b49…

Just a spinning wheel. Then it takes a long time to recover being able to use, or even close, the app.

@Cecile-C - a gentle welcome back from the Easter break - now there’s work to do :stuck_out_tongue_winking_eye:

1 Like

Hello, we can reproduce it here, so we’ll look closely into it. In the meantime, a workaround is the use the “Apply Preset” button at the top right of the window instead, as this updates the previews correctly. Best regards

1 Like

I can do too. With PhotoLab versions 5, 6 and 7, all of them in current versions on macOS Sonoma 14.4.1 on 5K iMac 2019.

Thank you for this additional information

1 Like

Hello, Can you please try on your side and see if you still have the issue?

Preset previews show as expected in DPL 7.6.0 on macOS 14.4.1 in 2019 iMac.