Possible Healing Bug - PL6

Weird one just now that I’ve not come across before.

Unable to pin point any real cause other than Computer or in this case PL6 suddenly deciding ‘nope, not happy’ whilst doing a spot of ‘healing’.

Screenshot says what it needs to for now until DxO ask for more if I can even provide it…

Error appeared on the last two ‘new stroke’ actions. It actually happened on the 1st but went away however no ‘healing’ took place. Tried again and ‘lost’ the picture until rolling back those two steps in the history.
Without doing that the picture was completely locked.

Obviously not the end of the world as using the Advanced History panel got me out of it and I was working on a Virtual Copy but would have been somewhat annoying to have potentially lost the whole edit so far had stepping back in the history not worked.

For reference. A restart of both PL6 and Mac made no difference and also copying edit and applying to another VC carried whatever across with it which I kind of expected but was worth a shot anyway.

Again for reference after stepping back two actions I can continue to edit the file, so again not all is lost but clearly something went wrong which DxO may or of may not want to look into unless this is something known to them or indeed others.

Hello @Lost_Manc ,
Could you upload your oiginal image and *.dop sidecar to our file server at the following URL:

Please, fill in all the fields using your Forum User Name. Please advise in your reply in this thread to confirm that the files are available on our server.

1 Like


I have just uploaded the raw & .dop for the image in question.

For a little further information since my original post.

The image is cropped.
The area I was attempting to ‘heal’ was near to the edge of the crop but still enough useable space to take the ‘repair’ from although I believe that it will sample from outside the cropped area anyway.

I have added another screenshot to highlight the area I was working on when the error occurred.
After rolling back I made a couple of test tweaks (Master curve change and then reset) to see if I could continue to edit. These have over-written the to healing strokes in the history panel. Does/will that matter?

Beyond exporting a copy of the progress so far I haven’t continued to work on the image in anyway so can’t say if I will/would encounter any further issue(s).

Screen-grab of area I was working on when error occurred. I was attempting to remove the twigs.

Ok. seem to have found more issue with healing.

Heal one area. Move to another click ‘close’ and anything healed before the last area returns. The edits are not committing.

Very strange.

Thanks for your files, we’ll have look into it

1 Like


Seems in relation to my previous post regarding healing un-healing itself it only does it on that specific files so assuming whatever went wrong and resulted in that error message has completely made that files essentially useless.

I’ll probably delete the .dop and start again.

yes, it does – tried it w/ the clone tool (hard edge) and was positively surprised

1 Like

(Assuming you’re using the DxO database, then) that may not help, L-M … because PL will (probably) “recognise” that image as existing in its database, and will reapply the stored corrections.

If you find that’s the case then (as well as deleting the sidecar/.dop file) also rename the RAW file-name - from outside PL, with PL not running - - so that PL will create a new database entry.

John M

1 Like

Yeah. Poorly worded/explained post by me.
I intended and indeed have deleted the DB as well as the DOP.
To no avail. The issue remains.
If I get time later which is unlikely with work I intend to do some more experiments.

I’m currently only testing with 5 pictures and although I have issue with the picture in my OP I’m experiencing issues with the healing/retouch tool much deeper than my original issue and on all 5 files.
I’m going to dig some more files out to check and hopefully rule out those RAF/RAWs being an issue and also try some from another camera however I’m thinking healing/retouch is pretty much broken at present.
I just need the time to do some more digging before I commit to a definite opinion one way or another.


Ive made a new thread here as believe this issues is bigger than first thought and to hopefully get the attention of more users to test/check.