ReTouch Broken PL6

Apologies for starting a new thread but my original has received little input from other users however DxO have stated they are looking into it however I was reporting a different (or so I believed) issue when in fact I think they are now related and that ReTouch is effectively completely broke or at the very least for me for some reason.

Again. Apologies but this is going to get a bit picture heavy but its the only way I feel I can accurately display the issue and then hopefully others can recreate and maybe DxO can then also investigate and resolve either for me or indeed everyone.

Background first was an unexpected error message whilst ReTouching/Healing an image that then resulted in said image being effectively ‘locked’ and no further editing available until I rolled back on the history.
I came back to that image to continue editing yesterday and started to notice more issues whilst using ReTouch/Heal.

Today to rule out either DxO PL6 being a bad install I deleted the program and all associated files I could find and reinstalled the program.
I also created a completely new directory and added the initial ‘problem’ picture plus a couple of others one from a completely different camera brand (Nikon/NEF) to rule out hopefully it being an issue specific to Fujifilm/RAF.

All testing I have now done indicates that the issue doesn’t care what type of RAW its dealing with and points to an issue with DPL6 and the ReTouching tool.

Basically then, if you zoom in to ReTouch the image and then move to a different area of the image that puts the original ReTouch no longer in the zoom section then that initial ReTouch will be deleted. Move to another area and if the last one is no longer in the view, thats gets deleted and so until you get the error message shown in screenshots below.
Another issue is that when you select the new ReTouch and an old one gets deleted then the new one doesn’t always get logged in history and when you zoom out or otherwise move around the screen the ReTouch point follows you.

Hopefully screenshots demonstrate better and that others can recreate also.

Fresh image…

First ReTouch…

First new Retouch on new part of image/screen…

Note the Advanced History shows a ‘Stroke Removed’ and also note that the ReTouch hasn’t crated a ‘New Stroke’ and also isn’t showing where it has sampled from.

Added another ReTouch whilst here. Note still only one "new Stroke’ added but should be two really.

Here’s our first ReTouch now removed…

Move to a new area. Stroke removed from the previous area…

New trick time though. Zoom out to view the whole image to try and see which ReTouch it removed and we now get…

Which is the stroke I just made but most definitely not where I made it!

Click on it to delete and…

So that was a Fujifilm RAF. Time for the Nikon NEF.

Some random ReTouches…

Ignore the previous history I was trying different things but realised it was going to be too many screenshots!

New ReTouch…

Zoom out and…

Original Retouches all removed and no ‘New Stroke’ added to History.

Another image to highlight again the randomly moving ReTouch point and as a bonus the Error too.


Zoom out…

Click the ReTouch to delete/move, and…

And some silliness!

It seems you can add as many ReTouches as you want at a specific zoom without any being removed until…

The clues in the Advanced History!

All gone barring the one just added that according to the History hasn’t been added and one other random point.

So if you’ve managed to put up with all of that, well done, and hopefully someone either tells me I’ve wasted a load of time and am doing something silly and I can go away and feel stupid or others can recreate.

To me though that has to indicate something is completely broken within the tool. This can not be expected behaviour surely?

@Marie @Musashi @Barbara-S Tagging as the only names I can immediately think of as active often.

Edit to add:

Issue first occurred under 6.0.0 but these tests where all done using 6.0.1.

I am running macOS Monterey 12.6

1 Like

Yup. I have kinda the same/similar experience with the refurbished Retouch-tool in PL 6.x. It is essentially gloriously dysfunctional.

( … macOS 12.6 )


Glad it’s not just me then!

And for the time at least it’s…

2 x MacOS 12.6 users.

Might point to a specific issue with the Mac version of DPL6.
Hopefully some Windows users can check and confirm either way if they are having issues or can recreate.

1 Like


The files used are raw files from Canon R6 and 5DSR. The retouch tool is consistenly dysfunctional with all these files.

Little bit more to add.

Tested same files in DPL5 (copied files to new directory minus .dop so should be seen as ‘new’ to DPL5) and had zero issues as I expected but just wanted to rule out for myself more than anything.

Also realised I’d only tested the ‘Repair’ part of the new ReTouch in DPL6 so I repeated the tests on one of the pictures but used ‘Clone’ this time.
Not sure I really expected it to be any different and it wasn’t, but wanted to check to be sure.
Exactly the same scenario plays out regardless on ‘Repair’ or ‘Clone’ being used.

As it stands until this is solved/clarified/whatever I will stick to DPL5 or resort to having to repair/heal/clone/whatever in another program which is a shame as the ReTouch shows itself to much better (when it works!) than the old version.

1 Like

Tried it w/ a NEF-File – no problem like yours.
Everything silly I was doing w/ the clone and repair tool was still there when I went back to see the complete pic.

BTW, I didn’t watch the history. In Windows it is not permanent.

1 Like

I’m just guessing here but I just tried to recreate your problem on Windows and I could not recreate it, so it is definitely Mac-related. I noticed in your screenshots that you are using the “add a stroke”(with the little + sign) command instead of the “create a new Stroke” command. I’m thinking that this may have something to do with it. Could you try again and always use the “create a new stroke” button for each new stroke? Regardless of the outcome the Windows version does not behave like this and the problem certainly needs to by corrected for the mac version.

1 Like

Cheers for trying @Wolfgang indeed looking like a Mac related issue.

Likewise @rrblint thanks for trying.
As for the shots showing the plus sign. That was just a case of the shift-command-3 screenshot shortcut in MacOS.
Every stroke was done as an individual new stroke.

Certainly looking Mac related at least until a Mac user states zero issue.

So far then…

2x MacOS 12.6 users with issue.
2x Windows 10/11? without issue.

Just realised what you meant here. At no point did I actively select the ‘add a stroke’ command but indeed it is selected.
I was thinking the repair point was showing a plus which it briefly does when doing the screenshot command but I now see you mean within the actual tool (second option).
Like I say, I never actively selected that tool/command.

I will hopefully look further tomorrow and see if it’s switching to it of its own accord (I’m assuming it shouldn’t?) and if it is, again, it appears to only cause issue whilst zoomed in.

I seem to recall both @platypus and @Joanna are Mac users. If either are prepared could they have a look and see if it’s me being stupid or not!

1 Like

I am using Macs indeed…and when I use the ReTouch tool in both modes, they work as expected in DPL on macOS 12.6. Shifted and zoomed the image and the source and destination masks changed with zoom level and moves - with just a tiny little bit of lag, which is expected too.

Can you reproduce the issue?

1 Like

J’ai également ce problème avec mes raw (NEF) sur Mac OS 12.6 et PhotoLab 6.0.1 : les retouches disparaissent sur certaines images d’un même dossier. Mais pas sur d’autres images, ce qui paraît bizarre.

1 Like

I can reproduce the issue all day long. Doesn’t matter what I do or how many different files or formats RAF/NEF/JPG I try exactly the same outcome.

@rrblint just had another look. Every stroke is a new stroke and not an addition. The screenshots are definitely like that due to the screenshot shortcut (shift-command-3).

En supposant que Google Translate ait fonctionné, au moins 3 d’entre nous rencontrent ce problème. Quelque chose doit être lié au problème pour nous que les autres utilisateurs de Mac ne sont pas affectés. Bizarre en effet.

(Assuming Google translate worked then that is at least 3 of us experiencing this issue. Something must be linking the issue for us that other Mac users are not being affected by. Bizarre indeed.)

I will attempt to upload a screen recording later but will need to convert it as the site doesn’t seem to accept .mov files.

Use a sharing service like dropbox, onedrive or - Send large files securely and free of charge

I am a new user, I just got DxO Photolab 5 a few weeks ago and have purchased the Photolab 6 upgrade. I’m happy I didn’t uninstall version 5 because 6 is unusable for me. I am on a new Macbook Pro M1 running Monterey 12.6.
I am having the same issues as the OP. The repair tools are completely broken for me- erasing my edits, not showing edits, randomly populating the screen with red plus signs…
I have come from using Lightroom then Capture One. I believe I like Photolab better, but v6 is very buggy on my Macbook!

1 Like

No need in this instance. I just ran out of time to convert. Hopefully this works and gives everyone who isn’t experiencing this and hopefully DxO when/if they pick up on this thread an idea of what some of us are experiencing.

Keep an eye on the Advanced History panel.
I make 3 strokes then move to a new location and make a new one.
immediately it deletes a stroke as evidenced in the history pane but doesn’t add the new stroke to history.
From that point you can then easily see what goes on.

Likewise I have more of a background with LR although have dipped in and out of PL since Fuji support arrived.
Its definitely ‘better’ at what it does than LR imo but this obviously needs addressing if possible.

Hopefully DxO staff pick up on this today.

1 Like

I happen to have both a Windows machine (private, used for PL normally) and a MacBook Pro 2019. At first I was going to report to you did I couldn’t reproduce. But the longer I tested it on my MacBook, the more ways I found to reproduce it.

Please note: before each test I deleted the DOP and the PL6 database to make sure PL6 was in its maiden state. Not something you want to do on the machine you’re using for your ‘daily’ processing.

At first I thought it worked well, as you can see in this movie. I do a retouch, move to another part by dragging the zoom box in the Move/Zoom palette and do another retouch. I move back to the initial and it’s still shown. Until I select that initial retouch: the second one was removed.

When using the scroll wheel to move around, things get funny :slight_smile: At least for me when testing it because the bug itself is quite nasty and not something end-users would think is funny.

I used cmd-scroll as cmd will put the Retouch tool in another mode (Transform mode). This makes pressing the cmd key visible. But it can be reproduced with ctrl-scroll and option-scroll as well. In most cases, if I zoom with cmd-scroll and I release the cmd key after zooming out just to press it again before zooming in, the before is similar as when moving using the Move/Zoom box. So initially both retouches are still there, until I zoom out again, release, zoom in and select the initial retouch. You can see when I press the cmd key as it will highlight the Transform mode in the Retouch overlay

If I don’t release the command key before zooming in again, the issue occurs right away but this time the initial retouch is removed. Furthermore, the second retouch action isn’t fixed anymore. It will move around and even rescale when zooming out.

This bug makes ReTouch quite unusable.

On my Windows machine, I can’t reproduce the issue at all. I can retouch, move, resize, add, delete and whatever more you can think of without issues.

@Barbara-S I don’t know if you already have this issue under investigation, otherwise I hope this helps resolving the issue as soon as possible.


Thank you for taking the time to attempt to reproduce what I and others are experiencing. Im selfishly glad you could reproduce the issue as it shows it may be a wider issue.

Unfortunately this is the reality unless you only need to retouch one area. Even if its multiple sections of one area.

I think the key to the error is the zooming and panning.

You can ReTouch as much as you want so long as all points remain on the screen at all times from my tests.

Again, unfortunately, I think once its happened it will now continue to happen.
At least in my case. I haven’t had one single case of being able to successfully ReTouch if its more than one location.

Definitely appears to be a MacOS issue.

The question now is this a bug in DPL6 and potentially it’s just a matter of time before other Mac users encounter the issue? Or, is it because you, me and the others share a common component/trait or otherwise on our respective machines and if so can DxO rectify it in that case.

We really could do with someone from DxO commenting in on this one.

In terms of further testing though I am now going to stop.
Unless DxO or indeed anyone else can suggest a possible solution I can see you benefit to me continuing as I am just repeating and seeing the same time and again.

So having spoken to @Grebstad via pm and also what @RvL stated in his post it’s seems one initial common thread is the fact all 3 of us are using 2019/20 MacBook Pro’s and at least in the case of @Grebstad and myself they are Intel i5 based.

What processor is in you MBP @RvL ?

Could this be the issue?

And if so are we likely to see a solution?

Is anyone from DxO staff looking at this thread/issue and willing to say whether it’s being looked into?

@Barbara-S i know you responded to my initial bug which I assumed was completely unrelated. Are you able to offer any insight.

If this does have anything to do with the intel i5 processor (I’ve no idea if that’s even likely just trying to see if there is a common link between those of us who are experiencing issue or who can recreate it) then surely it has the potential to be a bigger issue than just those of us who post here.

I’m sure the staff are busy but the silence is deafening especially when staff have responded to other posts today.
It would be nice if someone even popped up to say it was being investigated.

As it stands though…

3x MacOS 12.6 MacBook Pro’s
2x intel i5’s
1x currently unknown.

1 Like

Same here. Weird stuff indeed.

Are you still using an iMac are per your user details/tag?

If so that rules out the MacBook Pro angle but possibly not the processor side. What processor is in your iMac?


3x MacBook Pro
1x iMac

3x intel i5’s
1x intel i7

Edit to update list as per @KameraD and @RvL response below.