PL4 does not work with Public Beta of macOS Monterey

The current version of PL4 has stopped working with the public beta of macOS Monterey after Apple released the current build 12.0 Beta (21A5534d) – beforehand I did not see any relevant issues:

I ran DPL4 on macOS Monterey beta 8 and found that it worked after restarting the Mac.
I found a few display issues that I suppose will be fixed in a later release.

As for earlier versions of PhotoLab and before: Even OpticsPro v9 seems to work - with all kinds of GUI-issues…

Moved the topic to ‘PhotoLab - Mac’.

Indeed, we have seen such issues with beta 8. It’s still unclear whether these are temporary issues that would be fixed by Apple, or if it’s on our end. In any case, we are currently looking into this, but as of now, we don’t know much more.


It looks like things are way better with beta9. Can you confirm the same?

PL 4.3.3 works with macOS Monterey PublicBeta 12.0.1 (21A558).

Cannot tell right now, I just migrated from Mojave to Big Sur and needed the Monterey drive as a migration stepstone.

Update: Things are better on macOS Monterey 21A559. No more GUI issues, did a quick check with DPL2, 3, 4 and 5.