PL 3 - How to rebuild database / reread keywords

I am a new user to Photolab.
I am using Mylio as “DAM” and selected some photos for post processing there.
I added a keyword to the selected photos in Mylio to mark them.
The directories containing the pictures were previously indexed by PL, some of the photos were already process for other purposes.
I wanted to make a PL project with the new photos and to select them, reindex the directories to be able to search for the new keyword.
Unfortunately PL was not updating the keywords read (for more then 300 files).

How can I get PL to reread the keywords?




Hy welcome to the forum.
you have xmp files with keywords in there?
And you want to refresh the database?
i assume you have used “right click on folder and refresh” and the index button at the top?

i know one very hars way that’s deleting the database and rebuild from scratch.

If you using dopfiles deleting of the Database has no problem all changes are written inside the dopfile.
And the xmp files will be reread by indexing.

DxO told us that the editing function of keywords will be implemented in December so i hope that then also writing to xmp and a real refresh of folders can be done. (Refresh by overwriting existing data in Database.)

But for now: c:\users\loginname\appdata\roaming\dxo\dxo photolab 3\ database-file.

thx for the quick answer.
Yes, I have RAW files and corresponding XMP files with keywords assigned.

Unfortunately your suggestion is not working. After deleting the database multiple times and reindexing some folder, only the old keywords can be found. I also checked for files, where there is no dop file.
Adobe Bridge is showing the keywords correctly.
Maybe the problem is, that I tried to assign hierarchical keywords separated by |.

It would be really good to be able to at least update keywords without deleting the complete database of some thousand files, as this is to only way I found I can communicate with another application, where selection/rating of files is much easier. (I selected the photos from my shots from this year and they are not really cleaned up.)

I checked with a new keyword without | and it was updated (with database delete).
This is definitely a bug which also needs to be corrected.

1 Like

Ah ok you have to wait for the Staff to answer this matter then tomorrow.
It’s a in working progress : the keywords DAM function.
Maybe DxOPL can’t read that character as a command
(i use sins shorttime XNviewmp to generate xmp files)
i hope that v3.1 has a editing function good enough to let xnviewmp go and go for the inside dxo function.
december isn’t far away so… :wink:

I have read many posts here about the keyword functionality and waiting eager to have it in the Windows version.
I like the look of my images with Photolab. That was the reason I chose this software, altough I am limited through my Canon M50 with the CR3 format. I found, that the images from Photolab looked the most like the JPEG from the camera with the default preset (I also like the JPEG look in many cases), so it is a good starting point.
But I also like Mylio because of the excellent, cloudless (local) face recognition and organizing capabilities. Unfortunately the only way I found to have my image selection also visible in other applications is to add a keyword (as a marker).
It would be nice (and I hope it will be in the upgrade) to add another keyword after I processed the file, to be able to filter for it in Mylio.

Have a look here: Creating Photolab Projects from photo selections in other software

Good morning,

First, about the update of the keywords - you do not need to delete the DB to have the keywords updated, folder re-index or even reselection is enough if the modification date of the xmp file is changed.

You have it not updated because of ‘|’ as you’ve correctly guessed. I will discuss with the team about it’s support.

Svetlana G.

Hello Svetlana,

Thank you for the information of not having to delete the database.

About the | separator: I don’t think it is needed to have it as a real hierarchical structure, but it should be read (and written) as a simple keyword.
It is very confusing not to see the updates (when I know, that I have updated a file).
Other software able to display it in hiearachy will take care of the handling.


Thanks for the suggestion. Will have a look when back home.

About this one, we support this “I” separation when it goes for example from Adobe Bridge (it’s properly displayed in PL as a hierarchy). But I should play with your app “Mylio” to see how it’s handled there.

Svetlana G.

In Mylio I only typed it in as a complete text. There is no display of hierarchy.

But I tried one file yesterday in Bridge (just to see if it is working) and there the display was correct, with hierarchy.

I don’t have PL3 yet. I presently have a Lightroom catalog with XMP files containing keywords, etc. If I open a folder of raw files and XMP files in PL3, it should be able to read the keywords into its own database?

YES. Try it :wink: