PhotoLab v7.4.0b45 Disappearing Masks

I just updated to 7.4 on a Mac and the local adjustments chroma and luma sliders hide the mask when moved.

This makes adjustment of these sliders unusable.

I have tried to fill in a bug report but the form is too complex and doesn’t allow me to select a precise category.

I have reverted to 7.3

When I tried reporting one I also felt the process was designed to put off reporting them!

It seems to be the same with the Windows version of PL 7.4. I only see the effect of moving the Chroma or Luma sliders after I release the mouse. That makes setting the sliders a matter of trial and error, i.e. unusable in the real world.

However, I’ll stick with v7.4 as increasingly I’m finding I only ever use PL for initial RAW development, essentially for the optical corrections and noise reduction. Beyond that I move over to Affinity Photo.

As a less than optimal workaround, you can increase the exposure to see the real-time effects of the luma/chroma adjustments. Going back to 7.3 is the better solution.

Another work-around (which is what I do in any case) is to Right-Click either side of the Chroma/Luma sliders - so that values are incremented/decremented in steps of 5

Which, effectively, is the same as ;

1 Like

Agreed this sort of works but, as we all know, this is a kludge to workaround something that work fine in the pervious build :wink:

3 Likes

Win11, i7-14700KF, RTX 4070, PL 7.4.0b151 here.

@Wolfgang has reported the same behavior in Update 7.4.0 b45, mask selectivity not usable anymore - #7 by Wolfgang . However, it works as expected in my case - mask is updated almost live, while moving chroma or luma without depressing the mouse button. Maybe the behavior depends on CPU/GPU?

Another thing pointed out by @Wolfgang – moving the control point hides the mask but displays the corrections “live”. You have to release the mouse button to see the new mask. This is good for me, maybe it’s bad for others. I use LA very rarely, so I don’t remember how it worked in 7.3.

@Joanna I noticed this ehavior on Windows 10. I was astonished to see that all of my preferences had been reverted to the default state, this included "Always see high quality previews being unchecked. Checking this box fixed it.

I have ‘Always see high quality previews’ always unchecked – wouldn’t like too much heat. It takes small fraction of a second for PL to update the mask while using the sliders (with ‘Show masks’ checked) but I don’t have to release the mouse button – the changes are reflected almost live. Maybe it’s a performance issue?

… has nothing to do with the mentioned masks, but how the big preview appears when changing sliders for Exposure, Selective Tone etc.

But @rrblint says it has, as far as I understood.

@rrblint was replying to @Joanna
and I mentioned it with your post here in mind & my former reply to you.

And yes – “Always see high quality previews” is checked.

Just tried control point again and now I can reproduce the OP problem (but on Win11), which I couldn’t reproduce some two hours ago. Restarted DPL and the problem is still there. I just can’t believe my eyes.

Edit: User error, as explained in my next post, sorry.

Sorry guys I misunderstood what @Joanna was saying, I’m still a bit off my game

Well, I just hope that DxO will adress the problem in the Mac and Windows version.
At present it is more than annoying.

I think I’ve found explanation for the weird behavior described in my previous post.
In the first case, I had set Exposure=-1.0 correction, so while moving the sliders, the corrections were displayed live, which made me think the mask was updated too. It was also a specific photo to get confused.

I was just about to start a thread about this.