PhotoLab can't handle big-endian files

If I save an image file on a Mac using Apple Preview, the file type is described as “TIFF image data, big-endian”. These files do not show up in PL’s PhotoLibrary, and PhotoLab cannot preview them or open them correctly.

I believe that this is probably the same problem identified in the thread

but the problem is not restricted to CR3 files.

Trying to reproduce the situation (macOS Mojave in iMac 19,1) I found the following.

First Test:
Right after exporting, from Preview, a CR2 as 16 bit TIFF, DPL3 was unable to display the image.
I then did a few checks on the file without saving it again and suddenly, DPL3 displayed the image.

I also created a TIFF trying to save the file with cmd-s using this popup. This TIFF did not show in DPL3.

Other than that, both TIFFs displayed in DPL2, no matter what.

I then logged out of my user account and logged in again.
Now, both TIFFs display in DPL2 and DPL3.

Second Test
Deleted the TIFFs, emptied the trash and recreated them again.
Now, both DPL2 and DPL3 opened the files without hiccups.

Third Test
Deleted the DPL database and cache files -> DPL2/3 did not see the TIFFs
Logged out and in again -> DPL2/3 did not see the TIFFs

Fourth Test (this is it!)
Right clicked on a TIFF and selected to open it in DPL2/3
Both versions of DPL displayed the file without hiccup.

Fifth Test
Deleted database and cache files -> DPL2/3 don’t show the file
Dragged the file icon onto the DPL 2/3 icons -> DPL2 shows, DPL3 gives me this
Tried to open with context menu -> same as above
Dragged again onto DPL3 a few times -> image finally shows up after a few tries

Note to DxO: See here for bug report:

I was on the wrong track here, but there is a bug in PhotoLab on a Mac. Here’s how to replicate it:

(1) Take an image file XYZ.tif
(2) Use CMD-I to get file information
(3) Click on “Hide Extension”
(4) Rename the file to XYZ.tiff

At this point the file will disappear from the index in PhotoLab’s PhotoLibrary. The same problem arises for a file originally named XYZ.tiff and renamed to XYZ.tif, following the sequence described above.

I erroneously thought that my problem with Preview had to do with big-endian files. But actually it seems to have been caused by Preview saving a file with its extension hidden.

well, I tried this too and sometimes it made a difference and sometimes it did not.

Trying it again, I found that when I hid extensions and opened DPL3, it did not show anything and that after closing of DPL and logging out and in again, the sidecars were gone. This actually killed the work I had done with my test images. :nauseated_face: