Photolab 7.7 – Prime not working anymore

Just downloaded Photolab 7.7. I had to enter my registration again manually(???) and, much more concerning, I have no access to the Prime, Deep Prime, DeepPrime XD noise reduction anymore (at least with dng-files from a Nikon D500). :unamused:

1 Like

Does nikon D500 produce dng out of the box ?
Looks like you’re not opening a raw file, but a bitmap file (dng can contain anything).

Yes, RAW files from beginning to end. And I first observed it, while exporting old files. The result was terribly noisy – completely inacceptable. I just cannot switch the different Prime variants on anymore.

How did you create this dng (I don’t think D500 output this format, maybe I’m wrong) ?

1 Like

You are wrong. It is an OOC dng file (as all my photos).

ok, good to know.
So d500 output dng raw files.
Why don’t shoot nef ? (just curious).

Just seeing this reply and found the same, was working with 7.6.
7.7 is completely broken for me, and now the export has no watermark option either.

Yes, I will go back to 7.6 myself now.

Was it a trial version before the update or a commercial version purchased?

It’s a purchased version for me.

I just checked and all of the Prime options are grayed out in 7.7 for ALL of my RAW files (Nikon, Olympus, Pentax). As a side note, lens profiles are still not working for Sony A7RII which was broken in previous release. This is why I keep Lightroom.

1 Like

It was the update of my purchased commercial version.
Also: most of my dngs did not show up in 7.7 as thumbnails. I am back on 7.6 now and everything is fine again. The update was a complete failure. I suggest you better withdraw it.

I think they simply f-ed up by mixing up Essential and Elite version…

@Marie Same here! How can I downgrade to previous version i.e where can I find one? MacOS 14.5 here

Same problem here. I cant select Option in Deep Prime. And Clear View Plus was gone completly

lol, it’s turning into a comedy, same here as I just checked on seeing your message.

1 Like

I open a mail to the support.

Where do we get the older version?

Maybe a big upgrade on processing time ?
:melting_face: :melting_face: :melting_face:

I was doing some retouch on photos I edited yesterday, and I haven’t exported any before I have seen this post about Prime was gone (and checked it was indeed gone) lol.

Now I am waiting as I didn’t have 7.6 installer, and it’s no where to be found. Hilariously this is what DxO support replied:

And this is the link given:

Oh well guess I just have to wait.

There is a huge issue on PL7 (latest upgrade for Mac). It will not now open any of my Fuji RAF files. It says the images are taken by a body only supported by the Elite edition. I have Elite, or I did, and all my raf files were edited just fine on the previous version.

Edited to add - Ah - solved it. For some reason the update killed the registration so I had to input the serial again. It never asked for it I just found out by checking.