Optical module isn't recognised correctly

when coming back from a trip and developing images taken with exactly the same combo of camera and lens, in some images the lens isn’t recognized correctly. Instead, PL3 states either 'no optical module available" or offers me to choose from a list of similar lenses.
I’d like to have an opportunity to set the optical module manually to a certain one (the same, that is automatically chosen for other images from the same series)
This is i.e. for my Nikon D610 + D500 in combination with Tamron SP 150-600mm F/5-6.3 Di VC USD G2
Best would work (at least fo me), if you give us the opportunity, to choose manually from your database when we think the automatic is going wrong. Just like a manual overdrive/correction for automatic recognition.


@Marie could you, please, have a look at this combination

Thank you,
Svetlana G.


we have modules for these combination.
@avalon could you upload one image for D500 + Tamron 150-600mm G2 and one image for D610 + Tamron 150-600mm G2, please ?
JPG images will be enough for investigation, no need of RAW.


1 Like

…autonomous cars have it :wink:

ok, today I run in the same problem again. One out of 4 images came up with that strange behavior

the highlighted line is the correct combination

the problem still exists with PL 3.2 :grimacing:

Hello @avalon,

can you please upload some test image please ?


they are already there: see 2 posts above in the history of this threat!


btw. for whatever reason, now even Sigma lenses are offered. I don’t have Sigma lenses

the last option is the correct one!

Hello @avalon,

I’ve seen it but I need original images for test. When I said JPG images are enough I should have mentionned it is JPG from the camera.If you don’t have it a RAW file is fine to.
PhotoLab uses Exif information and metadata to identify a lens and then match the optics module to use. In files you uploaded there is no Exif.


that’s funny, as I can see exif data in the files.20200321_065824-500_9780.NEF (24,7 MB)

Automatic module detection is like autonomous driving: It can create accidents.

I strongly urge DxO to give their users a possibility to select the camera/lens combination manually.
To prevent false positives, automatic selection should be override-able.

One possibility would be to enable the user to select from supported combinations of

  1. bodies owned or used
  2. lenses owned or used
  3. any body and any lens

I believe that most users having DPL will be able to handle a manual selection properly.




The behavior will be improved with next DxO Optics modules release, in middle of April.


How about an option similar to “I don’t have this combination, don’t ask me again”?

Hi Marie, I just got the latest update 3.2.1 build 51 and the problem still exists :frowning:

Hello @avalon,

we will do a DxO Modules update on April 15th, the imrpovement will be with it.


ok, I’m looking forward to that update :slight_smile:

Hi, I am having problems with processing some CR2 raw files taken using a Canon 7D II/100-400mm f4.5-5.6 II combination in Photolab v3 on a Mac. In most cases Photolab 3 identifies the correct optical module so that the raw files can be processed correctly, but for a subset it cannot find any optical module and the lens sharpness panel is greyed out and cannot be used. If I open the files on another Mac running DXO OpticsPro 11, and that has not had any versions of DXO Photolab or recent updates to optical modules installed, the correct optical module is found for all of the raw files. I have uploaded one raw file that could not be processed correctly in Photolab 3.3.2_R9A0558.CR2 (27.5 MB) .
Thanks, Ian

Your file opens nicely in PhotoLab 3 on my Mac.

You could try the following:

  • restart PhotoLab
  • log out of your user account and log in again
  • restart your Mac

If the above does not help, you could backup the following folders or files and try any of this:

  • delete the lens module folder ~/Library/DxO PhotoLab v3/Modules/
  • delete the database file(s) ~/Library/DxO PhotoLab v3/DOPDatabase*
  • Delete the settings ~/Library/Preferences/com.dxo.PhotoLab3.plist
  • delete the cache folder ~/Library/Caches/com.dxo.PhotoLab3/

Thanks for your response. I have tried all of these suggestions and I still have the same problem.
Cheers, Ian

Just a data point but the file opens for me in Win 10 and DXO downloads the lens profile.