Now getting warning in 7.5 of already exported even when using different folder

I always down load jpgs for Facebook when they are going to be used on it. To do this I use a folder in the original export one. Now every time PL (7.5) comes up with the warning of the images already exist. That they have been exported is now being saved to something (not the database as I have deleted that) when it appears to have just checked the folder you selected before. Any one found a way of stopping this?

Try posting a screenshot of the Export dialog that you are seeing.

Screenshot 2024-03-18 165747

This is the same warning you get if saving into a folder already with saved images. This is to a totally new folder.

I have PL 7.5 on Windows 10 and I can’t reproduce what you are seeing:

  1. Using Windows File Explorer I created a subfolder under the folder that holds some RAW .CRS3 files.
  2. I opened PL7.5 and selected a RAW file that I had previously processed and exported as a .tif to the same folder as the RAW file.
  3. I clicked Export to file.
  4. In the export dialog I changed the ‘Destination’ to ‘Custom folder’ and selected the new subfolder I’d created at step 1).
  5. I clicked ‘Export’ and PL 7.5 created a new file in the subfolder without any warnings about the file already existing, since it doesn’t exist in this new subfolder, the existing file is up a level, alongside the RAW file.
  6. I re-exported to the same subfolder but this time as a .jpg file. Again no warning because although the subfolder now holds a file of the same name, the filename extension is different

Now, could you post a screenshot of the export dialog, instead of just the error message?

No change from pri 7.5

I am just exporting jpegs and until 7.5 never had this at all.

See what problem may be the its not deselecting the original export option which it clearly is in 6 and was in 7. But as the original export was to a different folder it must be remembering the original folder for the full sized export not just using the new FB folder selected for the 2nd export there are just the FB saves there not both sized ones.

That’s not my experience with 7.5 on Windows.

If the original file is a jpeg and you are not adding a suffix to the filename, then the export will try to write a file with the same name and extension.

Try adding a suffix. PhotoLab default is to add “_DxO”

I have run tests and the problem is unless I deselect the original save option (full sized) when I save the the reduced option for FB the original export option isn’t being deselected when changing options. There for its saving to both options and one has the original saved images in it there for the error message is correct.
If I manually deselect the original save option I get no error as its not trying to save to the original folder with the full sized saving options.

I have tried 6 and that deselects the original save when you select a different one and I am sure 7 did as well as its only since 7.5 I have been getting this.

Ether by design or accident they have changed the multiple types of saving from you selecting two or more options to save to over to them staying selected until you deselect them.

Its odd as different types of saving do clear options already selected but not every time. For example I had all but the FB selected clink on that and all cleared. Have the bottom two selected and select DNG and the bottom two cleared some times. Some times selecting full sized output clears the FB one but selecting FB doesn’t usually clear the full sized output.
It strikes me they have added a bug but I don’t have the time to get onto support about it now!

If you use the checkboxes to select options, then you will get multiple options. But, if you just click on the description panel, you only get one.

Yes its more constant to use the panel but not every time I tried that. But its better than using the check boxes which is what I have always used (until now with no problem in 7 and still non in 6).

If you choose “unique names” in what directory do you see them/ are the written to?


Saves always get saved to the path selected in the current case more than one if I don’t ensure the one originally used is deselected

So, in which directory was the file with the unique name? That’s the path you’ve problems with.


Sorry the problem is saving now needs careful selection to not have two forms of saving selected nothing to do with where it being saved too. I never had the problem until 7.5 but know now what to watch out for.

Hi John - - I see in your screenshot, above, that you have TWO Export-to-Disk targets selected … Is it possible that the duplication is on your export to “High Output to test folder” option ?

I mention this because I had a similar “weird duplication” issue that puzzled me for quite a while too :grin:

1 Like

That’s not the answer to my question. In which directory do you get the renamed export?


I’m sorry I don’t know what you are asking I’m not having a problem with renaming