NIK will not open

I explained it not very well.
You have to create an account on, log in and register your serial number.
THEN you start the install with the registered serial number.
That’s what I had to do.

terrycymNik Collection EA member11h
Hi Gene,
When I registered NIK, I went to the DxO website (a link was supplied) where I had to enter my registration code in order to “register” the registration code (weird but don’t ask!)
I got a message to say everything was ok
I the installed NIK and entered the registration code
All worked fine.

Have you done this?

Terry, on the DxO website there is no way that I can find to register my copy on NIK. The option is only to purchase…which I have already done. How did you register the code on their website?
Thanks for your help.

…and now the ActivationTool.exe file in Program Files DxO doesn’t work either.

Well, here’s the latest update on what’s happening:

I removed all versions of Microsoft Visual C++ from the computer (about ten of them) and then installed the latest version (2017).

I added “MSVCP140.dll” to the Windows System folder.

I went thru a few other things and when I just attempted to open NIK in Photoshop and Bridge, IT WORKED! I tried it second and a third time and it continued to work.

I rebooted the computer just to make sure and NIK continues to open properly.

I am crossing my fingers that this workaround continues to work.

Hopefully all of you good people will not hear from me again about this topic. If not then I do want to thank everyone who contributed to troubleshooting this issue.

And now I think I’ll have a nice glass of wine to celebrate…


Ahh … the old “MSVCP140.dll” did it! Congratulations, enjoy, I’m happy for you.

Congratulations, @Gene1000! :tada:

I am experiencing this problem and working with customer support. Here’s the history and what we’ve attempted:
MacPro 2013 - desktop
macOS Mojave 10.14.6
LR 8.4.1

Purchased the Nik collection (October 2019), installed it on my MacBook Pro and works perfectly. Note, Mac and LR on laptop are the same versions as desktop. I had the google version of the Nik collection installed on desktop, worked fine. Ran “uninstall” on the desktop from the google version software. Then installed the DXO version. Tech Support said that the I could either uninstall the google version or the DXO version would automatically remove it during installation. I ran into the, “Please verify your internet connection, or your activation code, and try again. (1)”

DXO/Nik confirmed the activation codes is valid. I installed the software from the DXO/Nik website

Instruction from Tech Support:

  • remove the file at /Library/Application Support/DxO Labs/Licenses/nik2019.lic
  • restart the plugin and try to activate again
    NOTE: This the Library off the Hard Drive itself, not the Library found under the user profile.

I only found one location for the “Library” folder and it was inside the OS Hard Drive. The folder “Licenses” was empty. Just in case, I tried to locate the a “Library” folder under the user profile. Could not find one.

Next I allow all Nik programs to pass through the Firewall (part of the macOS). Still the same error. Then I turned the Firewall off. Still the same error.

No antivurus software on the computer.

Any assistance would be greatly appreciated.

Guys plz help me when i am opening nik software in photoshop its crashing my pc

Hi, Sunil. Have you opened a support ticket at That is the best way to go. You can sometimes get help here with the Nik Collection, but there are many details to consider with a problem like yours.

There are several topics open in this forum about Photoshop crashing when running the Nik Collection. But you said that your PC, not just Photoshop, is crashing. Can you explain exactly what’s happening, either here or when you open a ticket at And say what version of the Nik Collection, Photoshop, your operating system, etc. you are using. The more details, the better.