NIK will not open

I was too fast :grinning: , sorry. This section is in the stage of preparation and will get available from tomorrow afternoon.

Svetlana G.

Tried launching the .exe file. Nothing happens. I also removed all of the hyphens from the registration code. Nothing happens.

I opened a jpg in Bridge and sent it to Photoshop. When I attempt to register, it says this:

“Please verify your Internet connection or verification code and try again”

The Internet connection is fine and the registration code I enter is as I received it.

EDIT: it runs in Demo mode only.

I had a similar activation trouble when trialing Viewpoint V2 a few years ago. Worked with DXO support via webex and they discovered two of the dll’s wasn’t the correct version. They installed the correct dll version and I as then able to register the activation. The files were libreay32 and ssleay32 both dll and of course at the time 32 bit version. Maybe support could look into similar file corruption for your installation. Just sayin.

Thanks, Copy.
This makes sense. It’s happened to me a couple of times over the years too.

For the moderator here, could someone look at the dlls to see if they are correct? I’m thinking that if they are not, then everyone would be having this issue, but I hope it’s a simple fix.

Here is a screen shot I took of the failed activation:

I can’t upload the screen shot of the good dlls, I am limited to one image upload.

I kept the screen shots and files in-case I had to re-install Viewpoint and need to know which files were the good ones…

Good luck!

Here is a screen shot of the dlls that fixed the problem, note the file version number:

Good morning, Gene,

Let’s do the following thing as the last attempt before really connecting to your machine:

  1. Please, uninstall Nik collection.
  2. Remove the following folder: c:\Users%user_name%\AppData\Local\DxO\ and this one - c:\ProgramData\DxO\Nik Collection\
  3. Open this directory c:\ProgramData\DxO Labs\Licenses\ and remove all nik2018xxx.lic files
  4. Reinstall Nik collection and try to activate it either during installation (simple variant) or then through the plugin.

Please, let me know your result.
Thank you
Svetlana G.

Just a thought, but it might be worth downloading the free version of CCleaner and getting it to clean out your registry for any remaining NIC related entries after the uninstall.
Do it after you’ve rebooted your PC.
You never know!

Hello Svetlana,

I followed your instructions and had to remove and reinstall NIK three times. The same problems kept repeating.

However, there were a few times when I opened Adobe Bridge 64 bit and sent a jpg to Photoshop from Bridge that NIK seemed to work OK. But now it does not. Even when I send a jpg to Photoshop from Bridge, I get the same problems…“The command is not currently available”.

Once again, nothing seems to work.

When I try to run “Activation Tool.exe”, nothing happens.

Thanks, Terry. I may give that a try, but CCleaner had wrecked my registry in the past. I’ll make sure to back up the registry before I try it.

Appreciate the suggestion.

CCleaner gives you an opportunity to create a REG file before it deletes stuff so double-clicking afterwards will restore the deletions.

Good morning Gene,

So you could not activate the application through the installer? I mean when you are installing NIK the installer suggest you to activate and the activation fails, right?

P.S. If your activation fails even in the installer, then it means that you could receive the key that needs to be registered in the personal account page. Please, check it or report to the Support team.

Thank you
Svetlana G.

First, I tried again to remove NIK and discovered that it was suddenly not listed on the “Remove Programs” list, even though it was shown in Adobe Photoshop. I then restored the computer to a previous restore point and still, the program was not listed on the “Remove Programs” list, but was shown in Photoshop (still did not work).

I then reinstalled the program.

During installation it asks me to “Activate” by entering the registration code. After I do this, it seems to install fine. But after installation when I try to open it in Photoshop or Bridge, I once again get an error message that “The command cannot be found”. And when I try to activate it, it tells me to check the activation code or check my Internet connection.

The program has major flaws. If your tech people cannot get it to run on my Windows 10 PC, then I want my money back. Once you fix all of the bugs, I will purchase it again.

Please give me my money back,

Thank you.

Hi Gene,
When I registered NIK, I went to the DxO website (a link was supplied) where I had to enter my registration code in order to “register” the registration code (weird but don’t ask!)
I got a message to say everything was ok
I the installed NIK and entered the registration code
All worked fine.

Have you done this?

Hello Gene,

As it’s activated during installation successfully, so the issue is not in the activation for sure. It seems that the problem is with the host applications (probably the prior version was not properly removed and left some artifacts).

Could you, please, create a request here -, the support team will connect to you and help to clean the machine or update the necessary files to fix the issue on your machine.

Thank you
Svetlana G.

I have previously submitted a support request but no one contacted me. I will do so again. As I recall, when I first installed NIK it did work, but only for a couple of minutes. Then something happened, but I don’t know what. At that time, I had not removed the program and reinstalled it, so it’s doubtful that back then, the problem wasn’t leftover files from an uninstall.

Hopefully the support people will get back to me this time.

Thank you for your help,


Thanks, Terry.

My install does not direct me to the website, but I’ll remove and reinstall to see if I can do it your way.

Thanks for the help,


Well, once again I attempted to remove NIK only to discover that it is not shown on any program list. It’s not shown on the programs to be removed list too. Yet it appears in Photoshop and continues not to work.

The DxO folder under “Program Files” is empty.

The DxO folder under Program Data does not have an activation exe file as it did before. It only shows four “efex” files.

The DxO Labs folder does have a license file in it.

All of this after I reinstalled the program a day ago.

I’m not sure how I’m going to remove it this time. Perhaps try reinstalling it again and then removing.

This has been a very unpleasant experience.