Nik V4 renders Nik V3 unusable

I have used and loved Nik V3 for some time. However, I find it insulting that I now have to wait over 2 minutes the first time I start up V3 each day for the nag message to arrive about buying V4.

Making the software that I paid for (not rented) unusable is an insult to DXO’s existing customers. I do not plan on buying V4 on principle - because I am sure one day V5 will come along and then V4 will be made unuable.

Yes - I am aware that there is some hack that is possible if you modify some code somewhere. I tried that last time. It is overwritten at every minor bug fix.

DXO Guys - please do the right thing and stop treating your existing customers with such disdain!


Strong feelings about this. Fortunately, it’s been the case that the notices about an update go away after about 30 days.

I totally agree with you and actually quit using Nik V3 in favor of another software because of this issue.

NIK Software bundle version 3 worked without a glitch along CS6, and I made the mistake of upgrading to NIK version 4. The problems didn’t start at the beginning of v.4, just on the updates to version 4, as it rendered the apps in version 3 unusable. I have Photo Lab 4 Elite, and also the latest Version of Affinity Photo, but am not ready to remove CS6 from my Mac, since CS6 and NIK, up to version 4 was just about perfect for me.

I do have the NIK software version 3 installer in the "Downloads folder " of my Mac, so maybe I can reinstall this version on CS6 only (not on Photo Lab and Affinity Photo), but I am hesitant about it.

I did so on Windows → Issues with Nik4 - #8 by Wolfgang