Nik Collection 4 doesn't show up as an installed program in Windows 10

I mentioned this in another thread, about Silver Efex Pro 3 hanging when called from Photolab 5 and Lightroom, but posting again in the hope of some insight. In attempting to resolve the problem I tried to uninstall Nik, but discovered it was not listed, either under Apps & Features in Settings or Programs & Features in Control Panel. I finally was able to uninstall it using the Microsoft Install/Uninstall troubleshooter (which surprised me because these troubleshooters hardly ever seem to work). After a new install the hanging issue was fixed. But Windows still doesn’t list Nik as an installed program. Can anyone explain this behavior?

I did read this:

but it doesn’t seem to be precisely the same problem.

No such problem for me. Do you have antivirus or anti-malware software running and have you tried disabling it?

on my machine they are shown twice

Screen Shot 01-12-22 at 03.48 PM


as I took the (unusual) route to install the new version Nik 4 and the former Nik 3
Issues with Nik4 - #8 by Wolfgang