Nik Collection 3 not installing on new Win 10 PC

I’ve done a support request about this, but… new PC, supplied with Windows 10 21H1, updated to 21H2.

PhotoLab 4 installs fine, but the installer for Nik Collection 3 fails to run at all. Via Explorer, it gives a “the application was unable to start correctly 0xc00007b” error. (Via PowerShell, nothing at all: no program, no error message.)

To rule out a corrupt installer file, have you tried downloading the Nik Collection 3 installer again?

Yes. Twice. Identical file and the signature is valid, for example.

If anyone wants a hash of the file, let me know.

Other programs installed on this PC with no problem:

Skylum’s Luminar 3, 4 and AI, plus Photolemur 3 and Aurora HDR

Serif’s Affinity Photo and Affinity Publisher.

Corel Painter 2021.

This post, by @kitwchris might be useful in this case (?)

John M

Hi John-M
Some additional advice:
Before using the Microsoft tool, I deleted NIK Collecton 4 which I tried to install.
To do this I used “IObit uninstall tool”, free version.
It worked perfectly.

Thanks, but I did that with no luck.

Also installed with no problem: Exposure X6, BlowUp 3, Snap Art 4…

It’s just this one I’m having problems with.

I’ve never had Nik Collection 4 installed. This is a new PC, with just the software named above installed along with Firefox and Chrome.

Oh, just in case anyone wants to check their copy, here’s the SHA256 hash of the installer file I have:

PS C:\Users\Ian\Downloads> Get-FileHash .\Nik_Collection_3_byDxO.exe

Algorithm       Hash                                                                   Path
---------       ----                                                                   ----
SHA256          1C52EF585DA1F5CAEAAF757592173B165F3C33D6943BE2D0CF29E657661A549D       

Matches my checksum.

1 Like

Hello HalBaked Ian.
Think you may have to have a host software package installed before you try and install Nik Collection 4

I have DXO Photolab 5 which NIK Collection 4 installed into.

See original post: DxO PhotoLab 4 installed fine.

Nik Collection 3 installer doesn’t even get to the ‘agree to having no rights’ licence bit, never mind the ‘where do you want me, what do you want me to act as a plugin for’ stage.

Sorry I can’t comment on Nik collection 3, my issue was with Nik collection 4. Now resoloved

First, I have to say that official DxO support has been hopeless - their solution is ‘buy Nik Collection 4’ even though a) this system meets the published system requirements for Nik Collection 3 and b) according to the published system requirements, that would also mean having to pay to upgrade to PhotoLab 5. Erm, no.

The first attempt at copying the files and some registry keys from the old PC, where it was working, didn’t work, but by installing a trial version in a virtual machine* (don’t want to lose my last activation!) and looking at the installation log,** some more files were copied and…

… it works, it’s been activated, and other programs (eg Serif Affinity) can see and use the various Nik Collection 3 plugins.

However PhotoLab 4 doesn’t think Nik Collection has been installed.

How do I persuade it that it has been?

“Obviously” saying “install Nik Collection 3 again” isn’t an option.

Seeing the installation process work means I can confirm that on this PC it never gets to the “Please wait while Setup is loading… verifying installer: 01%” stage, never mind later.

  • Windows 10 20H2, just in case it is that this PC has 21H2 is significant.

** Fascinatingly, the Nik Collection 3 installer - when it works - checks for versions of PhotoLab up to version 10. Tell me again why version 5 is, according to the system requirements, not supported by Nik Collection 3.

screenshot taken from PL5

how to → Issues with Nik4 - #8 by Wolfgang and further Links

!! Installing Nik Collection 3 after the latest NC4 ‘resets’ the version date to NC3
and you always get the bothering “there is a new version notice”,
but everything works. !!

See above - the Nik Collection 3 installer simply will not run on this PC, so anything involving running it after doing anything won’t work.

well, the very same OS … then, I can’t help you :frowning:

With absolutely zero useful help from DxO support, I think I have sorted this: it appears that the Nik Collection 3 installer is not written to the best standards possible. (I’d say I’m shocked, but by this point I’m just surprised it isn’t worse…)

The latest versions of Windows 10 come with enhanced exploit protection that looks out for assorted dodgy things like executing code in ways that well-written programs shouldn’t. It comes with a handful of ‘let this specific program do this one thing’ exceptions and you can add other programs to that list manually.

By opting the Nik Collection 3 installer out of every. single. protection - there are twenty-something of them! - it will run. At effing last, PhotoLab 4 now recognises that the Nik Collection 3 is installed.

I would expect that probably only one or two opt outs are actually necessary, but given how totally useless DxO support have been in sorting this, I am not going to do any further testing for them for free.

I do wonder if the Nik Collection 4 installer does exactly the same things, mind. Given how eager the ‘support’ wanted me to buy my way out of the problem by getting it, it would be funny if it was also seen to be doing whatever improper things version 3 does.

Out of interest, Ian - how/where does one opt-out of these protection settings ?

John M

Search in Settings for ‘exploit’.