Have been using the Nik Coll for several years now, however I still have problems with PS and LR freezing after choosing a file to process in one of the Nik applications. This causes a “force quit” on the Mac with a report going to Apple. I use this daily and I experience 3-4 freezes each day. I almost always use RAW files and save as a tiff, however even the occasional jpegs freeze. So is it LR, PS DXO or Apple. I thought when I upgraded for $50 Dxo said the Nik Collection was integrated wit Adobe? Any help would be appreciated.

It is not a problem I am seeing on Mojave. Same as you I work from RAW. Are you using the free or paid for version of Nik?

Topic starter says he upgraded for $50, so that will be the DxO version.
What OS are you running and what version(s) of PS and LR.
I must say I am moving away from Adobe (no subscriptions for me), but have tested Nik in Photoshop CS6 (v.6.14) under High Sierra and Mojave and do not experience any freezes or crashes. As I am moving to Affinity Photo, I have the feeling that the Nik modules are (now?) behaving nicely in Affinity Photo, which was not the case with the previous version(s).

I think you mày be wrong re DxO Nik and Affinity Photo

Only the old free from google of Nik collection work with Affinity Photo, the new by DxO just freeze and need a force quit to close it.

Yes this is the paid NikDXO version. I am on a Mac OS Mojave, and an Adobe CC subscriber. All up dates are current. Would it be useful to uninstall the DXO software and do a reinstall? My experience is this is so random its hard to find a cause. It seem to center on the hand off to DXO from LR or PS. At times it never happens, or it initializes the freezes. All I can say is totally frustrating, but I like the Nik Coll results so I stick with it.

I tested the most recent Nik by DxO build (version 1.218) yesterday, and no freezing or crashes in Affinity Photo. Running Mojave 10.14.1 on a late 2012 iMac with 16GB RAM.
No problem on my PS CS6 either, but weren’t there any issues with CC?

There were issues with CC and Nik before DxO updated. The Affinity forums are still saying there are issues and the devs agree. Can’t add anymore really as I use CC where all is well. The power in Nik never ceases to amaze me and I am finding more and more that that and LR gives me all I need. I am using PL less and less these days.

I only use PS and LR "Classic"CC. Don’t know if LRCC has issues. Has there been a DXO update I missed? Also, should I delete the Nik DXO and do a reinstall?

DxO did some work on Google Nik to fix Adobe compatibility. If memory serves that work was done to meet the first DxO paid for release. There has not been a subsequent update yet. LRCC does not accept plugins at this point (which is a shame as I like the way LRCC works). The only external editor acceptable is PS which does of course run the Nik plugin. My reference to CC was in respect of the Creative Cloud photographers suite.

If you have DxO Nik and it is crashing with LR doing a reinstall might help. I’d certainly try it. Also Mojave updated here today.

LesC, I have deinstalled all my Adobe products and use Affinity Photo (AP) and other purchased software (DXO Nik Collection for example) for photo editing.
Please share with me how you got AP to recognize the DXO Plugins. I pointed them to the DXO folder, gave global permissions, and allowed “unknown” plugins. Yet, AP still doesn’t recognize the DXO Nik folder/apps.
I also work on a Mac running Mojave (updated today).
Thanks for any help you can offer. It has been very frustrating trying to support DXO’s version for Nik and not having it work with AP.

I do not use Nik with Affinity I use it with the Adobe plan. I do not use Affinity period. When I did try I could not get it to work. To be frank if Affinity cannot come up with a better way then I am not interested. Affinity acknowledge there is an issue with running DxO Nik.

I still have CS6 (and CS5) still installed and, although I am trying to kick off them, in favour of Affinity Photo, I still have all the plugins (including Nik Collection/Dxo installed at:
MyMac/Applications/Adobe Photoshop CS6 ƒ/Plug-ins/
and have my Preferences in AP set to:

As Adobe will be removed eventually, I have meanwhile created a folder next to the AP app in Applications:
MyMac/Applications/Affinity Photo Plugins ƒ
and, doing a Custom installation of Nik, I can populate that folder with DxO/ 8 subfolders.

To avoid a conflict, and just for testing, I removed the link to the PS plugins, added a link to Affinity Photo Plugins, and restarted AP. Of course all my other plugins (that I did not install in the AP folder) were gone, but Nik was there and worked as it should.

I wish I could make my PortraitPro work in AP, but that still freezes and crashes AP.

Hope this helps. I must say, it took me a time before I could get things working, and I still keep my fingers crossed, but so far, so good.

Thanks LesC, I’ll give that a try.

LesC, Thank you for your detailed response. I’ve tried creating a custom folder and pointing AP to it. Unfortunately none of the DXO Nik Collection shows up. I’ll continue to experiment with other configurations and let you/the group know if I have any success.
I do wish that DXO and AP/Serif would get together and resolve the issue instead of forcing us to come up with workarounds.
Again, I appreciate your efforts to help us out. Take care.

You have done a custom install of Nik, haven’t you? When you do the installation, before proceeding, it will show the programs in which it will install. In my case, several Adobe programs that I still have. But I press the + button and then add a installation in the AP plugin folder I have made beforehand. The installer will still call it Adobe custom or something like that (can’t remember), but it will definitely install a DxO folder inside Affinity Plugin ƒ, that DxO containing 8 folders:

LesC, actually I just tried pointing AP to the current DXO/Nik install. I will try a custom install and see if it works then.
Thanks so much for the follow-up. I’ll let you know if it works.
Take care.

LesC, I did a custom install and got the same configuration as your screenshot. AP would then recognize the Folders/Apps

Attempts to open Viveza crashed the program.

AP did open Silver Efex but would not open the image inside the SE app/plug-in. After closing Silver Efex (via the close button-the cancel button would not work) all of the NIK Collection, as well as the Preferences panel on AP were grayed out/inaccessible. Plus, the program was locked up and I had to perform a “Force Quit.”

Sigh. Very frustrating.

I guess I’ll just have to rely on Luminar to access the NIK Collection.

Regardless, thank you for your efforts.

LesC can you show a screenshot of an image in Nik from AP?

0Kami: did you first duplicate the layer in Nik before opening Nik through Filters/Plugins… ?
In Photoshop this is done automatically. In Nik you need that extra step. As you cannot use the brush in Nik, you can afterwards apply a layer mask to that duplicate (Nik) layer, invert it, and apply Nik only where you want.