(LesC) #21

Is this OK: to the left (and at the back) a pic (jpg) of my grandson as opened in AP.
More to the right: the photo opened in Nik Color Efex and an effect applied. At the right you can see that the effect is applied on a duplicate (that I made before starting Nik).
Hope this helps.

As I only want the effect to apply on the skin, and probably less than 100%, I will now add a layer mask to the duplicate layer, invert it (⌘-I) and brush in the effect using a soft white brush.


so it does work with the latest OS Mojave, is it wirth upgrading to it from sierra?

(Benoît) #24

Well, well, well… it seems some people here have the luck to have Nik by DxO versions a little in advance :wink: . For the others, please be patient a little longer, and in the meantime, upgrading to Mojave won’t help regarding Affinity topic.


Benoit, when you say “be patient a little longer,” are you referring to an update to the DXO Nik Collection that will fix the Affinity problem?
Please say, “YES!”
If it’s a “No,” please don’t tease us like that! :wink:


LesC, thank you for the suggestion to duplicate the layer before trying to apply the Nik apps. Doing so allowed me to us Dfine and Viveza but the Silver Efex still crashed the program. AP still does not recognize Color Efex or Analog Efex.

I truly appreciate your efforts.

Benoit, in a post below mentioned that some have the “Nik by DxO versions a little in advance,” is it possible that you are using a version that hasn’t been distributed/updated to the original DXO/Nik purchasers from back in the spring?
(Or, perhaps there has been an update I was unaware of!?.)

(Rolf Meier) #27

@LesC You say there is a version 1.218 of Nik DxO. I have installed version 1.214. How can I update my installed version to the newest one? Shouldn’t there be an automatic update?

(Benoît) #28

1.2.18 version is available starting from … now. Freeze when launching Nik plug-ins from Affinity (on macOS) should be solved now.

(Wilkinson) #29

How does one get the update?? I read on various photo sites it is available? When logging into my DXO account it shows nothing al6though I have the DXO receipt and activation code?

(Pascal) #30


That’s for a free trial - will that work as an update?

(Marc) #32

I guess it is this link ?

The DXO homepage is a bit confusing at the moment… :roll_eyes:

(Pascal) #33

It should be


Thanks - yup that worked. Wonder why the updater in Nik is not working, on Mac at least.


Neither on Windows. But the above link is ok. Thank you!


That would had been nice to have the latest update announced, never got an email saying there was a new version 1.2.18. You already have a list of who paid for it, why no email were sent to those users?

*maybe adding check for update in the menu?

(Benoît) #37

This release is just from today afternoon. If you already have downloaded a Nik version by DxO, you should receive an email today or tomorrow. Automatic check for update will be on by the end of the week.


Oh nice, got it downloaded but haven’t got the email yet.


never got email from you guys regarding the update, been looking on the website for what is the latest version and can’t find it, should be something easy to find.