Nik 4 won't install

I just upgraded gto Nik Silver Efex 4. I ran the installer and still have version.

Nik Collection 4 installs (among all the other items) Silver Efex Pro 3. When I open SFX and “about”, I get the following information:

While “Nik Collection” has version number 4,
Silver Efex Pro is Labeled “Silver Efex Pro 3” and shows version numbers 5.0.4 x64 and 4.0.7

Somehow, DxO has not been able to make version numbering understandable during the last four years, maybe they are held back by some legal constraint in whatever contracts DxO have with previous copyright owners.

Confirmed, same here and agree to the mysterium on how NikC versions are labeld by DXO. Same with the updating process, or how to check if the version is up to date at all.

That’s because the Nik Collection, itself, has its own version number (currently Nik v4) - whereas, the various components therein have their own version numbers – eg. SEPv3, CEPv4, AEPv2, etc

If all components had received the version #4 then we’d be wondering what were the enhancements made to, say, AEPv2 - when, for this upgrade, there are none.

John M

1 Like

Downloaded the Nik 4 trial and the installation fails with this message:
(System is Windows 10 x64)

Error 0x80070643
There is a problem with this Windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.


Thank you. Now I get it. I was looking Silver Efe Pro 4.

My upgrade for NIK 4 will not start installing. Clicking the file is fully dead.
If I open the file as system administrator, it will go to the first step asking “do you allow to make changes in your system?” After that, it is all dead.

I have downloaded the file several times but always the same result.

The updating of PL4 went fully successfully jus the other day.

WIN 10 64, latest version (I suppose).


I have the same problem.

1 Like

I have the same problem, I tried to download it several times and also on other PCs. Even as a manager. The installation file will not start. And the support totally ignores me. I want to work, but like when I can’t.


Installer can’t run. Nothing happen after double click.

Win 10 (21H1)
Intel i3-6100
DDR3 24gb
Nvidia GFX 650

1 Like

I made a ticket and DxO responded quickly saying they are on it and they will solve the issue asap.
The solution is on the way!


I received a message from support that they were dealing with it.

Me, too.

Windows 10 (20H2)
Intel i9-10885H
Nvidia Quadro RTX 3000

@klasal @Hofver @Eugen @jcoahgne @jhammerstad
There is an issue with supporting some Win OS languages during the installation. It means that for some languages the installation could not start. So if you are not using English, please, try a workaround:

  1. Change OS language to English
  2. Reboot PC
  3. Install Nik 4 (it should be fine)
  4. Chnage OS language to which you used to use

The fix would be in the minor release, but this workaround might help now.

1 Like

That might explain why, as an English speaker, I have had no issues installing and using Nik 4 from within PhotoLab 4 Elite on my Windows 10 machine.


1 Like

It is a workaround :slight_smile: But not for me. Just fix it asap. No hard feelings.

1 Like

Same with me. I unzipped the exe-file with PowerArchiver. There are only data files (0, u1,u2 and so fort). No install or setup executable. Completely different from the nik3 inst-file.

It does not explain my issue. My software is English only.
(DxO does not even have a Finnish language version.)

I hope any correction will arrive asap!

I am not going to do that.
If this is actually the case, this gives me very troubled feelings about the software development.
And making us wait until July for a fix essentially cuts out any non-english Windows user - it that really company policy?

1 Like

It is a temporary fix while the bug is being addressed. Change the language to English, install the software, and once installed change the language back to whatever you choose.