Nik 4 won't install

Why are we paying to be their Beta Testers?

Seriously, this makes the DXO folks look unprepared, disorganized, and/or incompetent.

2 Likes

I realize that it’s frustrating, but there’s no need to get nasty. They’re working on it and will get the fix to you as soon as is humanly possible.

1 Like

You are not expected to be a beta tester. It’s new software and they discovered a bug which they are addressing. All software by every vendor has bugs that were not caught during testing. It’s a fact of life. You can either try the work around to get Nik up and running now or you can wait for an official fix. Its up to you.

Mark

1 Like

Oh, come on… It’s a bug, sure. But bugs that occur in installation and activation should be caught in beta testing or earlier. Seriously, isn’t that a major part of what Beta Testing is for.

Also, I have a separate and distinct problem from the one discussed above. I purchased the upgrade to FX4. My account info shows the invoice and order numbers for that purchase. But the My Software section is inexplicably unaware of that fact. It keeps trying to sell me an upgrade that I have already purchased. And, just to make things really fun, I’ve received no activation codes - by email or on the site. The confirmation email even states expressly, right at the top, that the activation codes are below, in the body of the email… but they’re not.

Again, these are the types of issues that should be caught well before an official, major upgrade release. (Which also turns out not to be such a major upgrade, since many of the apps within the suite are unchanged and untouched, still suffering from longstanding bugs that should be relatively easy to fix.)

EDIT:
Suddenly, I’m unable to log in to the main site. Whenever I try, it says, “The account sign-in was incorrect or your account is disabled temporarily. Please wait and try again later.”

I’m fairly confident that my password manager did not suddenly forget my password, so should I take it that my account has been disabled? WTF is going on here?

1 Like

“…there’s no need to get nasty…”

I’m not being “nasty.” I’m merely the bringer of bad news. I mean, I want all of this to work like it should. Or, if issues arise, I want to see prompt replies from people who are working on those problems. When those things happen, it fosters confidence in customers that things are being well-run at this company.

And when those things don’t happen…

When you roll out a major release, only to have lots of people unable to properly use your software due to issues that absolutely should’ve been caught long before release day, then it doesn’t look good from the outside.

It looks like corners are being cut; robust beta testing is being put off (or cancelled?); lots of money being rushed into promoting the release, instead of taking the time to really get it right.

Those sorts of things simply do not inspire confidence in (potential) customers that matters will be promptly and vigorously dealt with.

Not trying to be “nasty.”

Just being honest.

I’d much rather be able to say that everything was running smoothly and that the improvements were even better than I’d hoped.

But. That. Is. Simply. Not. The. Case.

Welcome to the forum, Matt.

I’m as confident as I can be that this is certainly not the case - I’ve never found DxO to be vindictive … on the contrary, they go out of their way to solve all serious issues - and I am confident they’re working on a solution to this problem, as it impacts you, as we “speak”.

I just encourage you to “hang in there” …

John M

PS. Another thought, in case it’s not clear: This is a user forum - tho, it is monitored by DxO staff … but, for specific DxO support, see here.

Hi,

I’m sorry, but I found one bug after installation. After switching back to the Czech language, the icons on the control panel began to disappear. I had to give a restore point before installing and it was fixed. Something has changed during the change and the same installation. So I had to uninstall it and drop it. I’ll wait for the right file. You should extend the upgrade action until the end of the correct release. How do I buy i

I just did that…for DXO!
And…
Untitled
Untitled2

So…i downloaded the trial install exe again…and…
Untitled3

So this whole DXO thing is a joke (+a piece of shit)… :man_shrugging:

I have also trouble to install. The program file just does not answer properly (i.e. at all). Making myself an administrator to run it, Windows asks me if I allow it, I answer yes, and then once again nothing happens. The version number is 4.0.7.

My Windows Pro 10, version 21H1, and everything else in this computer, bought as late as in January, are the latest downloadable versions and technologies available (very close at least, including a graphics card of the latest Nvidia Geforce 3000-series). Nothing else gives me trouble in this computer. The latest DxO PhotoLab 4 update worked flawlessly etc. So why this?

It seems to be very high time to get that update released that makes everything work as expected! Nothing else is what I have experienced from DxO earlier.

Hi Staffan - - See here.

John M

What is your language setting? Svensk ?

Then change to English (United States) > log off and on and start the installer > Install > Change back to Svensk > log off and on again and start the program you use NIK4 in

What is your language setting? English (Australia) ?

Then change to English (United States) > log off and on and start the installer > Install > Change back to English (Australia) > log off and on again and start the program you use NIK4 in

Yesterday I got the fix from DxO, deleted all old versions of NIK and installed the new. Now the installation went well!
I have yet not used the new NIK4 but look forward to do so.
So far, all good!

1 Like

I as well can not install Nik collection 4. 1-year-old windows 10 machine, US English, upgrading from Nik 3; installation freezes at the welcome screen, the Cancel and next buttons are both greyed out, but cancel works. Next does nothing. I have uninstalled Nik 3 hoping that would help, but no, still freezes at the welcome screen. Not sure how to proceed.