MBP14 M2Max Crashs Whole Laptop

I have narrowed down an issue with using PhotoLab6 and a new MBP 14 with M2 Max chip.

If one uses either the CPU or GPU to export a batch of photos greater than one image, the whole laptop crashes to a black screen and no power, one can not even press the power button to restart unless one uses the AC wall adaptor first and the restart the computer.

I have gone to the Apple store and had the firmware updated, and that did not fix the problem.

I have narrowed down my issue to using DxO PhotoLabs6 and using either the CPU or GPU only settings. If I use the Nueral Engine to export photos with, then the software does not crash the whole computer and exports all the images in a batch export just fine.

Wanted to let you all know there is a bug that has originated in the software within the last week or so since the latest update was installed.

I even tried uninstalling and reinstalling, but the same issue occurs when on battery power and using only the CPU or GPU only settings for exporting photos.

Hope this bug can be fixed.


1 Like

Hi, have you already tried it with the new Ventura 13.3 release from last Monday?

Regards, Rob

I can’t believe a PhotoLab bug could cause that. Rather, it seems your battery and power management aren’t able to handle the workload. It might be a hardware problem (e.g., insufficient voltage to a component) - but you should make sure the OS update doesn’t solve it.

1 Like

This forum is a user forum, DxO rarely participate. If you belive this to be a reproducible bug then you should report it to DxO here:

I should note too that I have used my MBP14 M2Max for 2 months without issue and a M1 MBP for a year or so with the latest DxO Labs software with no issues, this error/issue started after I updated to the latest version of DxO PhotoLabs6.

Thanks again for the link, will handle directly with DxO. DxO even has an issue with using the nueral engine in the apple silicon right now, its noted in the settings menu currently. It is funny though that the Nueral Engine is the only processor that is working for me right now.

The Apple Store ran full diagnostics on my hardware and it passed without issue. No other software produces this crash, and currently it is reproducable with CPU or GPU only processing on a M2 Max Chip.

Thank you for the details. I was supprised that the software is the issue, but it is the current single point of failure that occurs repeatably with this issue.

Will work this one with the DxO Support team.

Yes, tried with the latest software and was running Ventura for 2 months without issues until Sunday when I updated DxO Labs.