[Mac]Photolab 2: "This image cannot be processed because of an unknown error. It may be corrupted or in an unsupported format"

I recently purchased a Nikon Z6 with 24-70mm F/4 lens. I transferred the images that I had taken in various days out to my iMac and put them into named folders. I wanted to process them recently so I opened up Photolab 2 2.2 and searched for my Z6 folder, they all showed up but only one of them showed any images. The DxO module for my camera/lens downloaded and they look great. However the other photos taken with the same camera/lens combination gives the following error:

This image cannot be processed because of an unknown error. It may be corrupted or in an unsupported format.

So I tried opening these same images in the following software: Luminar 3, Aurora HDR 2018, Nikon Capture NXi/NX-D and Affinity Photo. All of these opened fine! So, I copied some of these unsupported images to my Macbook Pro and opened them in Photolab 2 without any problems. There is nothing wrong with the files.

So I went back to my original iMac folders and deleted every sidecar file. Still the same problem!

Has anyone experienced this strange file behaviour with PhotoLab 2 and if so, what is the fix? I haven’t opened a support call as I’d like a prompt solution rather than a “we’re working on it” reply.

P.S. Since opening the file in Nikon Capture NX-D I noticed that there are now NIK type local corrections (control points) provided in this software. This enabled me to process my images without Photolab 2, similar to when I could use Capture NX2. Bonus!!!

Are you running macOS 10.11 on your iMac?
PL2 requires one of the last three macOS versions 10.12-14.
Could that be what’s causing the problems?

I’m running 10.14.3 I’ve even deleted the camera/lens profile and re- downloaded it. :cry:

I had the same issue on my Mac with OS X 10.14.3. I renamed the folders containing the images and it resolved the issue for me.

Did you change the names that way that you did avoid special characters?

No. I simply added a “v2” to the folder name e.g changed 1-2019 to 1-2019v2. That did the trick for me

I have added a space to the top tier folder (Z6 to Z 6) and it now all works. This must be a DAM error, hopefully someone from DxO will pick this up and get it sorted. Thanks for providing the solution :grinning::grinning::grinning::grinning::grinning:

What happens if you change back the name now to the old one - still works?

When I changed it back to the original Z6 they all continued to be recognised! Where does the problem lie?

PhotoLab 2.1.2 seems to work fine on El Capitan (10.11.6). I would be very unhappy to see DxO drop support for 10.11 for the next couple of years. All my work computers are on 10.11 which is stable and fast and reliable and doesn’t have any changes to the file system. I understand that Apple makes it difficult for developers to support more than current OS + 2 back, but forcing DxO users to update (Apple OS updates are not upgrades any more) to use PhotoLab would show a lack of respect for users’ time.

Give what we pay for PhotoLab I’d hope that DxO will respect our time.

This is not “DAM error”, whatever that should mean. I saw the same issue sometimes in PL1, especially when moving pictures to a folder currently opened in PL.

The workaround has been described: rename the picture or the folder. That forces PL to reread the file and it doesn’t match it to its internal database/cache anymore.

To avoid it in the future do not copy pictures into a folder currently visible in PL.

I believe the root cause it that PL tries to read the file before it has been completely written. Then it remembers the file as broken.

1 Like

I reckon this is probably due to the image-name being held in the PL Database file - but with different associated folder-location info from its current actual location.

Try deleting the database file (assuming you use Sidecar files and, therefore, don’t care about the database). See the General tab on Edit/Preferences for the location of the database file(s).

Regards, John M

The scenario you suggest of not putting files into existing folders is absurd. If I put my Spitfire images into a folder called Spitfires, then take more photos of them, where do you think I’d be wanting to put them? This only happens with PhotoLab so it is a problem with the software. The fact that no image was in an un-recognised format, nor corrupted, shows that something is wrong with the way PhotoLab is managing the folders. To rename it then rename it back again just so their database can work is not a viable work-around long term. Perhaps someone from DxO would like to step in here and comment?

1 Like

So whatever you are not doing is absurd? I shoot when I shoot, I edit pictures when I edit pictures. Before I edit pictures I copy the RAW files. Only then I start PL. Is this absurd?

That’s exactly what I did as well, we both work the same way. However, to not copy new RAW files into an existing folder with the same subjects, before editing them, is what I disagree with. For that folder to be un-recognised afterwards is a PhotoLab problem, every other software program can see them perfectly. I do not want 20+ “Spitfire” folders on my computer just so that PhotoLab can see them, I want one folder that I put my “Spitifre” images into. Now imagine every other aircraft type, insect, animal, landscape etc. that could have their own named folders; keeping multiple folders for each subject would be too much to manage.

1 Like

I am not sure if I understood it right, but what I did. I opened a folder in PL2 and while those images are shown in the image browser, I dropped another picture into the folder and the image browser just updated and showed this picture too. So for me here no problem.
I also already have pictures destination open in PL 2 while importing from my card with Nikon Transfer 2. Never a problem. The pics just appear while being imported.

If I understand above correctly then there must be another issue. I have never had problems of files appearing in DXO when I added new files into an existing folder.

I have not yet tried to import any new files into an existing folder, I commented that not to do so would be un-workable. However, the original start to this thread was because all sub-folders in my Z6 folder were not recognised by PhotoLab until I renamed the folder. This is the problem that I encountered. It seems like a PhotoLab database problem as no other software has a problem. Once renamed the sub-folders were fully recognised so there is no errors in the image files.

Peter - Your observation reinforces my suspicion - - Did you see this post ?

Regards, John M

Thanks John, I’ve seen your post and done it.