Mac OS Monterey Photoshop and NIK Collection

Hi, I recently upgraded to Mac OS Monterey and now when I am editing images in Photoshop and refine in NIK Collection, the program quits, or crashes. Does anyone know if there is an upgrade or fix, from DXO side of things? I am running DxO PhotoLab 4 Elite, Nik Collection 3, and DxO ViewPoint 3. I recently also upgraded to Photoshop 2022. Running on iMac (Retina 5K, 27-inch, 2017), 3.5 GHz Quad-Core Intel Core i5. Thanks for any insight someone might have I have left a message for Apple, Photoshop. Thanks



A couple of comments:

Which program crashes?

Have you thought of simplifying your workflow and just using PhotoLab? With FilmPack and ViewPoint integrated into the one app, it can do most of what you are trying to achieve without losing the ability to go back to the original RAW at any time, without losing any subsequent non-RAW edits.

Hi Joanna, Thanks for your reply. I open all my images in PhotoLab 4, but like to work with Smart filters in Photoshop, in case I want to tweak the image later in NIK. Silver Efex, Viveza, Color Efex. It does not seem to matter. I can edit a few images no problems. But seems to be intermittent, on what program and at what stage. Now I just save right away, so if it crashes I at least can get back to it. Thanks again.

I suggest you try out PL5 because we now have Control Lines, which can act in much the same way as smart filters, in that they can cover the entire image and allow you to select parts of the image based on either a chroma or luma value.

You might like to consider that, with PL5, with FilmPack and View Point integrated, you may not need to keep on round-tripping since most of the Nik Collection functionality is possible in the one app.

I would also suggest that you show us an example of where and why you would use a smart filter in PS, and maybe we will be able to find the best way to do the same thing in PL?

Madness. There is a technical problem with one user and under circumstances with others and instead of a solution here the use of control lines is suggested and the previous process to forget. This is just ridiculous. Why buy an upgrade, with DXO’s phobia of Apple?

1 Like

@JanD asked a question about Nik collection in a PhotoLab group so it can be assumed that PhotoLab is also involved in the process. Also Jan is only running PL4, so may not be aware that there are now other solutions for a complicated workflow.

Lots of things are breaking whilst Monterey is so new and, until they are fixed, it may be that Jan needs an alternative.

And DxO are sticking their head in the sand over it.
They are aware there are issues with Monterey such as DeepPRIME discussed elsewhere yet nowhere does it state that Monterey causes issues with PL or as the case may now be NIK.
In fact the system requirements page states that Monterey is supported. No where does it state that the support may only be partial at present.

Happy to take peoples money and let them run into issues afterwards. Issues they seem to be aware of regardless of who the blame lies with. Be that DxO or Apple.

1 Like

If you take the time to look, you will find that DxO is not the only software to be experiencing problems with Monterey. A quick search found that both Adobe and Affinity products also have problems - I didn’t look any further but I think you will find it is very difficult for any software house to get it right when the underlying OS is still effectively in beta.

In which case I would level the exact same criticism at those companies if they are also failing to make potential customers aware of issues they can possibly expect to encounter.

Personally I’ve only so far had issue with DxO although Affinity Photo took a lot longer to process a pano the other day which may or not be related.

Ultimately I just feel there should be a disclaimer that Monterey ‘may’ break some functionality and then it’s ultimately up to the individual to update the OS or not and indeed hold off purchasing even.

I share your problems do you know if there’s a way to switch back to Big Sur man it was so much easier no problems at all now all I do is drive myself crazy doing in a Rubiks cube of combinations in an attempt to just get the darn deep prime to work it sucks to because it worked well for me for about 8 to 10 months and I think my mind kind of came to expect it and then boom out of nowhere I download that stupid new Apple software and like you said if I had any indication at all that the stupid Monterey even if there’s like a 5% chance that something would go wrong I wouldn’t of updated it… My troubleshooting skills are lousy enough I don’t need to worry about stuff like this

1 Like

I don’t know if you can switch back and tbh for me even with the issues I am having with DeepPRIME I still wouldn’t revert but for me everything else I need to use be that PL5 based or something else are working perfectly fine under Monterey.

However, I wouldn’t have initially upgraded had I know it would ‘break’ PL5 and it hasn’t brought enough that I couldn’t have waited in fairness.

Apple are seeding a new version to developers and those brave/stupid enough to do the public beta on their machines so hopefully something is coming soon plus DxO (or at least a staff member) have stated on another thread that a possible solution exists but they need word from Apple first to see if its worth their time when a fix may be incoming from Apple anyway.

Although having said that. I wonder if DxO have tested the newest Beta 12.1 to see if it fixes the issue(s).

I have a MBP 16" M1Pro with Monterey 12.3 installed.
I continue to experience a lot a of issues with using modules of Nik Collection 4 by DXO as plugins of LRC.
So, tired with these bugs I uninstalled my DXO products, PL5 and NIK, except PR.
When do you think publishing native Apple Silicon PL5 and NIK ?
Thank to understand my displeasure with DXO Products, even I am a DXO user since DXO Optics Pro 3 …

What issues do you get? I have DPL, Nik, PR on my M1 MacBook Air next to LrC and things worked and work as expected on macOS Big Sur as well as Monterey.

If you reinstall DxO’s products and come across issues again, detailed issue descriptions can help to find the possible causes of those issues.

Thanks for your reply.
First of all, I already several times uninstalled and installed NIK on my MBP. Each time I get the same issues.
Then when I use NIK collection inside PL5, all works fine. But it is not my main usage.
Keep in mind I use essentially NIK as LRC plugins.
So I select a RAW on LRC and right-click to select « Modifier dans », then I select Silver Efex. Next I valid the pop-up and then generated TIFF is opened in the module silver-Efex.
I do some changes and register it. At this stage, the TIFF has to open in LRC. Sometimes it works sometimes no.
Now imagine it works. I select a second RAW to modify it in the same NIK plugin.
In this case first the plugin freezes then LRC crashes.
Not cool isn’t it ?

Agreed, this is uncool. I still don’t remember having had such an issue so far…therefore I tested again (I don’t use Nik apps that often)

  • Downloaded a fresh installer (Nik Collection 4.3.4, according to what the installer advertises)
  • Installed it on my iMac 2019 running macOS Big Sur 11.6.5
  • Tested with a few images, one after the other

Observations I made when testing with Lightroom Classic 11.2

  • LrC takes a fairly long time (several seconds) before even the progress bar appears
  • LrC CPU load is fairly high at 180%, in view of “nothing happening”
  • After several seconds (and this delay increased with every image), the tiff appears
    and Silver Efex launches
  • Saving changes in SFX brings back the results to LrC in a second or two
  • 4 images later, LrC runs at around 700%, but I cannot see anything happening…
  • When I display the 4 images side by side in LrC’s compare view, the last image displays some flickering, sign of LrC doing something. Tried to screen record that flickering, but it then stopped.

Test with Photoshop 23.2.2

  • Everything worked as expected

My conclusion

  • Something is not right in cooperation between LrC and SFX (have not tested other apps)
  • Looks like a new thing that I’ve never had with previous versions of
    macOS, Nik and LrC ← all have changed since my last tests
  • If I get ill effects on Big Sur, the quirk is not limited to macOS Monterey